summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-04-27 17:31:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-04-27 17:48:50 +0200
commit8d65eae52a95b4267b79a54adf2a24ec63a4f5b9 (patch)
tree4b27da36ba869d5aef4850be9d77b5d0c5403830
parentkde-apps/k3b: Inline virtual/cdrtools (diff)
downloadkde-sunset-8d65eae52a95b4267b79a54adf2a24ec63a4f5b9.tar.gz
kde-sunset-8d65eae52a95b4267b79a54adf2a24ec63a4f5b9.tar.bz2
kde-sunset-8d65eae52a95b4267b79a54adf2a24ec63a4f5b9.zip
dev-qt/qtsql: Drop IUSE=oci8
Missing KEYWORDS Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtsql/qtsql-4.8.7-r1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-qt/qtsql/qtsql-4.8.7-r1.ebuild b/dev-qt/qtsql/qtsql-4.8.7-r1.ebuild
index 6fa5a880..2d1d3873 100644
--- a/dev-qt/qtsql/qtsql-4.8.7-r1.ebuild
+++ b/dev-qt/qtsql/qtsql-4.8.7-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
inherit multilib qt4-build-multilib
DESCRIPTION="The SQL module for the Qt toolkit"
@@ -10,17 +11,16 @@ if [[ ${QT4_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc x86"
fi
-IUSE="freetds mysql oci8 odbc postgres qt3support +sqlite"
+IUSE="freetds mysql odbc postgres qt3support +sqlite"
REQUIRED_USE="
- || ( freetds mysql oci8 odbc postgres sqlite )
+ || ( freetds mysql odbc postgres sqlite )
"
DEPEND="
~dev-qt/qtcore-${PV}[debug=,qt3support=,${MULTILIB_USEDEP}]
freetds? ( dev-db/freetds )
mysql? ( dev-db/mysql-connector-c:=[${MULTILIB_USEDEP}] )
- oci8? ( >=dev-db/oracle-instantclient-basic-11.2.0.4[${MULTILIB_USEDEP}] )
odbc? ( || (
>=dev-db/unixODBC-2.3.2-r2[${MULTILIB_USEDEP}]
>=dev-db/libiodbc-3.52.8-r2[${MULTILIB_USEDEP}]
@@ -38,12 +38,12 @@ multilib_src_configure() {
local myconf=(
$(qt_native_use freetds sql-tds plugin)
$(qt_use mysql sql-mysql plugin) $(use mysql && echo -mysql_config "${EPREFIX}/usr/bin/${CHOST}-mysql_config")
- $(qt_use oci8 sql-oci plugin) $(use oci8 && echo "-I${ORACLE_HOME}/include -L${ORACLE_HOME}/$(get_libdir)")
$(qt_use odbc sql-odbc plugin) $(use odbc && echo "-I${EPREFIX}/usr/include/iodbc")
$(qt_native_use postgres sql-psql plugin) $(use postgres && multilib_is_native_abi && echo "-I${EPREFIX}/usr/include/postgresql/pgsql")
$(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo -system-sqlite)
-no-sql-db2
-no-sql-ibase
+ -no-sql-oci
-no-sql-sqlite2
-no-sql-symsql
$(qt_use qt3support)