summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 20:36:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-07 20:36:37 +0100
commit46321c8d541261ea510237c085fabffdba577ada (patch)
tree55120e2fb733d8f6f73e7a5f4d7ea06c0ac93c0f
parentmedia-sound/hydrogen: Remove unbuildable package, thank you SCons! (diff)
downloadkde-sunset-46321c8d541261ea510237c085fabffdba577ada.tar.gz
kde-sunset-46321c8d541261ea510237c085fabffdba577ada.tar.bz2
kde-sunset-46321c8d541261ea510237c085fabffdba577ada.zip
sys-kernel/kccmp: EAPI-7 bump, switch to qmake-utils
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--sys-kernel/kccmp/kccmp-0.3.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/sys-kernel/kccmp/kccmp-0.3.ebuild b/sys-kernel/kccmp/kccmp-0.3.ebuild
index fecfe441..2e0db32a 100644
--- a/sys-kernel/kccmp/kccmp-0.3.ebuild
+++ b/sys-kernel/kccmp/kccmp-0.3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-inherit qt4-r2
+EAPI=7
+
+inherit qmake-utils
DESCRIPTION="A simple tool for comparing two linux kernel .config files"
HOMEPAGE="http://stoopidsimple.com/kccmp/"
@@ -13,15 +14,20 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="dev-qt/qtcore:4
+DEPEND="
+ dev-qt/qtcore:4
dev-qt/qtgui:4"
RDEPEND="${DEPEND}"
src_prepare() {
- qt4-r2_src_prepare
+ default
echo "DEFINES += KCCMP_QT_4" >> ${PN}.pro
}
+src_configure() {
+ eqmake4
+}
+
src_install() {
dobin kccmp
dodoc README