aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@fordfrog.com>2015-10-24 15:24:26 +0200
committerMiroslav Šulc <fordfrog@fordfrog.com>2015-10-24 15:24:26 +0200
commit528f48cffd1dcaabf2d8570409ffada7ea41ff8f (patch)
treefb96c2ba1a89f12ef880fcaacd6f7e6b0ff33961 /pom.xml
parentimplemented basic framework and documented functionality (diff)
downloadjava-ebuilder-528f48cffd1dcaabf2d8570409ffada7ea41ff8f.tar.gz
java-ebuilder-528f48cffd1dcaabf2d8570409ffada7ea41ff8f.tar.bz2
java-ebuilder-528f48cffd1dcaabf2d8570409ffada7ea41ff8f.zip
improved the framework
Diffstat (limited to 'pom.xml')
-rw-r--r--pom.xml16
1 files changed, 16 insertions, 0 deletions
diff --git a/pom.xml b/pom.xml
index bcf6bd2..c5ff753 100644
--- a/pom.xml
+++ b/pom.xml
@@ -10,4 +10,20 @@
<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>
</properties>
+ <build>
+ <plugins>
+ <plugin>
+ <groupId>org.apache.maven.plugins</groupId>
+ <artifactId>maven-jar-plugin</artifactId>
+ <version>2.6</version>
+ <configuration>
+ <archive>
+ <manifest>
+ <mainClass>org.gentoo.java.ebuilder.Main</mainClass>
+ </manifest>
+ </archive>
+ </configuration>
+ </plugin>
+ </plugins>
+ </build>
</project> \ No newline at end of file