aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/meson.build b/tests/meson.build
new file mode 100644
index 0000000..9192707
--- /dev/null
+++ b/tests/meson.build
@@ -0,0 +1,24 @@
+py_test_env = environment()
+tests_python_paths = [
+ meson.project_source_root(),
+ meson.project_source_root() / 'src',
+]
+py_test_env.append('PYTHONPATH', tests_python_paths)
+
+py_tests = [
+ 'EnvironmentManager',
+ 'Package',
+ 'VM',
+ 'VersionManager',
+ 'VersionManagerEnv2',
+ 'Virtual',
+]
+
+foreach py_test : py_tests
+ test(
+ 'python-unittest-' + py_test,
+ py,
+ args: ['-m', 'unittest', 'tests.testsuite.' + py_test],
+ env: py_test_env,
+ )
+endforeach