aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-11-15 10:34:47 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-11-16 16:52:54 +0100
commit54c5c9ebbf701f9dcd9f78da9f13ae967f922243 (patch)
treea7a3c43a8302ed18eccc909fcbd3de7093723be5 /meson.build
parentupdate deprecated test methods for python-3.12 compatibility (diff)
downloadjava-config-54c5c9ebbf701f9dcd9f78da9f13ae967f922243.tar.gz
java-config-54c5c9ebbf701f9dcd9f78da9f13ae967f922243.tar.bz2
java-config-54c5c9ebbf701f9dcd9f78da9f13ae967f922243.zip
Use Meson as build system
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..3dff1fd
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,38 @@
+project(
+ 'java-config',
+ version: '2.3.3-SNAPSHOT',
+ license: 'GPL-2.0',
+ meson_version: '>=1.1.1'
+)
+
+py_mod = import('python')
+py = py_mod.find_installation(pure : true)
+
+system_wide = get_option('system-wide')
+python_only = get_option('python-only')
+
+eprefix = get_option('eprefix')
+datadir = get_option('datadir')
+
+sysconfdir = system_wide ? get_option('sysconfdir') \
+ : datadir / 'etc'
+
+conf_data = configuration_data({
+ 'VERSION': meson.project_version(),
+ 'EPREFIX': eprefix
+})
+
+subdir('src')
+subdir('tests')
+
+if python_only
+ subdir_done()
+endif
+
+subdir('config')
+
+if not system_wide
+ subdir_done()
+endif
+
+subdir('man')