aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOndrej Mosnacek <omosnace@redhat.com>2019-05-22 09:00:23 +0200
committerJason Zaman <jason@perfinion.com>2019-07-13 14:43:14 +0800
commit38107cc3d4864c0436c40e44016b66533fcde6ed (patch)
tree341c1deccf78c0896ff42c2bb8458e506fe3149b /Makefile
parentlogrotate: Make MTA optional. (diff)
downloadhardened-refpolicy-38107cc3d4864c0436c40e44016b66533fcde6ed.tar.gz
hardened-refpolicy-38107cc3d4864c0436c40e44016b66533fcde6ed.tar.bz2
hardened-refpolicy-38107cc3d4864c0436c40e44016b66533fcde6ed.zip
Fix find commands in Makefiles
Without this fix, building a custom module in a directory that contains a file with special characters in its name (e.g. '(') triggers a syntax error: $ cat >foo.te <<EOF module foo 1.0; require { class file entrypoint; type shell_exec_t; type vmtools_unconfined_t; } allow vmtools_unconfined_t shell_exec_t : file entrypoint; EOF $ touch "my broken (file)" $ make -f /usr/share/selinux/devel/Makefile foo.pp /bin/sh: -c: line 0: syntax error near unexpected token `(' /bin/sh: -c: line 0: `find anaconda-ks.cfg my broken (file) vncserver.strace systemd.strace rhel-server-7.6-x86_64-boot.iso rt_minimal.c vnc.cil foo.te rsyslog tmp virt-install.log evil_banner.sh livemedia.log program.log foo.if rhel7-minimal.ks TestZip.java TestZip.class foo.fc sudoloop foo.pp strace.log -maxdepth 0 -type d' Link: https://bugzilla.redhat.com/show_bug.cgi?id=1692676 Reported-by: Renaud MĂ©trich <rmetrich@redhat.com> Suggested-by: Petr Lautrbach <plautrba@redhat.com> Signed-off-by: Ondrej Mosnacek <omosnace@redhat.com> Signed-off-by: Jason Zaman <jason@perfinion.com>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index dba38fc45..28bc1a52f 100644
--- a/Makefile
+++ b/Makefile
@@ -261,9 +261,9 @@ user_default_contexts_names := $(addprefix $(contextpath)/users/,$(subst _defaul
appfiles := $(addprefix $(appdir)/,default_contexts default_type initrc_context failsafe_context userhelper_context removable_context dbus_contexts sepgsql_contexts x_contexts customizable_types securetty_types lxc_contexts openrc_contexts virtual_domain_context virtual_image_context) $(contextpath)/files/media $(fcsubspath) $(user_default_contexts_names)
net_contexts := $(builddir)net_contexts
-all_layers := $(shell find $(wildcard $(moddir)/*) -maxdepth 0 -type d)
+all_layers := $(shell find $(moddir)/* -maxdepth 0 -type d)
ifdef LOCAL_ROOT
-all_layers += $(shell find $(wildcard $(local_moddir)/*) -maxdepth 0 -type d)
+all_layers += $(shell find $(local_moddir)/* -maxdepth 0 -type d)
endif
generated_te := $(basename $(foreach dir,$(all_layers),$(wildcard $(dir)/*.te.in)))