aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg (Zorry) <zorry@gentoo.org>2010-04-13 00:24:45 +0200
committerMagnus Granberg (Zorry) <zorry@gentoo.org>2010-04-13 00:24:45 +0200
commit26f5fe1212d6f03d2e29bcb92dfd711fe5b55de9 (patch)
treea775eab5c632cbf9624bb272cf5201703a4e5f7a
parentUpdated the todo file (diff)
downloadhardened-gccpatchset-26f5fe1212d6f03d2e29bcb92dfd711fe5b55de9.tar.gz
hardened-gccpatchset-26f5fe1212d6f03d2e29bcb92dfd711fe5b55de9.tar.bz2
hardened-gccpatchset-26f5fe1212d6f03d2e29bcb92dfd711fe5b55de9.zip
Updated the espf-gcc-4.3.4 with changelogs stuff.
-rw-r--r--espf-gcc-4.3.4/10_all_gcc43_configure.patch12
-rw-r--r--espf-gcc-4.3.4/20_all_gcc43_gcc.c.patch14
-rw-r--r--espf-gcc-4.3.4/README.Changelog21
-rw-r--r--espf-gcc-4.3.4/README.history137
4 files changed, 84 insertions, 100 deletions
diff --git a/espf-gcc-4.3.4/10_all_gcc43_configure.patch b/espf-gcc-4.3.4/10_all_gcc43_configure.patch
index a981092..382b1fe 100644
--- a/espf-gcc-4.3.4/10_all_gcc43_configure.patch
+++ b/espf-gcc-4.3.4/10_all_gcc43_configure.patch
@@ -1,15 +1,17 @@
-2009-09-20 Magnus Granberg <zorry@ume.nu>
+2010-04-10 Magnus Granberg <zorry@gentoo.org>
* configure Add --enable-espf. Add-fno-stack-protector
to stage1_cflags.
- * gcc/configure.ac Check -z now and -z relro.
+ * gcc/configure Check -z now and -z relro.
Check if we support FORTIFY_SOURCES level 2.
Define ENABLE_ESPF.
- Check if we support crtbeginTS and define ENABLE_CRTBEGINTS.
- * libmudflap/configure.ac Add AC_SUBST enable_espf.
+ * libmudflap/configure Add AC_SUBST enable_espf.
On Gentoo
- * gcc/configure We don't need to check for FORTIFY_SOURCES support
+ * gcc/configure We don't need to check for FORTIFY_SOURCES support.
+ Check if the compiler support -fstack-protector and define HAVE_GCC_SSP.
+ Check if we support crtbeginTS and define ENABLE_CRTBEGINTS.
+ Add AC_SUBST enable_crtbeginTS.
--- configure 2009-04-29 01:16:59.000000000 +0200
+++ configure 2009-07-21 18:45:41.000000000 +0200
diff --git a/espf-gcc-4.3.4/20_all_gcc43_gcc.c.patch b/espf-gcc-4.3.4/20_all_gcc43_gcc.c.patch
index 62a1bac..cd6cc75 100644
--- a/espf-gcc-4.3.4/20_all_gcc43_gcc.c.patch
+++ b/espf-gcc-4.3.4/20_all_gcc43_gcc.c.patch
@@ -1,9 +1,8 @@
-2009-07-18 Magnus Granberg <zorry@ume.nu>
+2010-02-10 Magnus Granberg <zorry@ume.nu>
* gcc/gcc.c include: espf.h
+ *cpp_unique_options Add espf_cpp_unique_options.
#ifdef EXTRA_SPECS: Add ESPF_EXTRA_SPECS
- process_command(): Check for lazy, now, relro or norelro
- do_spec_1(): Add -z now and -z relro
main(): Add do_self_spec espf_command_options_spec()
2009-06-27 Matthias Klose <doko@ubuntu.com>, Kees Cook <kees@outflux.net>
@@ -14,15 +13,12 @@
* gcc/gcc.c default_compilers[] Add %(espf_options)
*cpp_unique_options Add %(espf_cpp_unique_options)
-2009-09-20 Magnus Granberg <zorry@ume.nu>
+2010-02-10 Magnus Granberg <zorry@ume.nu>
*gcc/gcc.c Gentoo changes
- static const char *cc1_spec We set that in espf.h
- *cpp_unique_options No need to use espf_cpp_unique_options
+ static const char *cc1_spec We set that in espf.h if ENABLE_ESPF.
+ *cpp_unique_options Remove espf_cpp_unique_options. (-D_FORTIFY_SOURCE=2)
*cc1_options Add espf_options_pie_check if ENABLE_ESPF.
- process_command(): check for -z relro -z norelro is no needed
- do_spec_1(): -z relro is default in binutils and
- espf_link_spec is added
--- gcc/gcc.c.zorry 2009-04-29 01:17:00.000000000 +0200
+++ gcc/gcc.c 2009-07-22 20:18:10.000000000 +0200
diff --git a/espf-gcc-4.3.4/README.Changelog b/espf-gcc-4.3.4/README.Changelog
index d20e92d..70ea74b 100644
--- a/espf-gcc-4.3.4/README.Changelog
+++ b/espf-gcc-4.3.4/README.Changelog
@@ -1,10 +1,27 @@
+0.3.8 Magnus Granberg <zorry@gentoo.org>
+
+ * gcc/configure Added a -fstack-protector check.
+ * gcc/config.in Added HAVE_GCC_SSP
+ * gcc/gcc.c Removed code for espf_link_spec in do_spec_1() %X
+ * gcc/espf.h Added ifdef HAVE_GCC_SSP, change code for espf_link_spec and link_pie_spec
+
+0.3.7 Magnus Granberg <zorry@ume.nu>
+
+ * gcc/gcc.c Remove code for Wl,-z,now check
+ * gcc/espf.h Change text for -z now
+
+0.3.6 Magnus Granberg <zorry@ume.nu>
+
+ * configure Check --enable-espf change ppc* to powerpc*, powerpc64 and add ia64.
+ * gcc/configure Don't check for -z,relro on ia64. Disable crtbeginTS for ia64.
+ * gcc/espf.h ia64 don't support -fstack-protector*
+
0.3.5 Maguns Granberg <zorry@ume.nu>
* gcc/espf.h Change the specs for crtbegin.TS.o.
* gcc/gcc.c Rename espf_cc1_options to espf_options_pie_check.
* gcc/config/linux.h Fix typos ENABLE_CRTBEGINS to ENABLE_CRTBEGINTS
- * gcc/config/rs6000/linux64.h ASM_SPEC32: %{fpic:-K PIC} %{fPIC:-K PIC} to
- %{fpic|fPIC|fpie|fPIE:-K PIC}
+ * gcc/config/rs6000/linux64.h ASM_SPEC32: %{fpic:-K PIC} %{fPIC:-K PIC} to %{fpic|fPIC|fpie|fPIE:-K PIC}
0.3.4 Magnus Granberg <zorry@ume.nu>
diff --git a/espf-gcc-4.3.4/README.history b/espf-gcc-4.3.4/README.history
index a2aa648..e8750e7 100644
--- a/espf-gcc-4.3.4/README.history
+++ b/espf-gcc-4.3.4/README.history
@@ -1,132 +1,101 @@
+0.3.8 10-04-2010
+ 10_all_gcc44_configure.patch
+ 11_all_gcc44_config.in.patch
+ 20_all_gcc44_gcc.c.patch
+ 30_all_gcc44_espf.h.patch
+
+0.3.7 10-02-2010
+ 20_all_gcc44_gcc.c.patch
+ 30_all_gcc44_espf.h.patch
+
+0.3.6 23-12-2009
+ 10_all_gcc44_configure.patch
+ 30_all_gcc44_espf.h.patch
+ README
+
0.3.5 24-09-2009
- - 30_all_gcc44_espf.h.patch
- + 30_all_gcc44_espf.h.patch
- - 20_all_gcc43_gcc.c.patch
- + 20_all_gcc43_gcc.c.patch
- - 35_all_gcc44_config_crtbegints.patch
- + 35_all_gcc44_config_crtbegints.patch
+ 30_all_gcc44_espf.h.patch
+ 35_all_gcc44_config_crtbegints.patch
+ 33_all_gcc44_config_rs6000_linux64.h.patch
- - README.Changelog
- + README.Changelog
- - README.history
- + README.history
+ README.Gentoo.patches
0.3.4 11-09-2009
- - 10_all_gcc43_configure.patch
- + 10_all_gcc43_configure.patch
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc43_gcc.c.patch
- + 20_all_gcc43_gcc.c.patch
+ 10_all_gcc44_configure.patch
+ 11_all_gcc44_config.in.patch
+ 12_all_gcc44_Makefile.in.patch
+ 20_all_gcc44_gcc.c.patch
- 23_all_gcc44_opts.c.patch
- - 30_all_gcc44_espf.h.patch
- + 30_all_gcc44_espf.h.patch
- + 35_all_gcc44_config_crtbegints.patch
+ 30_all_gcc44_espf.h.patch
+ 35_all_gcc44_config_crtbegints.patch
+ 60_all_gcc44_invoke.texi.patch
- - README.Changelog
- + README.Changelog
- - README.history
- + README.history
- - README
+ README
0.3.3 14-08-2009
- - 23_all_gcc44_opts.c.patch
- + 23_all_gcc44_opts.c.patch
+ 23_all_gcc44_opts.c.patch
0.3.2 09-08-2009
- + 50_all_gcc44_no_ssp_tls_uclibc.patch
+ 50_all_gcc44_no_ssp_tls_uclibc.patch
+ README.Changelog
+ README.history
- - 23_all_gcc44_opts.c.patch
+ 23_all_gcc44_opts.c.patch
- - 30_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
+ 30_all_gcc44-espf.h.patch
0.3.1 23-07-2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
+ 10_all_gcc44_configure.patch
0.3.0 23-07-2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
+ 10_all_gcc44_configure.patch
+ 11_all_gcc44_config.in.patch
+ 12_all_gcc44_Makefile.in.patch
+ 20_all_gcc44_gcc.c.patch
+ 40_all_gcc44_obj_lang-specs.h.patch
+ 40_all_gcc44_objp_lang-specs.h.patch
+ 40_all_gcc44_cp_lang-specs.h.patch
- 50_all_gcc44_gentoo_v20090614.1.patch
- - 30_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
+ 30_all_gcc44-espf.h.patch
0.2.9 14-06-2009
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 30_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
- - 50_all_gcc44_gentoo_v20090612.2.patch
+ 12_all_gcc44_Makefile.in.patch
+ 30_all_gcc44-espf.h.patch
+ 50_all_gcc44_gentoo_v20090614.1.patch
+ - 50_all_gcc44_gentoo_v20090612.2.patch
0.2.8 12-06-2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
+ 10_all_gcc44_configure.patch
+ 11_all_gcc44_config.in.patch
+ 12_all_gcc44_Makefile.in.patch
- 22_all_gcc44-toplev.c.patch
- - 25_all_gcc44-espf.h.patch
+ 30_all_gcc44-espf.h.patch
+ - 25_all_gcc44-espf.h.patch
+ 50_all_gcc44_gentoo_v20090612.2.patch
0.2.7 29-05-2009
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
+ 11_all_gcc44_config.in.patch
+ 12_all_gcc44_Makefile.in.patch
+ 20_all_gcc44_gcc.c.patch
+ 23_all_gcc44_opts.c.patch
- - 25_all_gcc44-espf.h.patch
- + 25_all_gcc44-espf.h.patch
+ 25_all_gcc44-espf.h.patch
- 30_all_gcc44-config-defaul-linux.patch
0.2.6 28-05-2009
+ 22_all_gcc44-toplev.c.patch
- - 25_all_gcc44-espf.h.patch
- + 25_all_gcc44-espf.h.patch
- - 30_all_gcc44-config-defaul-linux.patch
- + 30_all_gcc44-config-defaul-linux.patch
+ 25_all_gcc44-espf.h.patch
+ 30_all_gcc44-config-defaul-linux.patch
0.2.5 27-05-2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- - 25_all_gcc44-espf.h.patch
- + 25_all_gcc44-espf.h.patch
- - 30_all_gcc44-config-defaul-linux.patch
- + 30_all_gcc44-config-defaul-linux.patch
+ 10_all_gcc44_configure.patch
+ 12_all_gcc44_Makefile.in.patch
+ 20_all_gcc44_gcc.c.patch
+ 25_all_gcc44-espf.h.patch
+ 30_all_gcc44-config-defaul-linux.patch
- 40_all_gcc44-gentoo.patch
0.2.4 08-05-2009
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
+ 12_all_gcc44_Makefile.in.patch
0.2.3 08-05-2009
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- - 40_all_gcc44-gentoo.patch
- + 40_all_gcc44-gentoo.patch
+ 20_all_gcc44_gcc.c.patch
+ 40_all_gcc44-gentoo.patch
0.2.2 04-05-2009
+ 10_all_gcc44_configure.patch