summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-11-18 09:54:04 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-11-18 09:54:04 +0000
commite797f1d2b2c11d09def2e13e0888376c10ac56cb (patch)
tree68f08519d02d269491ced1d684e0fc1b6f5f7ecc
parentUpdate etoile-0.2 to allow newer versions (preparing for 0.4.0) (diff)
downloadgnustep-e797f1d2b2c11d09def2e13e0888376c10ac56cb.tar.gz
gnustep-e797f1d2b2c11d09def2e13e0888376c10ac56cb.tar.bz2
gnustep-e797f1d2b2c11d09def2e13e0888376c10ac56cb.zip
Add some base Etoile 0.4.0 frameworks
svn path=/overlay/; revision=379
-rw-r--r--gnustep-libs/coreobject/Manifest3
-rw-r--r--gnustep-libs/coreobject/coreobject-0.4.0.ebuild27
-rw-r--r--gnustep-libs/etoile-foundation/Manifest2
-rw-r--r--gnustep-libs/etoile-foundation/etoile-foundation-0.4.0.ebuild23
-rw-r--r--gnustep-libs/etoile-serialize/Manifest2
-rw-r--r--gnustep-libs/etoile-serialize/etoile-serialize-0.4.0.ebuild19
-rw-r--r--gnustep-libs/unitkit/Manifest2
-rw-r--r--gnustep-libs/unitkit/unitkit-0.4.0.ebuild16
8 files changed, 94 insertions, 0 deletions
diff --git a/gnustep-libs/coreobject/Manifest b/gnustep-libs/coreobject/Manifest
new file mode 100644
index 0000000..f2e5903
--- /dev/null
+++ b/gnustep-libs/coreobject/Manifest
@@ -0,0 +1,3 @@
+DIST etoile-0.4.0.tar.gz 8892225 RMD160 cf5396cdd2e4e8477f4ac1c493f814b862999a75 SHA1 3848ededa6f5f7981e208cea0c1833416b425e4c SHA256 785774e4697e7f1387d0c92c04886e6705d44272aeeb08ebd648871be5f5b59f
+EBUILD coreobject-0.4.0.ebuild 602 RMD160 ab842d90bf4ad0ce9f26158b1c05b6c462e6af7c SHA1 8e52877d72d4872b6a41709e7adefed2eee9c7fd SHA256 a316d555638f13ddaec5350b3a95ad7d384cf971ed4b9767ffd8fd55c35b9511
+MISC .coreobject-0.4.0.ebuild.swp 12288 RMD160 fa1fcf5ed228c39ab4316fc6a5b12752671501e0 SHA1 5554a504b4be64026cb49832b77934feef4ef36d SHA256 d127993cb02b270f9cea1de634b815dbffc19b7f8a4049491622620cf20fef0e
diff --git a/gnustep-libs/coreobject/coreobject-0.4.0.ebuild b/gnustep-libs/coreobject/coreobject-0.4.0.ebuild
new file mode 100644
index 0000000..fbcb189
--- /dev/null
+++ b/gnustep-libs/coreobject/coreobject-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Frameworks/CoreObject"
+
+DESCRIPTION="A framework for describing and organizing model objects"
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-db/libpq
+ gnustep-libs/etoile-serialize"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/Etoile-${PV}"
+
+ sed -i -e "s/-Werror//" etoile.make || die "sed failed"
+}
diff --git a/gnustep-libs/etoile-foundation/Manifest b/gnustep-libs/etoile-foundation/Manifest
index bfff441..a003c13 100644
--- a/gnustep-libs/etoile-foundation/Manifest
+++ b/gnustep-libs/etoile-foundation/Manifest
@@ -1,2 +1,4 @@
DIST etoile-0.2.tar.gz 21373391 RMD160 99aa05909469fc7ffae9118829a5f155050271c5 SHA1 9ecf33b0130687c1946da3eb7568605b5e9dfcbf SHA256 293cb9e5c50b27a8e38f16374c17595f20c5950ba44d00ffac3fb17ddd852d2c
+DIST etoile-0.4.0.tar.gz 8892225 RMD160 cf5396cdd2e4e8477f4ac1c493f814b862999a75 SHA1 3848ededa6f5f7981e208cea0c1833416b425e4c SHA256 785774e4697e7f1387d0c92c04886e6705d44272aeeb08ebd648871be5f5b59f
EBUILD etoile-foundation-0.2.ebuild 416 RMD160 43092f3bda36d29dff1e3734628bb949555e89ae SHA1 dd042890b3f7b9e085f112e798600f2df4d921d6 SHA256 c69d2271d42f94b8f849abb8668e33a9b3f476065c474c0c96da98bb149370af
+EBUILD etoile-foundation-0.4.0.ebuild 548 RMD160 6bc2dd60b183bde3feb8291a76f66fb5250ae532 SHA1 f03e9ffb003d28177a3f2ee8c55fd056aa92907a SHA256 34ceb2e25270f850f3ff5c00dc7ad9900d70476f377b6ec109bb0ddcdf366027
diff --git a/gnustep-libs/etoile-foundation/etoile-foundation-0.4.0.ebuild b/gnustep-libs/etoile-foundation/etoile-foundation-0.4.0.ebuild
new file mode 100644
index 0000000..6dc9a26
--- /dev/null
+++ b/gnustep-libs/etoile-foundation/etoile-foundation-0.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Frameworks/EtoileFoundation"
+
+DESCRIPTION="Foundation framework extensions from the Etoile project"
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/Etoile-${PV}"
+
+ sed -i -e "s/-Werror//" etoile.make || die "sed failed"
+}
diff --git a/gnustep-libs/etoile-serialize/Manifest b/gnustep-libs/etoile-serialize/Manifest
new file mode 100644
index 0000000..347c4b1
--- /dev/null
+++ b/gnustep-libs/etoile-serialize/Manifest
@@ -0,0 +1,2 @@
+DIST etoile-0.4.0.tar.gz 8892225 RMD160 cf5396cdd2e4e8477f4ac1c493f814b862999a75 SHA1 3848ededa6f5f7981e208cea0c1833416b425e4c SHA256 785774e4697e7f1387d0c92c04886e6705d44272aeeb08ebd648871be5f5b59f
+EBUILD etoile-serialize-0.4.0.ebuild 518 RMD160 ccec92c1f775d345cbcbd012d566be7c968893ad SHA1 9a1cba7acf958990da747ffd26043e936b1cb997 SHA256 71f63124652e9069fbdfb52b719278bd42d0350dc5d7538bf1fa474314565cc3
diff --git a/gnustep-libs/etoile-serialize/etoile-serialize-0.4.0.ebuild b/gnustep-libs/etoile-serialize/etoile-serialize-0.4.0.ebuild
new file mode 100644
index 0000000..bb73a46
--- /dev/null
+++ b/gnustep-libs/etoile-serialize/etoile-serialize-0.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Frameworks/EtoileSerialize"
+
+DESCRIPTION="Collection of classes that perform serialization and deserialization of arbitrary objects"
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="gnustep-libs/etoile-foundation"
+RDEPEND="${DEPEND}"
diff --git a/gnustep-libs/unitkit/Manifest b/gnustep-libs/unitkit/Manifest
new file mode 100644
index 0000000..7c771a6
--- /dev/null
+++ b/gnustep-libs/unitkit/Manifest
@@ -0,0 +1,2 @@
+DIST etoile-0.4.0.tar.gz 8892225 RMD160 cf5396cdd2e4e8477f4ac1c493f814b862999a75 SHA1 3848ededa6f5f7981e208cea0c1833416b425e4c SHA256 785774e4697e7f1387d0c92c04886e6705d44272aeeb08ebd648871be5f5b59f
+EBUILD unitkit-0.4.0.ebuild 398 RMD160 fd4c67cf7fa4f40cc570211637c49a96fd9ae670 SHA1 939a1be0ccdd5a20422e0b4e0b99fd275b283e85 SHA256 1db522ed3d9604ec23e83935d639f5e2c62e93bce8b76656dfdbcf75144aef74
diff --git a/gnustep-libs/unitkit/unitkit-0.4.0.ebuild b/gnustep-libs/unitkit/unitkit-0.4.0.ebuild
new file mode 100644
index 0000000..b7bac08
--- /dev/null
+++ b/gnustep-libs/unitkit/unitkit-0.4.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Frameworks/UnitKit"
+
+DESCRIPTION="Test framework for GNUstep"
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""