aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-12 21:43:17 +0000
committerSam James <sam@gentoo.org>2024-03-12 21:43:17 +0000
commit806d0cca43dfbdc124978381305361daf47677cb (patch)
tree659c0f4d67a2b7ce10d63b5efa8ffba36c32c313 /meson.build
parentci: enable new test option (diff)
downloadgentoolkit-806d0cca43dfbdc124978381305361daf47677cb.tar.gz
gentoolkit-806d0cca43dfbdc124978381305361daf47677cb.tar.bz2
gentoolkit-806d0cca43dfbdc124978381305361daf47677cb.zip
Revert "meson: make tests optional"
This reverts commit 988e47557368df49035eeba94beca893f7b267c1. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index b7b07c1..c3e83c5 100644
--- a/meson.build
+++ b/meson.build
@@ -39,10 +39,8 @@ endif
subdir('bin')
subdir('pym')
-if get_option('tests')
- pytest = find_program('pytest')
- test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
-endif
+pytest = find_program('pytest')
+test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
if get_option('code-only')
subdir_done()