summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-04-09 18:31:16 -0400
committerMike Gilbert <floppym@gentoo.org>2016-04-09 18:31:59 -0400
commit97e3616a927367df8a3d96379f06b73aac39fbae (patch)
tree1db8c98853ea0f2159c2291d764db3cef2d24ef4
parentInstall a system-preset to disable services by default (diff)
downloadgentoo-systemd-integration-97e3616a927367df8a3d96379f06b73aac39fbae.tar.gz
gentoo-systemd-integration-97e3616a927367df8a3d96379f06b73aac39fbae.tar.bz2
gentoo-systemd-integration-97e3616a927367df8a3d96379f06b73aac39fbae.zip
Drop var-lock.mount and var-run.mount
-rw-r--r--Makefile.am11
-rw-r--r--configure.ac5
-rw-r--r--mounts/var-lock.mount19
-rw-r--r--mounts/var-run.mount19
4 files changed, 0 insertions, 54 deletions
diff --git a/Makefile.am b/Makefile.am
index c0bbe5e..4482c77 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,9 +8,6 @@ dist_sysctl_DATA = \
sysctl.d/60-gentoo.conf
dist_tmpfiles_DATA = \
tmpfiles.d/gentoo-run.conf
-dist_systemdsystemunit_DATA = \
- mounts/var-lock.mount \
- mounts/var-run.mount
dist_systemdsystempreset_DATA = \
system-preset/99-default.preset
dist_systemdsystemgenerator_SCRIPTS = \
@@ -19,14 +16,6 @@ dist_systemdsystemgenerator_SCRIPTS = \
udevrulesdir = $(udevdir)/rules.d
dist_udevrules_DATA = udev/40-gentoo.rules
-install-data-hook: \
- systemd-system-unit-install-hook
-
-systemd-system-unit-install-hook:
- mkdir -p $(DESTDIR)$(systemdsystemunitdir)/sysinit.target.wants
- $(LN_S) ../var-lock.mount ../var-run.mount \
- $(DESTDIR)$(systemdsystemunitdir)/sysinit.target.wants/
-
DISTCLEANFILES = \
$(systemdsystemunit_DATA)
diff --git a/configure.ac b/configure.ac
index d8d6b2a..abe9705 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,11 +9,6 @@ AC_PROG_SED
# https://bitbucket.org/mgorny/systemd-m4/
SYSTEMD_MISC
-SYSTEMD_SYSTEMUNITDIR
-if test -z "$systemdsystemunitdir"; then
- AC_MSG_ERROR([systemdsystemunitdir must be set])
-fi
-
SYSTEMD_SYSTEMGENERATORDIR
if test -z "$systemdsystemgeneratordir"; then
AC_MSG_ERROR([systemdsystemgeneratordir must be set])
diff --git a/mounts/var-lock.mount b/mounts/var-lock.mount
deleted file mode 100644
index 07277ad..0000000
--- a/mounts/var-lock.mount
+++ /dev/null
@@ -1,19 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=Lock Directory
-Before=local-fs.target
-# skip mounting if the directory does not exist or is a symlink
-ConditionPathIsDirectory=/var/lock
-ConditionPathIsSymbolicLink=!/var/lock
-
-[Mount]
-What=/run/lock
-Where=/var/lock
-Type=bind
-Options=bind
diff --git a/mounts/var-run.mount b/mounts/var-run.mount
deleted file mode 100644
index ab4da42..0000000
--- a/mounts/var-run.mount
+++ /dev/null
@@ -1,19 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=Runtime Directory
-Before=local-fs.target
-# skip mounting if the directory does not exist or is a symlink
-ConditionPathIsDirectory=/var/run
-ConditionPathIsSymbolicLink=!/var/run
-
-[Mount]
-What=/run
-Where=/var/run
-Type=bind
-Options=bind