summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2017-03-14 17:08:56 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2017-03-14 17:09:16 +0100
commitaf9dbfa71b55e725f9c6c44edae00e9108ad1e6d (patch)
tree45ad02ed952e5255ef8f0dd0a877de58fba5288a /dev-libs
parentmate-base/libmatekbd: sync live ebuild (diff)
downloadgentoo-mate-af9dbfa71b55e725f9c6c44edae00e9108ad1e6d.tar.gz
gentoo-mate-af9dbfa71b55e725f9c6c44edae00e9108ad1e6d.tar.bz2
gentoo-mate-af9dbfa71b55e725f9c6c44edae00e9108ad1e6d.zip
dev-libs/libmateweather: sync live ebuild
* Drop gtk3 and python useflags Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libmateweather/libmateweather-9999.ebuild41
1 files changed, 7 insertions, 34 deletions
diff --git a/dev-libs/libmateweather/libmateweather-9999.ebuild b/dev-libs/libmateweather/libmateweather-9999.ebuild
index 4b1232f..c18aa29 100644
--- a/dev-libs/libmateweather/libmateweather-9999.ebuild
+++ b/dev-libs/libmateweather/libmateweather-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MATE_LA_PUNT="yes"
-PYTHON_COMPAT=( python2_7 )
-inherit python-r1 mate
+inherit mate
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
@@ -16,26 +15,15 @@ DESCRIPTION="MATE library to access weather information from online services"
LICENSE="GPL-2"
SLOT="0"
-IUSE="debug gtk3 python"
+IUSE="debug"
-REQUIRED_USE="
- gtk3? ( !python )
- python? ( ${PYTHON_REQUIRED_USE} )
- "
-
-COMMON_DEPEND=">=dev-libs/glib-2.36:2[${PYTHON_USEDEP}]
+COMMON_DEPEND=">=dev-libs/glib-2.36:2
>=dev-libs/libxml2-2.6:2
>=net-libs/libsoup-2.34:2.4
>=sys-libs/timezone-data-2010k:0
x11-libs/gdk-pixbuf:2
virtual/libintl:0
- !gtk3? ( >=x11-libs/gtk+-2.24:2 )
- gtk3? ( >=x11-libs/gtk+-3.0:3 )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/pygobject-2:2[${PYTHON_USEDEP}]
- >=dev-python/pygtk-2:2[${PYTHON_USEDEP}]
- )"
+ >=x11-libs/gtk+-3.0:3"
RDEPEND="${COMMON_DEPEND}"
@@ -47,23 +35,8 @@ DEPEND="${COMMON_DEPEND}
>=sys-devel/libtool-2.2.6:2
virtual/pkgconfig:*"
-src_prepare() {
- mate_src_prepare
- use python && python_copy_sources
-}
-
src_configure() {
- mate_py_cond_func_wrap mate_src_configure \
+ mate_src_configure \
--enable-locations-compression \
- --disable-all-translations-in-one-xml \
- --with-gtk=$(usex gtk3 3.0 2.0) \
- $(use_enable python)
-}
-
-src_compile() {
- mate_py_cond_func_wrap default
-}
-
-src_install() {
- mate_py_cond_func_wrap mate_src_install
+ --disable-all-translations-in-one-xml
}