summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/kuroo4/kuroo4-9999.ebuild')
-rw-r--r--app-portage/kuroo4/kuroo4-9999.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/app-portage/kuroo4/kuroo4-9999.ebuild b/app-portage/kuroo4/kuroo4-9999.ebuild
index 47ff331..f56f960 100644
--- a/app-portage/kuroo4/kuroo4-9999.ebuild
+++ b/app-portage/kuroo4/kuroo4-9999.ebuild
@@ -2,31 +2,23 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=3
+EAPI=4
-inherit subversion kde4-base eutils
+inherit subversion kde4-base
-DESCRIPTION="Kuroo is a Qt 4 based portage GUI"
+DESCRIPTION="Grophical Portage frontend based on KDE4/Qt4"
HOMEPAGE="http://kuroo.sourceforge.net/"
SRC_URI=""
ESVN_REPO_URI="http://kuroo.svn.sourceforge.net/svnroot/kuroo/kuroo4/trunk"
ESVN_PROJECT="kuroo4"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="4"
KEYWORDS=""
-IUSE="+debug"
+IUSE="debug"
-DEPEND="kde-base/kdesu
- dev-db/sqlite
- app-portage/gentoolkit
- kde-base/kompare"
+DEPEND="app-portage/gentoolkit
+ dev-db/sqlite
+ $(add_kdebase_dep kdesu)
+ $(add_kdebase_dep kompare)"
RDEPEND="${DEPEND}"
-
-pkg_setup() {
- kde4-base_pkg_setup
-}
-
-src_prepare() {
- kde4-base_src_prepare
-}