aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-29 00:04:35 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-29 00:04:35 +0100
commit404cdc26b8b203b7a1910be73f256a05a1e64b18 (patch)
treefee6414c20264c66a79dd6019093fcaedd766cea /make-tarball.sh
parent11.0.0: start new patchset for live branch (diff)
downloadgcc-patches-404cdc26b8b203b7a1910be73f256a05a1e64b18.tar.gz
gcc-patches-404cdc26b8b203b7a1910be73f256a05a1e64b18.tar.bz2
gcc-patches-404cdc26b8b203b7a1910be73f256a05a1e64b18.zip
make-tarball.sh: add patchset creation against live ebuilds
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'make-tarball.sh')
-rwxr-xr-xmake-tarball.sh1
1 files changed, 1 insertions, 0 deletions
diff --git a/make-tarball.sh b/make-tarball.sh
index a626a3d..18dfe47 100755
--- a/make-tarball.sh
+++ b/make-tarball.sh
@@ -25,6 +25,7 @@ rm -f ${digest/gcc\//gcc\/files\/digest-}
gver=${ebuild##*/gcc/gcc-} # trim leading path
gver=${gver%%.ebuild} # trim post .ebuild
gver=${gver%%-*} # trim any -r#'s
+gver=${gver%%_pre*} # trim any _pre.*#'s
# trim branch update number
sgver=$(echo ${gver} | sed -e 's:[0-9]::g')