aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-08 00:15:56 +0100
committerSam James <sam@gentoo.org>2024-04-08 00:16:27 +0100
commit0b365302d77dabad96a00c5fe3643d905ec39298 (patch)
tree921eb2404f2a6472d593c278b4ce76e6c87154dd
parent13.2.0: drop upstreamed patch, backport riscv gstreamer fix (diff)
downloadgcc-patches-0b365302d77dabad96a00c5fe3643d905ec39298.tar.gz
gcc-patches-0b365302d77dabad96a00c5fe3643d905ec39298.tar.bz2
gcc-patches-0b365302d77dabad96a00c5fe3643d905ec39298.zip
13.2.0: rebase patches
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--13.2.0/gentoo/76_all_match.pd-don-t-emit-label-if-not-needed.patch8
-rw-r--r--13.2.0/gentoo/77_all_match.pd-Remove-commented-out-line-pragmas-unless-vv.patch8
-rw-r--r--13.2.0/gentoo/78_all_match.pd-CSE-the-dump-output-check.patch8
-rw-r--r--13.2.0/gentoo/79_all_genmatch-split-shared-code-to-gimple-match-exports.c.patch18
-rw-r--r--13.2.0/gentoo/80_all_match.pd-automatically-partition-match.cc-files.patch18
-rw-r--r--13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch46
-rw-r--r--13.2.0/gentoo/82_all_Makefile.in-clean-up-match.pd-related-dependencies.patch6
-rw-r--r--13.2.0/gentoo/86_all_build-Replace-seq-for-portability-with-GNU-Make-vari.patch9
-rw-r--r--13.2.0/gentoo/87_all_Remove-DEFAULT_MATCHPD_PARTITIONS-macro.patch46
-rw-r--r--13.2.0/gentoo/88_all_Makefile.in-Make-TM_P_H-depend-on-TREE_H-PR111021.patch6
-rw-r--r--13.2.0/gentoo/89_all_Makefile.in-Make-recog.h-depend-on-TREE_H-PR111021.patch6
-rw-r--r--13.2.0/gentoo/90_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch26
-rw-r--r--13.2.0/gentoo/README.history12
13 files changed, 133 insertions, 84 deletions
diff --git a/13.2.0/gentoo/76_all_match.pd-don-t-emit-label-if-not-needed.patch b/13.2.0/gentoo/76_all_match.pd-don-t-emit-label-if-not-needed.patch
index 9d702eb..95da940 100644
--- a/13.2.0/gentoo/76_all_match.pd-don-t-emit-label-if-not-needed.patch
+++ b/13.2.0/gentoo/76_all_match.pd-don-t-emit-label-if-not-needed.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From 30f78d42a215686cab9c7276076f11e5ea08341d Mon Sep 17 00:00:00 2001
+From 6178fddd3e0957fbb8bcfc443fef172691b7640b Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:35:17 +0100
-Subject: [PATCH 02/14] match.pd: don't emit label if not needed
+Subject: [PATCH 01/15] match.pd: don't emit label if not needed
This is a small QoL codegen improvement for match.pd to not emit labels when
they are not needed. The codegen is nice and there is a small (but consistent)
@@ -20,7 +20,7 @@ gcc/ChangeLog:
1 file changed, 22 insertions(+), 8 deletions(-)
diff --git a/gcc/genmatch.cc b/gcc/genmatch.cc
-index 98b429a9d0bb..0c5a19aca8ed 100644
+index c1023d921fca..9ecd0a462b4f 100644
--- a/gcc/genmatch.cc
+++ b/gcc/genmatch.cc
@@ -3354,6 +3354,7 @@ dt_simplify::gen_1 (FILE *f, int indent, bool gimple, operand *result)
@@ -110,5 +110,5 @@ index 98b429a9d0bb..0c5a19aca8ed 100644
}
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/77_all_match.pd-Remove-commented-out-line-pragmas-unless-vv.patch b/13.2.0/gentoo/77_all_match.pd-Remove-commented-out-line-pragmas-unless-vv.patch
index fb50871..ea61987 100644
--- a/13.2.0/gentoo/77_all_match.pd-Remove-commented-out-line-pragmas-unless-vv.patch
+++ b/13.2.0/gentoo/77_all_match.pd-Remove-commented-out-line-pragmas-unless-vv.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From 1e714dddc3646b484014ec6636b3d80910536b4b Mon Sep 17 00:00:00 2001
+From 2be19327b38b4e3e183d47529871614a3ef0c3ad Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:36:01 +0100
-Subject: [PATCH 03/14] match.pd: Remove commented out line pragmas unless -vv
+Subject: [PATCH 02/15] match.pd: Remove commented out line pragmas unless -vv
is used.
genmatch currently outputs commented out line directives that have no effect
@@ -24,7 +24,7 @@ gcc/ChangeLog:
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/gcc/genmatch.cc b/gcc/genmatch.cc
-index 0c5a19aca8ed..8937c76369cb 100644
+index 9ecd0a462b4f..45e49c790b6d 100644
--- a/gcc/genmatch.cc
+++ b/gcc/genmatch.cc
@@ -209,7 +209,7 @@ output_line_directive (FILE *f, location_t location,
@@ -37,5 +37,5 @@ index 0c5a19aca8ed..8937c76369cb 100644
development it's right now more convenient to have line information
from the generated file. Still keep the directives as comment for now
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/78_all_match.pd-CSE-the-dump-output-check.patch b/13.2.0/gentoo/78_all_match.pd-CSE-the-dump-output-check.patch
index 8dda55a..e084c4c 100644
--- a/13.2.0/gentoo/78_all_match.pd-CSE-the-dump-output-check.patch
+++ b/13.2.0/gentoo/78_all_match.pd-CSE-the-dump-output-check.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From c256e2c80e56c4e015d8d7ca50fa01a6ed98a1eb Mon Sep 17 00:00:00 2001
+From 2d83fafb3f263544be09bf7dbde036e4a84f6d7c Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:36:43 +0100
-Subject: [PATCH 04/14] match.pd: CSE the dump output check.
+Subject: [PATCH 03/15] match.pd: CSE the dump output check.
This is a small improvement in QoL codegen for match.pd to save time not
re-evaluating the condition for printing debug information in every function.
@@ -26,7 +26,7 @@ gcc/ChangeLog:
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/gcc/genmatch.cc b/gcc/genmatch.cc
-index 8937c76369cb..a0643aa37308 100644
+index 45e49c790b6d..a17ef8a23ed5 100644
--- a/gcc/genmatch.cc
+++ b/gcc/genmatch.cc
@@ -3433,7 +3433,7 @@ dt_simplify::gen_1 (FILE *f, int indent, bool gimple, operand *result)
@@ -66,5 +66,5 @@ index 8937c76369cb..a0643aa37308 100644
if (!gimple)
fprintf_indent (f, 2, "if (TREE_SIDE_EFFECTS (t)) return false;\n");
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/79_all_genmatch-split-shared-code-to-gimple-match-exports.c.patch b/13.2.0/gentoo/79_all_genmatch-split-shared-code-to-gimple-match-exports.c.patch
index f52ea7a..1f7769f 100644
--- a/13.2.0/gentoo/79_all_genmatch-split-shared-code-to-gimple-match-exports.c.patch
+++ b/13.2.0/gentoo/79_all_genmatch-split-shared-code-to-gimple-match-exports.c.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From d5e12d6bf0a763f37e99eef5d579d9a6417e067c Mon Sep 17 00:00:00 2001
+From 49ed8cead428b48bf46afbbb37a4d043d00702d6 Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:37:49 +0100
-Subject: [PATCH 05/14] genmatch: split shared code to gimple-match-exports.cc
+Subject: [PATCH 04/15] genmatch: split shared code to gimple-match-exports.cc
In preparation for automatically splitting match.pd files I split off the
non-static helper functions that are shared between the match.pd functions off
@@ -68,7 +68,7 @@ index 06d192fa9ed8..406856acde1c 100644
s-match: build/genmatch$(build_exeext) $(srcdir)/match.pd cfn-operators.pd
diff --git a/gcc/genmatch.cc b/gcc/genmatch.cc
-index a0643aa37308..5320d4110082 100644
+index a17ef8a23ed5..665d7e2106ff 100644
--- a/gcc/genmatch.cc
+++ b/gcc/genmatch.cc
@@ -3957,7 +3957,7 @@ decision_tree::gen (FILE *f, bool gimple)
@@ -1349,12 +1349,12 @@ index 000000000000..7aeb4ddb1524
+ return get_conditional_internal_fn (associated_internal_fn (cfn, type));
+}
diff --git a/gcc/gimple-match-head.cc b/gcc/gimple-match-head.cc
-index ec603f9d043c..b08cd891a13a 100644
+index 21843d7870b3..3069ff5cb6e1 100644
--- a/gcc/gimple-match-head.cc
+++ b/gcc/gimple-match-head.cc
-@@ -48,1089 +48,8 @@ along with GCC; see the file COPYING3. If not see
- #include "gimple-range.h"
- #include "langhooks.h"
+@@ -50,1089 +50,8 @@ along with GCC; see the file COPYING3. If not see
+ #include "attribs.h"
+ #include "asan.h"
-/* Forward declarations of the private auto-generated matchers.
- They expect valueized operands in canonical order and do not
@@ -2444,7 +2444,7 @@ index ec603f9d043c..b08cd891a13a 100644
/* Helper for the autogenerated code, get at the definition of NAME when
VALUEIZE allows that. */
-@@ -1305,110 +224,3 @@ optimize_successive_divisions_p (tree divisor, tree inner_div)
+@@ -1307,110 +226,3 @@ optimize_successive_divisions_p (tree divisor, tree inner_div)
}
return true;
}
@@ -2556,5 +2556,5 @@ index ec603f9d043c..b08cd891a13a 100644
- return get_conditional_internal_fn (associated_internal_fn (cfn, type));
-}
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/80_all_match.pd-automatically-partition-match.cc-files.patch b/13.2.0/gentoo/80_all_match.pd-automatically-partition-match.cc-files.patch
index 6cee0ce..6405bf8 100644
--- a/13.2.0/gentoo/80_all_match.pd-automatically-partition-match.cc-files.patch
+++ b/13.2.0/gentoo/80_all_match.pd-automatically-partition-match.cc-files.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From 0b9341cec30004016c4a66013882ea983a9e3810 Mon Sep 17 00:00:00 2001
+From daac5d2f67656dcf8cc2bbff1c6eaa34f3fb55b9 Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:38:50 +0100
-Subject: [PATCH 06/14] match.pd: automatically partition *-match.cc files.
+Subject: [PATCH 05/15] match.pd: automatically partition *-match.cc files.
Following on from Richi's RFC[1] this is another attempt to split up match.pd
into multiple gimple-match and generic-match files. This version is fully
@@ -111,7 +111,7 @@ gcc/ChangeLog:
1 file changed, 190 insertions(+), 36 deletions(-)
diff --git a/gcc/genmatch.cc b/gcc/genmatch.cc
-index 5320d4110082..6cb05d006e8d 100644
+index 665d7e2106ff..f80e4b972288 100644
--- a/gcc/genmatch.cc
+++ b/gcc/genmatch.cc
@@ -183,6 +183,33 @@ fprintf_indent (FILE *f, unsigned int indent, const char *format, ...)
@@ -374,7 +374,7 @@ index 5320d4110082..6cb05d006e8d 100644
}
-@@ -5215,6 +5293,30 @@ round_alloc_size (size_t s)
+@@ -5213,6 +5291,30 @@ round_alloc_size (size_t s)
}
@@ -405,7 +405,7 @@ index 5320d4110082..6cb05d006e8d 100644
/* The genmatch generator program. It reads from a pattern description
and outputs GIMPLE or GENERIC IL matching and simplification routines. */
-@@ -5229,25 +5331,44 @@ main (int argc, char **argv)
+@@ -5227,25 +5329,44 @@ main (int argc, char **argv)
return 1;
bool gimple = true;
@@ -454,7 +454,7 @@ index 5320d4110082..6cb05d006e8d 100644
line_table = XCNEW (class line_maps);
linemap_init (line_table, 0);
line_table->reallocator = xrealloc;
-@@ -5294,10 +5415,28 @@ main (int argc, char **argv)
+@@ -5292,10 +5413,28 @@ main (int argc, char **argv)
/* Parse ahead! */
parser p (r, gimple);
@@ -486,7 +486,7 @@ index 5320d4110082..6cb05d006e8d 100644
/* Go over all predicates defined with patterns and perform
lowering and code generation. */
-@@ -5317,7 +5456,10 @@ main (int argc, char **argv)
+@@ -5315,7 +5454,10 @@ main (int argc, char **argv)
if (verbose == 2)
dt.print (stderr);
@@ -498,7 +498,7 @@ index 5320d4110082..6cb05d006e8d 100644
}
/* Lower the main simplifiers and generate code for them. */
-@@ -5334,7 +5476,19 @@ main (int argc, char **argv)
+@@ -5332,7 +5474,19 @@ main (int argc, char **argv)
if (verbose == 2)
dt.print (stderr);
@@ -520,5 +520,5 @@ index 5320d4110082..6cb05d006e8d 100644
/* Finalize. */
cpp_finish (r, NULL);
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch b/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
index 8834897..f525f63 100644
--- a/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
+++ b/13.2.0/gentoo/81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=109927#c21
-From 7ad6dc24f067e3ecf608143274c36b1eec51ba93 Mon Sep 17 00:00:00 2001
+From dcfebe060ee266f364bb60f1cdf0cec58818c4f7 Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Fri, 5 May 2023 13:42:17 +0100
-Subject: [PATCH 07/14] match.pd: Use splits in makefile and make configurable.
+Subject: [PATCH 06/15] match.pd: Use splits in makefile and make configurable.
This updates the build system to split up match.pd files into chunks of 10.
This also introduces a new flag --with-matchpd-partitions which can be used to
@@ -26,9 +26,10 @@ gcc/ChangeLog:
(cherry picked from commit 0a85544e1aaeca41133ecfc438cda913dbc0f122)
---
gcc/Makefile.in | 67 +++++++++++++++++++++++++++++++++---------------
+ gcc/config.in | 6 +++++
gcc/configure | 29 +++++++++++++++++++--
gcc/configure.ac | 15 +++++++++++
- 3 files changed, 89 insertions(+), 22 deletions(-)
+ 4 files changed, 95 insertions(+), 22 deletions(-)
diff --git a/gcc/Makefile.in b/gcc/Makefile.in
index 406856acde1c..f0c34d00ecbc 100644
@@ -152,8 +153,25 @@ index 406856acde1c..f0c34d00ecbc 100644
c-family/c-target-hooks-def.h d/d-target-hooks-def.h \
case-cfn-macros.h \
cfn-operators.pd omp-device-properties.h
+diff --git a/gcc/config.in b/gcc/config.in
+index 5281a12a707c..ea60c5b11fc5 100644
+--- a/gcc/config.in
++++ b/gcc/config.in
+@@ -67,6 +67,12 @@
+ #endif
+
+
++/* Define to larger than one set the number of match.pd partitions to make. */
++#ifndef USED_FOR_TARGET
++#undef DEFAULT_MATCHPD_PARTITIONS
++#endif
++
++
+ /* Define to larger than zero set the default stack clash protector size. */
+ #ifndef USED_FOR_TARGET
+ #undef DEFAULT_STK_CLASH_GUARD_SIZE
diff --git a/gcc/configure b/gcc/configure
-index dec2eca1a453..2c124f1b0337 100755
+index ade0af23e8cc..542d100c2b73 100755
--- a/gcc/configure
+++ b/gcc/configure
@@ -838,6 +838,7 @@ enable_gcov
@@ -182,7 +200,7 @@ index dec2eca1a453..2c124f1b0337 100755
--with-dwarf2 force the default debug format to be DWARF 2 (or
later)
--with-specs=SPECS add SPECS to driver command-line processing
-@@ -7895,6 +7900,26 @@ cat >>confdefs.h <<_ACEOF
+@@ -7918,6 +7923,26 @@ cat >>confdefs.h <<_ACEOF
_ACEOF
@@ -209,29 +227,29 @@ index dec2eca1a453..2c124f1b0337 100755
# Enable __cxa_atexit for C++.
# Check whether --enable-__cxa_atexit was given.
if test "${enable___cxa_atexit+set}" = set; then :
-@@ -19848,7 +19873,7 @@ else
+@@ -19871,7 +19896,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19851 "configure"
-+#line 19876 "configure"
+-#line 19874 "configure"
++#line 19899 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -19954,7 +19979,7 @@ else
+@@ -19977,7 +20002,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19957 "configure"
-+#line 19982 "configure"
+-#line 19980 "configure"
++#line 20005 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index c0d067ec2716..526ce0665a3e 100644
+index bf8ff4d63906..31aa8566a3e7 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -921,6 +921,21 @@ fi
+@@ -943,6 +943,21 @@ fi
AC_DEFINE_UNQUOTED(DEFAULT_STK_CLASH_GUARD_SIZE, $DEFAULT_STK_CLASH_GUARD_SIZE,
[Define to larger than zero set the default stack clash protector size.])
@@ -254,5 +272,5 @@ index c0d067ec2716..526ce0665a3e 100644
AC_ARG_ENABLE(__cxa_atexit,
[AS_HELP_STRING([--enable-__cxa_atexit], [enable __cxa_atexit for C++])],
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/82_all_Makefile.in-clean-up-match.pd-related-dependencies.patch b/13.2.0/gentoo/82_all_Makefile.in-clean-up-match.pd-related-dependencies.patch
index 950bfba..2512660 100644
--- a/13.2.0/gentoo/82_all_Makefile.in-clean-up-match.pd-related-dependencies.patch
+++ b/13.2.0/gentoo/82_all_Makefile.in-clean-up-match.pd-related-dependencies.patch
@@ -1,7 +1,7 @@
-From 88d7963056355a28adb9fc1b805752d422c2619e Mon Sep 17 00:00:00 2001
+From 2c1f550db00c7dd9abede5644a3acd915767e0ad Mon Sep 17 00:00:00 2001
From: Alexander Monakov <amonakov@ispras.ru>
Date: Fri, 5 May 2023 19:46:25 +0300
-Subject: [PATCH 08/14] Makefile.in: clean up match.pd-related dependencies
+Subject: [PATCH 07/15] Makefile.in: clean up match.pd-related dependencies
Clean up confusing changes from the recent refactoring for
parallel match.pd build.
@@ -56,5 +56,5 @@ index f0c34d00ecbc..fe3af5c8008c 100644
s-gimple-match: build/genmatch$(build_exeext) \
$(srcdir)/match.pd cfn-operators.pd
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/86_all_build-Replace-seq-for-portability-with-GNU-Make-vari.patch b/13.2.0/gentoo/86_all_build-Replace-seq-for-portability-with-GNU-Make-vari.patch
index 9b88852..892adbc 100644
--- a/13.2.0/gentoo/86_all_build-Replace-seq-for-portability-with-GNU-Make-vari.patch
+++ b/13.2.0/gentoo/86_all_build-Replace-seq-for-portability-with-GNU-Make-vari.patch
@@ -1,9 +1,10 @@
https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=319aef8d2fde32be5cfed99f321c7f90e33d1f1d
-From 3fd5922104168eb1a88ee6209d84ccc9e72a4bfa Mon Sep 17 00:00:00 2001
+From a18a994030d16f58ebced231e778ec4e06a98abb Mon Sep 17 00:00:00 2001
From: Jakub Jelinek <jakub@redhat.com>
Date: Sat, 6 May 2023 02:32:17 +0200
-Subject: [PATCH 1/6] build: Replace seq for portability with GNU Make variant
+Subject: [PATCH 08/15] build: Replace seq for portability with GNU Make
+ variant
Some hosts like AIX don't have seq command, this patch replaces it
with something that uses just GNU make features we've been using
@@ -23,7 +24,7 @@ for this already before for the parallel make check.
1 file changed, 12 insertions(+), 10 deletions(-)
diff --git a/gcc/Makefile.in b/gcc/Makefile.in
-index fe3af5c8008..975fbb61ea8 100644
+index fe3af5c8008c..975fbb61ea8a 100644
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
@@ -214,9 +214,19 @@ rtl-ssa-warn = $(STRICT_WARN)
@@ -68,5 +69,5 @@ index fe3af5c8008..975fbb61ea8 100644
# For parallelized check-% targets, this decides whether parallelization
# is desirable (if -jN is used). If desirable, recursive make is run with
--
-2.42.0
+2.44.0
diff --git a/13.2.0/gentoo/87_all_Remove-DEFAULT_MATCHPD_PARTITIONS-macro.patch b/13.2.0/gentoo/87_all_Remove-DEFAULT_MATCHPD_PARTITIONS-macro.patch
index 5e6a81d..1f47154 100644
--- a/13.2.0/gentoo/87_all_Remove-DEFAULT_MATCHPD_PARTITIONS-macro.patch
+++ b/13.2.0/gentoo/87_all_Remove-DEFAULT_MATCHPD_PARTITIONS-macro.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=bc45e18d433f879a02e369d027829f90f9e85724
-From e351a8c9975b93e3e98e52342cb77b6a2969257f Mon Sep 17 00:00:00 2001
+From b60091fe7d22e0cac71461dceeb804e37555b5d3 Mon Sep 17 00:00:00 2001
From: Tamar Christina <tamar.christina@arm.com>
Date: Mon, 12 Jun 2023 14:06:08 +0100
-Subject: [PATCH 10/14] Remove DEFAULT_MATCHPD_PARTITIONS macro
+Subject: [PATCH 09/15] Remove DEFAULT_MATCHPD_PARTITIONS macro
As Jakub pointed out, DEFAULT_MATCHPD_PARTITIONS
is now unused and can be removed.
@@ -16,15 +16,33 @@ gcc/ChangeLog:
(cherry picked from commit bc45e18d433f879a02e369d027829f90f9e85724)
---
+ gcc/config.in | 6 ------
gcc/configure | 9 ++-------
gcc/configure.ac | 2 --
- 2 files changed, 2 insertions(+), 9 deletions(-)
+ 3 files changed, 2 insertions(+), 15 deletions(-)
+diff --git a/gcc/config.in b/gcc/config.in
+index ea60c5b11fc5..5281a12a707c 100644
+--- a/gcc/config.in
++++ b/gcc/config.in
+@@ -67,12 +67,6 @@
+ #endif
+
+
+-/* Define to larger than one set the number of match.pd partitions to make. */
+-#ifndef USED_FOR_TARGET
+-#undef DEFAULT_MATCHPD_PARTITIONS
+-#endif
+-
+-
+ /* Define to larger than zero set the default stack clash protector size. */
+ #ifndef USED_FOR_TARGET
+ #undef DEFAULT_STK_CLASH_GUARD_SIZE
diff --git a/gcc/configure b/gcc/configure
-index 2c124f1b0337..61c18a13ab7b 100755
+index 542d100c2b73..cc8247037569 100755
--- a/gcc/configure
+++ b/gcc/configure
-@@ -7914,11 +7914,6 @@ if (test $DEFAULT_MATCHPD_PARTITIONS -lt 1); then
+@@ -7937,11 +7937,6 @@ if (test $DEFAULT_MATCHPD_PARTITIONS -lt 1); then
fi
@@ -36,29 +54,29 @@ index 2c124f1b0337..61c18a13ab7b 100755
# Enable __cxa_atexit for C++.
# Check whether --enable-__cxa_atexit was given.
-@@ -19873,7 +19868,7 @@ else
+@@ -19896,7 +19891,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19876 "configure"
-+#line 19871 "configure"
+-#line 19899 "configure"
++#line 19894 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -19979,7 +19974,7 @@ else
+@@ -20002,7 +19997,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19982 "configure"
-+#line 19977 "configure"
+-#line 20005 "configure"
++#line 20000 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index 526ce0665a3e..c15b65367419 100644
+index 31aa8566a3e7..d02ffc22a3a3 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -932,8 +932,6 @@ if (test $DEFAULT_MATCHPD_PARTITIONS -lt 1); then
+@@ -954,8 +954,6 @@ if (test $DEFAULT_MATCHPD_PARTITIONS -lt 1); then
Cannot be negative.]))
fi
@@ -68,5 +86,5 @@ index 526ce0665a3e..c15b65367419 100644
# Enable __cxa_atexit for C++.
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/88_all_Makefile.in-Make-TM_P_H-depend-on-TREE_H-PR111021.patch b/13.2.0/gentoo/88_all_Makefile.in-Make-TM_P_H-depend-on-TREE_H-PR111021.patch
index aa6a0f3..0a92592 100644
--- a/13.2.0/gentoo/88_all_Makefile.in-Make-TM_P_H-depend-on-TREE_H-PR111021.patch
+++ b/13.2.0/gentoo/88_all_Makefile.in-Make-TM_P_H-depend-on-TREE_H-PR111021.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=8353b9c5f5af0e65cb04fcbb7325d6a566006cd4
-From f9139ea69c23448a874cbb64c2d201cf9f7ece2f Mon Sep 17 00:00:00 2001
+From 87192b63d3ab56543461cb456c4f8b2f1085fd6c Mon Sep 17 00:00:00 2001
From: Kewen Lin <linkw@linux.ibm.com>
Date: Fri, 18 Aug 2023 05:03:40 -0500
-Subject: [PATCH 12/14] Makefile.in: Make TM_P_H depend on $(TREE_H) [PR111021]
+Subject: [PATCH 11/15] Makefile.in: Make TM_P_H depend on $(TREE_H) [PR111021]
As PR111021 shows, the below ${port}-protos.h include tree.h
for code_helper and tree_code:
@@ -62,5 +62,5 @@ index 975fbb61ea8a..115d2a6d9b76 100644
GTM_H = tm.h $(tm_file_list) insn-constants.h
TM_H = $(GTM_H) insn-flags.h $(OPTIONS_H)
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/89_all_Makefile.in-Make-recog.h-depend-on-TREE_H-PR111021.patch b/13.2.0/gentoo/89_all_Makefile.in-Make-recog.h-depend-on-TREE_H-PR111021.patch
index 330503a..e0c84ae 100644
--- a/13.2.0/gentoo/89_all_Makefile.in-Make-recog.h-depend-on-TREE_H-PR111021.patch
+++ b/13.2.0/gentoo/89_all_Makefile.in-Make-recog.h-depend-on-TREE_H-PR111021.patch
@@ -1,9 +1,9 @@
https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=ecb95399f43873e1f34119ac260bbea2ef358e53
-From fcf952823a3d246e6459ce7454144a96fc1f540b Mon Sep 17 00:00:00 2001
+From 45b0ac72b82e483ac2b8380ce08cedcfd021afb0 Mon Sep 17 00:00:00 2001
From: Kewen Lin <linkw@linux.ibm.com>
Date: Tue, 15 Aug 2023 03:01:20 -0500
-Subject: [PATCH 13/14] Makefile.in: Make recog.h depend on $(TREE_H)
+Subject: [PATCH 12/15] Makefile.in: Make recog.h depend on $(TREE_H)
[PR111021]
Commit r14-3093 introduced a random build failure on
@@ -41,5 +41,5 @@ index 115d2a6d9b76..2c16b14ad0f3 100644
FLAGS_H = flags.h flag-types.h $(OPTIONS_H)
OPTIONS_H = options.h flag-types.h $(OPTIONS_H_EXTRA)
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/90_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch b/13.2.0/gentoo/90_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
index c237e7b..f6ded53 100644
--- a/13.2.0/gentoo/90_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
+++ b/13.2.0/gentoo/90_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
@@ -1,10 +1,10 @@
https://gcc.gnu.org/PR54179
https://inbox.sourceware.org/gcc-patches/de0f7bdc-d236-4f5b-9504-d5bfb215d023@gmail.com/
-From 366eeb9d3b5e861291be112d66940d98e9dc2693 Mon Sep 17 00:00:00 2001
+From d63f858f41e2bb0e159d15ed8ee41bf303325ee7 Mon Sep 17 00:00:00 2001
From: Robin Dapp <rdapp.gcc@gmail.com>
Date: Fri, 27 Oct 2023 21:04:25 +0200
-Subject: [PATCH 14/14] genemit: Split insn-emit.cc into ten files.
+Subject: [PATCH 13/15] genemit: Split insn-emit.cc into ten files.
After working with Sam off-list (thanks) I managed to get hppa to
build. Initially it looked as if hppa just had a very small number of
@@ -168,7 +168,7 @@ index 2c16b14ad0f3..b0c118e6d189 100644
s-check : build/gencheck$(build_exeext)
$(RUN_GEN) build/gencheck$(build_exeext) > tmp-check.h
diff --git a/gcc/configure b/gcc/configure
-index 61c18a13ab7b..9a8d7ab8b8fa 100755
+index cc8247037569..c98088bea90d 100755
--- a/gcc/configure
+++ b/gcc/configure
@@ -838,6 +838,7 @@ enable_gcov
@@ -197,7 +197,7 @@ index 61c18a13ab7b..9a8d7ab8b8fa 100755
--with-dwarf2 force the default debug format to be DWARF 2 (or
later)
--with-specs=SPECS add SPECS to driver command-line processing
-@@ -7915,6 +7920,21 @@ fi
+@@ -7938,6 +7943,21 @@ fi
@@ -219,29 +219,29 @@ index 61c18a13ab7b..9a8d7ab8b8fa 100755
# Enable __cxa_atexit for C++.
# Check whether --enable-__cxa_atexit was given.
if test "${enable___cxa_atexit+set}" = set; then :
-@@ -19868,7 +19888,7 @@ else
+@@ -19891,7 +19911,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19871 "configure"
-+#line 19891 "configure"
+-#line 19894 "configure"
++#line 19914 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -19974,7 +19994,7 @@ else
+@@ -19997,7 +20017,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 19977 "configure"
-+#line 19997 "configure"
+-#line 20000 "configure"
++#line 20020 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
diff --git a/gcc/configure.ac b/gcc/configure.ac
-index c15b65367419..66b9eaa99e08 100644
+index d02ffc22a3a3..7021f95da3ee 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
-@@ -934,6 +934,19 @@ fi
+@@ -956,6 +956,19 @@ fi
AC_SUBST(DEFAULT_MATCHPD_PARTITIONS)
@@ -1400,5 +1400,5 @@ index b309c9c3deb6..2adcb58478fe 100644
struct enum_type *lookup_enum_type (const char *name);
void traverse_enum_types (htab_trav callback, void *info);
--
-2.43.0
+2.44.0
diff --git a/13.2.0/gentoo/README.history b/13.2.0/gentoo/README.history
index bacfe3b..26583a8 100644
--- a/13.2.0/gentoo/README.history
+++ b/13.2.0/gentoo/README.history
@@ -1,6 +1,18 @@
15 7 Apr 2024
- 50_all_PR111632_system_cxx_headers_libcxx.patch
+ U 76_all_match.pd-don-t-emit-label-if-not-needed.patch
+ U 77_all_match.pd-Remove-commented-out-line-pragmas-unless-vv.patch
+ U 78_all_match.pd-CSE-the-dump-output-check.patch
+ U 79_all_genmatch-split-shared-code-to-gimple-match-exports.c.patch
+ U 80_all_match.pd-automatically-partition-match.cc-files.patch
+ U 81_all_match.pd-Use-splits-in-makefile-and-make-configurabl.patch
+ U 82_all_Makefile.in-clean-up-match.pd-related-dependencies.patch
+ U 86_all_build-Replace-seq-for-portability-with-GNU-Make-vari.patch
+ U 87_all_Remove-DEFAULT_MATCHPD_PARTITIONS-macro.patch
+ U 88_all_Makefile.in-Make-TM_P_H-depend-on-TREE_H-PR111021.patch
+ U 89_all_Makefile.in-Make-recog.h-depend-on-TREE_H-PR111021.patch
+ U 90_all_PR54179_genemit-Split-insn-emit.cc-into-ten-files.patch
+ 92_all_riscv_PR109760-gstreamer.patch
14 28 Feb 2024