aboutsummaryrefslogtreecommitdiff
path: root/6.4.0
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-09-15 19:40:09 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-09-15 19:40:09 +0100
commit52d8f44f45d244184d737cec5a26a1754f877e75 (patch)
treed3cf5e729661a99a92ab6d6d7071a791d3d47213 /6.4.0
parent6/7/8 branches: add 101_all_x32-fix-eh-return-address.patch (diff)
downloadgcc-patches-52d8f44f45d244184d737cec5a26a1754f877e75.tar.gz
gcc-patches-52d8f44f45d244184d737cec5a26a1754f877e75.tar.bz2
gcc-patches-52d8f44f45d244184d737cec5a26a1754f877e75.zip
Pass CXXFLAGS as CXXFLAGS_FOR_BUILD to stage1.
Fixes build failure when CXXFLAGS contains TARGET-specific flags. Tested on x86_64-pc-linux-gnu host as: # CFLAGS='-O2 -mfpu=neon-vfpv4' CXXFLAGS='-O2 -mfpu=neon-vfpv4' \ armv7a-unknown-linux-gnueabihf-emerge -v1 sys-devel/gcc --quiet-build=n Fix by Peter Levine. Bug: https://bugs.gentoo.org/581406 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to '6.4.0')
-rw-r--r--6.4.0/gentoo/102_all_respect-build-cxxflags.patch39
-rw-r--r--6.4.0/gentoo/README.history1
2 files changed, 40 insertions, 0 deletions
diff --git a/6.4.0/gentoo/102_all_respect-build-cxxflags.patch b/6.4.0/gentoo/102_all_respect-build-cxxflags.patch
new file mode 100644
index 0000000..14139ea
--- /dev/null
+++ b/6.4.0/gentoo/102_all_respect-build-cxxflags.patch
@@ -0,0 +1,39 @@
+Pass CXXFLAGS as CXXFLAGS_FOR_BUILD to stage1.
+
+Fixes build failure when CXXFLAGS contains
+TARGET-specific flags.
+
+Tested on x86_64-pc-linux-gnu host as:
+ # CFLAGS='-O2 -mfpu=neon-vfpv4' CXXFLAGS='-O2 -mfpu=neon-vfpv4' \
+ armv7a-unknown-linux-gnueabihf-emerge -v1 sys-devel/gcc --quiet-build=n
+
+Fix by Peter Levine.
+https://bugs.gentoo.org/581406
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -170,6 +170,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.
+@@ -710,6 +711,7 @@
+ "CC_FOR_BUILD=$(CC_FOR_BUILD)" \
+ "CFLAGS_FOR_BUILD=$(CFLAGS_FOR_BUILD)" \
+ "CXX_FOR_BUILD=$(CXX_FOR_BUILD)" \
++ "CXXFLAGS_FOR_BUILD=$(CXXFLAGS_FOR_BUILD)" \
+ "EXPECT=$(EXPECT)" \
+ "FLEX=$(FLEX)" \
+ "INSTALL=$(INSTALL)" \
+--- a/Makefile.tpl
++++ b/Makefile.tpl
+@@ -172,6 +172,7 @@
+ # built for the build system to override those in BASE_FLAGS_TO_PASS.
+ EXTRA_BUILD_FLAGS = \
+ CFLAGS="$(CFLAGS_FOR_BUILD)" \
++ CXXFLAGS="$(CXXFLAGS_FOR_BUILD)" \
+ LDFLAGS="$(LDFLAGS_FOR_BUILD)"
+
+ # This is the list of directories to built for the host system.
diff --git a/6.4.0/gentoo/README.history b/6.4.0/gentoo/README.history
index 2294b26..012b265 100644
--- a/6.4.0/gentoo/README.history
+++ b/6.4.0/gentoo/README.history
@@ -1,5 +1,6 @@
1.7 TODO
+ 101_all_x32-fix-eh-return-address.patch
+ + 102_all_respect-build-cxxflags.patch
1.6 18 Aug 2018
+ 100_all_isl-include.patch
1.5 17 Aug 2018