aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-24 12:02:03 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-24 12:02:03 +0000
commit97a14fe1be5d6b6bf83ab60ac81ce032a522906c (patch)
tree27a43ded19294160d186111ca93a641b9b1635cb /4.8.1/gentoo
parentfix build time warnings due to missing header for warning() prototype (diff)
downloadgcc-patches-97a14fe1be5d6b6bf83ab60ac81ce032a522906c.tar.gz
gcc-patches-97a14fe1be5d6b6bf83ab60ac81ce032a522906c.tar.bz2
gcc-patches-97a14fe1be5d6b6bf83ab60ac81ce032a522906c.zip
sync poison patch with latest in OE
Diffstat (limited to '4.8.1/gentoo')
-rw-r--r--4.8.1/gentoo/67_all_gcc-poison-system-directories.patch76
-rw-r--r--4.8.1/gentoo/README.history1
2 files changed, 42 insertions, 35 deletions
diff --git a/4.8.1/gentoo/67_all_gcc-poison-system-directories.patch b/4.8.1/gentoo/67_all_gcc-poison-system-directories.patch
index 72b7e0d..dd20ff2 100644
--- a/4.8.1/gentoo/67_all_gcc-poison-system-directories.patch
+++ b/4.8.1/gentoo/67_all_gcc-poison-system-directories.patch
@@ -1,35 +1,26 @@
grabbed from openembedded
-Upstream-Status: Inappropriate [distribution: codesourcery]
-
- gcc/
- 2008-07-02 Joseph Myers <joseph@codesourcery.com>
- * c-incpath.c: Include toplev.h.
- (merge_include_chains): Use warning instead of cpp_error for
- system directory poisoning diagnostic.
- * Makefile.in (c-incpath.o): Depend on toplev.h.
- * gcc.c (LINK_COMMAND_SPEC): Pass
- --error-poison-system-directories if
- -Werror=poison-system-directories.
-
- 2007-06-13 Joseph Myers <joseph@codesourcery.com>
- * common.opt (--Wno-poison-system-directories): New.
- * doc/invoke.texi (-Wno-poison-system-directories): Document.
- * c-incpath.c: Include flags.h.
- (merge_include_chains): Check flag_poison_system_directories.
- * gcc.c (LINK_COMMAND_SPEC): Pass --no-poison-system-directories
- to linker if -Wno-poison-system-directories.
- * Makefile.in (c-incpath.o): Depend on $(FLAGS_H).
+From 160397ef3c3331099af028f1b8d3e085b07d88ad Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 29 Mar 2013 08:59:00 +0400
+Subject: [PATCH 16/35] gcc: poison-system-directories
- 2007-03-20 Daniel Jacobowitz <dan@codesourcery.com>
- Joseph Myers <joseph@codesourcery.com>
- * configure.ac (--enable-poison-system-directories): New option.
- * configure, config.in: Regenerate.
- * c-incpath.c (merge_include_chains): If
- ENABLE_POISON_SYSTEM_DIRECTORIES defined, warn for use of
- /usr/include, /usr/local/include or /usr/X11R6/include.
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Inappropriate [distribution: codesourcery]
+---
+ gcc/Makefile.in | 2 +-
+ gcc/common.opt | 4 ++++
+ gcc/config.in | 6 ++++++
+ gcc/configure | 20 ++++++++++++++++++--
+ gcc/configure.ac | 10 ++++++++++
+ gcc/doc/invoke.texi | 9 +++++++++
+ gcc/gcc.c | 2 ++
+ gcc/incpath.c | 19 +++++++++++++++++++
+ 8 files changed, 69 insertions(+), 3 deletions(-)
+diff --git a/gcc/Makefile.in b/gcc/Makefile.in
+index 54ea04f..90a2bba 100644
--- a/gcc/Makefile.in
+++ b/gcc/Makefile.in
@@ -2018,7 +2018,7 @@ attribs.o : attribs.c $(CONFIG_H) $(SYSTEM_H) coretypes.h $(TM_H) $(TREE_H) \
@@ -41,6 +32,8 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
CFLAGS-prefix.o += -DPREFIX=\"$(prefix)\" -DBASEVER=$(BASEVER_s)
prefix.o: prefix.c $(CONFIG_H) $(SYSTEM_H) coretypes.h prefix.h \
+diff --git a/gcc/common.opt b/gcc/common.opt
+index bdbd3b6..ab86b00 100644
--- a/gcc/common.opt
+++ b/gcc/common.opt
@@ -595,6 +595,10 @@ Wpedantic
@@ -54,6 +47,8 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
Wshadow
Common Var(warn_shadow) Warning
Warn when one local variable shadows another
+diff --git a/gcc/config.in b/gcc/config.in
+index d80fb9f..0524af7 100644
--- a/gcc/config.in
+++ b/gcc/config.in
@@ -138,6 +138,12 @@
@@ -69,6 +64,8 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
/* Define if you want all operations on RTL (the basic data structure of the
optimizer and back end) to be checked for dynamic type safety at runtime.
This is quite expensive. */
+diff --git a/gcc/configure b/gcc/configure
+index 135bbf5..b65d21d 100755
--- a/gcc/configure
+++ b/gcc/configure
@@ -917,6 +917,7 @@ with_gc
@@ -108,6 +105,8 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
# Substitute configuration variables
+diff --git a/gcc/configure.ac b/gcc/configure.ac
+index 6363a21..e226b85 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -5063,6 +5063,16 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
@@ -127,6 +126,8 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
# Substitute configuration variables
AC_SUBST(subdirs)
AC_SUBST(srcdir)
+diff --git a/gcc/doc/invoke.texi b/gcc/doc/invoke.texi
+index 9273d7d..a022622 100644
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
@@ -258,6 +258,7 @@ Objective-C and Objective-C++ Dialects}.
@@ -137,9 +138,9 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
-Wredundant-decls -Wno-return-local-addr @gol
-Wreturn-type -Wsequence-point -Wshadow @gol
-Wsign-compare -Wsign-conversion -Wsizeof-pointer-memaccess @gol
-@@ -4023,6 +4024,14 @@ should check to see whether the two values have ranges that overlap; and
- this is done with the relational operators, so equality comparisons are
- probably mistaken.
+@@ -4007,6 +4008,14 @@ headers---for that, @option{-Wunknown-pragmas} must also be used.
+ for most targets, it is made up of code and thus requires the stack
+ to be made executable in order for the program to work properly.
+@item -Wno-poison-system-directories
+@opindex Wno-poison-system-directories
@@ -149,9 +150,11 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
+directories contain the correct headers and libraries for the target
+system rather than the host.
+
- @item -Wtraditional @r{(C and Objective-C only)}
- @opindex Wtraditional
- @opindex Wno-traditional
+ @item -Wfloat-equal
+ @opindex Wfloat-equal
+ @opindex Wno-float-equal
+diff --git a/gcc/gcc.c b/gcc/gcc.c
+index 86077f8..efdb625 100644
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
@@ -740,6 +740,8 @@ proper position among the other output files. */
@@ -163,20 +166,23 @@ Upstream-Status: Inappropriate [distribution: codesourcery]
%{static:} %{L*} %(mfwrap) %(link_libgcc) " SANITIZER_EARLY_SPEC " %o\
%{fopenmp|ftree-parallelize-loops=*:%:include(libgomp.spec)%(link_gomp)}\
%{fgnu-tm:%:include(libitm.spec)%(link_itm)}\
+diff --git a/gcc/incpath.c b/gcc/incpath.c
+index 018da98..cd41c78 100644
--- a/gcc/incpath.c
+++ b/gcc/incpath.c
@@ -28,6 +28,7 @@
#include "intl.h"
#include "incpath.h"
#include "cppdefault.h"
-+#include "diagnostic.h"
++#include "diagnostic-core.h"
/* Microsoft Windows does not natively support inodes.
VMS has non-numeric inodes. */
-@@ -382,6 +382,25 @@ merge_include_chains (const char *sysroot, cpp_reader *pfile, int verbose)
+@@ -382,6 +382,26 @@ merge_include_chains (const char *sysroot, cpp_reader *pfile, int verbose)
}
fprintf (stderr, _("End of search list.\n"));
}
++
+#ifdef ENABLE_POISON_SYSTEM_DIRECTORIES
+ if (flag_poison_system_directories)
+ {
diff --git a/4.8.1/gentoo/README.history b/4.8.1/gentoo/README.history
index 22d10f6..a14a758 100644
--- a/4.8.1/gentoo/README.history
+++ b/4.8.1/gentoo/README.history
@@ -1,4 +1,5 @@
1.3 (pending)
+ U 67_all_gcc-poison-system-directories.patch
+ 96_all_pr57657_native-intel-cacheparam.patch
1.2 07 Oct 2013