aboutsummaryrefslogtreecommitdiff
path: root/4.8.0
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2013-08-26 08:58:10 +0000
committerMagnus Granberg <zorry@gentoo.org>2013-08-26 08:58:10 +0000
commit32a37c587521824270a5327e044e7bf65d14937b (patch)
treee8a4eb37f0e94c10146d7c1bda3f375ed173081a /4.8.0
parentAdd patch for linking errors with -O3 -march=core-avx2 (bug #475482). Respec... (diff)
downloadgcc-patches-32a37c587521824270a5327e044e7bf65d14937b.tar.gz
gcc-patches-32a37c587521824270a5327e044e7bf65d14937b.tar.bz2
gcc-patches-32a37c587521824270a5327e044e7bf65d14937b.zip
Update gcc 4.8.1 piepatchset to 0.5.7 part2
Diffstat (limited to '4.8.0')
-rw-r--r--4.8.0/pie/15_all_gcc44_decl-tls-model.patch20
-rw-r--r--4.8.0/pie/35_all_gcc48_config_arm.patch33
-rw-r--r--4.8.0/pie/37_all_gcc48_config_ia64.patch6
-rw-r--r--4.8.0/pie/40_all_gcc48_config_esp.patch17
-rw-r--r--4.8.0/pie/README.Changelog25
-rw-r--r--4.8.0/pie/README.history715
6 files changed, 448 insertions, 368 deletions
diff --git a/4.8.0/pie/15_all_gcc44_decl-tls-model.patch b/4.8.0/pie/15_all_gcc44_decl-tls-model.patch
new file mode 100644
index 0000000..09438a0
--- /dev/null
+++ b/4.8.0/pie/15_all_gcc44_decl-tls-model.patch
@@ -0,0 +1,20 @@
+2009-06-13 Magnus Granberg <zorry@ume.nu>
+
+ b.g.o #232601
+ * gcc/varasm.c (decl_tls_model): Check flag_pic instead of flag_shlib.
+
+--- gcc/varasm.c 2009-03-17 21:18:21.000000000 +0100
++++ gcc/varasm.c 2009-04-29 03:10:09.000000000 +0200
+@@ -5607,7 +5607,11 @@
+ bool is_local;
+
+ is_local = targetm.binds_local_p (decl);
+- if (!flag_shlib)
++ #ifdef ENABLE_ESP
++ if (!flag_pic)
++ #else
++ if (!flag_shlib)
++ #endif
+ {
+ if (is_local)
+ kind = TLS_MODEL_LOCAL_EXEC;
diff --git a/4.8.0/pie/35_all_gcc48_config_arm.patch b/4.8.0/pie/35_all_gcc48_config_arm.patch
index 5aecc6b..e50e78e 100644
--- a/4.8.0/pie/35_all_gcc48_config_arm.patch
+++ b/4.8.0/pie/35_all_gcc48_config_arm.patch
@@ -1,10 +1,23 @@
-2013-06-03 Magnus Granberg <zorry@gentoo.org>
+2013-04-01 Magnus Granberg <zorry@gentoo.org>
- * gcc/config/arm/arm.h (DRIVER_SELF_SPECS): Add ESP_DRIVER_SELF_SPEC.
- * gcc/config/arm/elf.h (SUBSUBTARGET_EXTRA_SPECS): Add ESP_EXTRA_SPECS.
+ * gcc/config/arm/arm.h (SUBTARGET_EXTRA_SPECS): Add ESP_EXTRA_SPECS.
+ (DRIVER_SELF_SPECS): Add ESP_DRIVER_SELF_SPEC.
--- a/gcc/config/arm/arm.h 2013-01-15 17:17:28.000000000 +0100
+++ b/gcc/config/arm/arm.h 2013-02-18 22:45:18.327284928 +0100
+@@ -226,8 +226,12 @@ extern void (*arm_lang_output_object_att
+ SUBTARGET_EXTRA_SPECS
+
+ #ifndef SUBTARGET_EXTRA_SPECS
++#ifdef ENABLE_ESP
++#define SUBTARGET_EXTRA_SPECS ESP_EXTRA_SPECS
++#else
+ #define SUBTARGET_EXTRA_SPECS
+ #endif
++#endif
+
+ #ifndef SUBTARGET_CPP_SPEC
+ #define SUBTARGET_CPP_SPEC ""
@@ -2326,6 +2326,11 @@ extern const char *host_detect_local_cpu
# define MCPU_MTUNE_NATIVE_SPECS ""
#endif
@@ -19,17 +32,3 @@
+# define DRIVER_SELF_SPECS MCPU_MTUNE_NATIVE_SPECS
+#endif
#endif /* ! GCC_ARM_H */
---- a/gcc/config/arm/elf.h 2013-01-10 21:38:27.000000000 +0100
-+++ b/gcc/config/arm/elf.h 2013-05-19 02:15:49.595855825 +0200
-@@ -49,7 +49,11 @@
- #endif
-
- #undef SUBSUBTARGET_EXTRA_SPECS
-+#ifdef ENABLE_ESP
-+#define SUBSUBTARGET_EXTRA_SPECS ESP_EXTRA_SPECS
-+#else
- #define SUBSUBTARGET_EXTRA_SPECS
-+#endif
-
- #ifndef ASM_SPEC
- #define ASM_SPEC "\
diff --git a/4.8.0/pie/37_all_gcc48_config_ia64.patch b/4.8.0/pie/37_all_gcc48_config_ia64.patch
index ba71922..bae8914 100644
--- a/4.8.0/pie/37_all_gcc48_config_ia64.patch
+++ b/4.8.0/pie/37_all_gcc48_config_ia64.patch
@@ -1,6 +1,6 @@
-2013-06-03 Magnus Granberg <zorry@gentoo.org>
+2013-04-01 Magnus Granberg <zorry@gentoo.org>
- * gcc/config/ia64/linux.h Define DRIVER_SELF_SPECS ESP_DRIVER_SELF_SPEC.
+ * gcc/config/ia64/linux.h Define DRIVER_SELF_SPECS ESP_DRIVER_SELF_SPECS.
* gcc/config/ia64/ia64.h (SUBTARGET_EXTRA_SPECS): Add ESP_EXTRA_SPECS.
--- a/gcc/config/ia64/linux.h 2013-01-10 21:38:27.000000000 +0100
@@ -11,7 +11,7 @@
#define STACK_CHECK_STATIC_BUILTIN 1
+
+#ifdef ENABLE_ESP
-+#define DRIVER_SELF_SPECS ESP_DRIVER_SELF_SPEC
++#define DRIVER_SELF_SPECS ESP_DRIVER_SELF_SPECS
+#endif
--- a/gcc/config/ia64/ia64.h 2013-01-10 21:38:27.000000000 +0100
+++ b/gcc/config/ia64/ia64.h 2013-03-26 02:03:21.052061828 +0100
diff --git a/4.8.0/pie/40_all_gcc48_config_esp.patch b/4.8.0/pie/40_all_gcc48_config_esp.patch
index 805cc2c..83630f2 100644
--- a/4.8.0/pie/40_all_gcc48_config_esp.patch
+++ b/4.8.0/pie/40_all_gcc48_config_esp.patch
@@ -1,23 +1,23 @@
-2013-08-10 Magnus Granberg <zorry@gentoo.org>
+2013-02-14 Magnus Granberg <zorry@gentoo.org>
* gcc/esp.h New file to support --enable-esp
- Version 20130810.1
+ Version 20130214.1
--- gcc/config/esp.h 2010-04-09 16:14:00.000000000 +0200
+++ gcc/config/esp.h 2012-06-23 01:00:31.248348491 +0200
-@@ -0,0 +1,128 @@
+@@ -0,0 +1,127 @@
+/* License terms see GNU GENERAL PUBLIC LICENSE Version 3.
-+ * Version 20130810.1
++ * Version 20130214.1
+ * Magnus Granberg (Zorry) <zorry@gentoo.org> */
+#ifndef GCC_ESP_H
+#define GCC_ESP_H
+
-+/* This file will add -fstack-protector-all, -fstack-check, -fPIE, -pie and -z now
++/* This file will add -fstack-protector-all, -fPIE, -pie and -z now
+ as default if the defines and the spec allow it.
+ Added a hack for gcc-specs-* in toolchain-funcs.eclass and _filter-hardened in flag-o-matic.eclass
+ to support older hardened GCC patches and we don't need to change the code on gcc-specs-* and _filter-hardened.
+ This will add some unsupported upstream commands options as -nopie and -nonow.
-+ -D__KERNEL__ is added so we don't have -fPIE, -pie and -fstack-protector-all and -fstack-check when building kernels.
++ -D__KERNEL__ is added so we don't have -fPIE, -pie and -fstack-protector-all when building kernels.
+ ESP_CC1_SPEC is added to CC1_SPEC.
+ ESP_CC1_STRICT_OVERFLOW_SPEC is added so we don't disable the strict-overflow check.
+ ESP_LINK_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
@@ -28,7 +28,7 @@
+ /* Hack to support gcc-specs-* in toolchain-funcs.eclass and _filter-hardened in flag-o-matic.eclass */
+ #define ESP_CC1_SPEC " %(esp_cc1_ssp) %(esp_cc1_pie) %(esp_cc1_strict_overflow)"
+ #if defined ( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )
-+ #define ESP_CC1_SSP_SPEC "%{!fno-stack-protector: %{!fno-stack-protector-all: %{!fno-stack-check: }}}"
++ #define ESP_CC1_SSP_SPEC "%{!fno-stack-protector: %{!fno-stack-protector-all: }}"
+ #else
+ #define ESP_CC1_SSP_SPEC ""
+ #endif
@@ -54,8 +54,7 @@
+ #if defined ( EFAULT_SSP ) || defined ( EFAULT_PIE_SSP )
+ #define ESP_OPTIONS_SSP_SPEC \
+ "%{nostdlib|nodefaultlibs|fno-stack-protector| \
-+ fstack-protector|fstack-protector-all:;:-fstack-protector-all} \
-+ %{fstack-check|fstack-check=*:;: -fstack-check}"
++ fstack-protector|fstack-protector-all:;:-fstack-protector-all}"
+ #else
+ #define ESP_OPTIONS_SSP_SPEC ""
+ #endif
diff --git a/4.8.0/pie/README.Changelog b/4.8.0/pie/README.Changelog
index e3ec163..b73e521 100644
--- a/4.8.0/pie/README.Changelog
+++ b/4.8.0/pie/README.Changelog
@@ -1,12 +1,3 @@
-0.5.7 Magnus Granberg <zorry@gentoo.org>
-
- * gcc/config/esp.h Add -fstack-check as default.
-
-0.5.6 Magnus Granberg <zorry@gentoo.org>
-
- * gcc/config/ia64/linux.h Change ESP_DRIVER_SELF_SPECS To ESP_DRIVER_SELF_SPEC
- * gcc/config/arm/elf.h (SUBSUBTARGET_EXTRA_SPECS): Add ESP_EXTRA_SPECS.
-
0.5.5 Magnus Granberg <zorry@gentoo.org>
* configure.ac Add mips
@@ -17,19 +8,19 @@
* gcc/Makefile.in Bumped for 4.8.0 release
* gcc/gcc.c Remove ESP_EXTRA_SPECS and
ESP_COMMAND_OPTIONS_SPEC
- * gcc/config/rs6000/sysv4.h Add ESP_DRIVER_SELF_SPEC
+ * gcc/config/rs6000/sysv4.h Add ESP_DRIVER_SELF_SPECS
and ESP_EXTRA_SPECS
- * gcc/config/i386/gnu-user-common.h Add ESP_DRIVER_SELF_SPEC
- * gcc/config/i386/gnu-user.h Add ESP_DRIVER_SELF_SPEC
- * gcc/config/i386/i386.h Add ESP_DRIVER_SELF_SPEC
- * gcc/config/arm/arm.h Add ESP_DRIVER_SELF_SPEC and
+ * gcc/config/i386/gnu-user-common.h Add ESP_DRIVER_SELF_SPECS
+ * gcc/config/i386/gnu-user.h Add ESP_DRIVER_SELF_SPECS
+ * gcc/config/i386/i386.h Add ESP_DRIVER_SELF_SPECS
+ * gcc/config/arm/arm.h Add ESP_DRIVER_SELF_SPECS and
ESP_EXTRA_SPECS
- * gcc/config/mips/gnu-user.h Add ESP_DRIVER_SELF_SPEC
- * gcc/config/mips/gnu-user64.h Add ESP_DRIVER_SELF_SPEC
+ * gcc/config/mips/gnu-user.h Add ESP_DRIVER_SELF_SPECS
+ * gcc/config/mips/gnu-user64.h Add ESP_DRIVER_SELF_SPECS
* gcc/config/mips/mips.h Add ESP_EXTRA_SPECS
* gcc/config/ia64/linux.h Add ESP_DRIVER_SELF_SPECS
* gcc/config/ia64/ia64.h Add ESP_EXTRA_SPECS
- * gcc/config/esp.h Bump for ESP_DRIVER_SELF_SPEC support
+ * gcc/config/esp.h Bump for ESP_DRIVER_SELF_SPECS support
0.5.4 Magnus Granberg <zorry@gentoo.org>
diff --git a/4.8.0/pie/README.history b/4.8.0/pie/README.history
index 18bdd75..b266a1a 100644
--- a/4.8.0/pie/README.history
+++ b/4.8.0/pie/README.history
@@ -1,322 +1,393 @@
-0.5.7 10 Jul 2013
- U 35_all_gcc48_config_esp.h.patches
- - 15_all_gcc44_decl-tls-model.patch
-0.5.6 03 Jun 2013
- U 35_all_gcc48_config_arm.patches
- U 37_all_gcc48_config_ia64.patch
-0.5.5 31 Mar 2013
- - 01_all_gcc47_configure.patch
- + 01_all_gcc48_configure.patch
- - 02_all_gcc47_config.in.patch
- + 02_all_gcc48_config.in.patch
- - 03_all_gcc47_Makefile.in.patch
- + 03_all_gcc48_Makefile.in.patch
- - 05_all_gcc47_gcc.c.patch
- - 05_all_gcc48_gcc.c.patch
- - 33_all_gcc46_config_rs6000_linux64.h.patch
- + 33_all_gcc48_config_rs6000.patch
- - 34_all_gcc47_config_all_gnu_user.patch
- + 34_all_gcc48_config_i386.patch
- + 35_all_gcc48_config_arm.patch
- + 36_all_gcc48_config_mips.patch
- + 37_all_gcc48_config_ia64.patch
- - 35_all_gcc47_config_esp.h.patch
- - 35_all_gcc48_config_esp.h.patch
- U README
-0.5.4 02 Oct 2012
- U 01_all_gcc47_configure.patch
- + 01_all_gcc47_configure.ac.patch
-0.5.3 06 Apr 2012
- U 01_all_gcc47_configure.patch
- + 02_all_gcc47_config.in.patch
- - 02_all_gcc45_config.in.patch
- + 06_all_gcc46_esp.h.patch
- - 06_all_gcc45_esp.h.patch
-0.5.2 24 Jan 2012
- + 16_all_gcc47_nopie_option.patch
-0.5.1 17 Jan 2012
- + 01_all_gcc47_configure.patch
- - 10_all_gcc45_configure.patch
- + 03_all_gcc47_Makefile.in.patch
- - 12_all_gcc46_Makefile.in.patch
- + 02_all_gcc45_config.in.patch
- - 11_all_gcc45_config.in.patch
- + 05_all_gcc46_gcc.c.patch
- - 20_all_gcc46_gcc.c.patch
- + 06_all_gcc45_esp.h.patch
- - 30_all_gcc45_esp.h.patch
- + 10_all_gcc46_default-ssp.patch
- - 22_all_gcc46-default-ssp.patch
- + 15_all_gcc44_decl-tls-model.patch
- - 21_all_gcc44_decl-tls-model.patch
- + 20_all_gcc46_config_crtbeginp.patch
- - 35_all_gcc46_config_crtbegints.patch
- + 24_all_gcc44_invoke.texi.patch
- + 60_all_gcc44_invoke.texi.patch
-0.5.0 07 Dec 2011
- + 35_all_gcc46_config_crtbeginp.patch
- - 35_all_gcc46_config_crtbegints.patch
- U 10_all_gcc45_configure.patch
- U 12_all_gcc46_Makefile.in.patch
- + 11_all_gcc45_config.in.patch
- - 11_all_gcc44_config.in.patch
- + 30_all_gcc45_esp.h.patch
- - 30_all_gcc44_esp.h.patch
-0.4.9 09 Nov 2011
- U 12_all_gcc46_Makefile.in.patch
-0.4.8 26 Mar 2011
- U 22_all_gcc46-default-ssp.patch
-0.4.7 05 Mar 2011
- U 20_all_gcc46_gcc.c.patch
- + 22_all_gcc46-default-ssp.patch
- - 30_all_gcc46_esp.h.patch
- + 30_all_gcc44_esp.h.patch
- U 33_all_gcc46_config_rs6000_linux64.h.patch
- U 35_all_gcc46_config_crtbegints.patch
-0.4.6 07 Jan 2011
- + 12_all_gcc46_Makefile.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 20_all_gcc46_gcc.c.patch
- - 20_all_gcc44_gcc.c.patch
- + 30_all_gcc46_esp.h.patch
- - 30_all_gcc44_esp.h.patch
- + 33_all_gcc46_config_rs6000_linux64.h.patch
- - 33_all_gcc45_config_rs6000_linux64.h.patch
- + 35_all_gcc46_config_crtbegints.patch
- - 35_all_gcc44_config_crtbegints.patch
- - 40_all_gcc44_obj_lang-specs.h.patch
- - 40_all_gcc44_objp_lang-specs.h.patch
- - 40_all_gcc44_cp_lang-specs.h.patch
-0.4.5 18 Jun 2010
- U 35_all_gcc44_config_crtbegints.patch
-0.4.4 26 May 2010
- U 30_all_gcc44_esp.h.patch
-0.4.3 26 May 2010
- U 20_all_gcc44_gcc.c.patch
- U 30_all_gcc44_esp.h.patch
-0.4.2 24 May 2010
- U 10_all_gcc44_configure.patch
- U 12_all_gcc44_Makefile.in.patch
- U 11_all_gcc44_config.in.patch
- U 30_all_gcc44_esp.h.patch
-0.4.1 29 Apr 2010
- U 10_all_gcc45_configure.patch
- U 12_all_gcc45_Makefile.in.patch
- U 11_all_gcc44_config.in.patch
- U 30_all_gcc44_esp.h.patch
-
-0.4.0 19 Apr 2010
- U 10_all_gcc45_configure.patch
- U 12_all_gcc45_Makefile.in.patch
- U 11_all_gcc44_config.in.patch
- U 20_all_gcc45_gcc.c.patch
- - 30_all_gcc44_espf.h.patch
- + 30_all_gcc44_esp.h.patch
-
-0.3.9 14 Apr 2010
- U 10_all_gcc45_configure.patch
- - 50_all_gcc44_no_ssp_tls_uclibc.patch
- U 33_all_gcc45_config_rs6000_linux64.h.patch
-
-0.3.8 10 Apr 2010
- 10_all_gcc44_configure.patch
- 11_all_gcc44_config.in.patch
- 20_all_gcc44_gcc.c.patch
- 30_all_gcc44_espf.h.patch
-
-0.3.7 10 Feb 2010
- 20_all_gcc44_gcc.c.patch
- 30_all_gcc44_espf.h.patch
- 10_all_gcc44_configure.patch
-
-0.3.6 23 Dec 2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 30_all_gcc44_espf.h.patch
- + 30_all_gcc44_espf.h.patch
- - README.Changelog
- + README.Changelog
- - README.history
- + README.history
- - README
- + README
-
-0.3.5 24 Sep 2009
- - 30_all_gcc44_espf.h.patch
- + 30_all_gcc44_espf.h.patch
- - 35_all_gcc44_config_crtbegints.patch
- + 35_all_gcc44_config_crtbegints.patch
- + 33_all_gcc44_config_rs6000_linux64.h.patch
- - README.Changelog
- + README.Changelog
- - README.history
- + README.history
- + README.Gentoo.patches
-
-0.3.4 11 Sep 2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- - 23_all_gcc44_opts.c.patch
- - 30_all_gcc44_espf.h.patch
- + 30_all_gcc44_espf.h.patch
- + 35_all_gcc44_config_crtbegints.patch
- + 60_all_gcc44_invoke.texi.patch
- - README.Changelog
- + README.Changelog
- - README.history
- + README.history
- - README
- + README
-
-0.3.3 14 Aug 2009
- - 23_all_gcc44_opts.c.patch
- + 23_all_gcc44_opts.c.patch
-
-0.3.2 09 Aug 2009
- + 50_all_gcc44_no_ssp_tls_uclibc.patch
- + README.Changelog
- + README.history
- - 23_all_gcc44_opts.c.patch
- + 23_all_gcc44_opts.c.patch
- - 30_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
-
-0.3.1 23 Jul 2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
-
-0.3.0 23 Jul 2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- + 40_all_gcc44_obj_lang-specs.h.patch
- + 40_all_gcc44_objp_lang-specs.h.patch
- + 40_all_gcc44_cp_lang-specs.h.patch
- - 50_all_gcc44_gentoo_v20090614.1.patch
- - 30_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
-
-0.2.9 14 Jun 2009
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 30_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
- - 50_all_gcc44_gentoo_v20090612.2.patch
- + 50_all_gcc44_gentoo_v20090614.1.patch
-
-0.2.8 12 Jun 2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 22_all_gcc44-toplev.c.patch
- - 25_all_gcc44-espf.h.patch
- + 30_all_gcc44-espf.h.patch
- + 50_all_gcc44_gentoo_v20090612.2.patch
-
-0.2.7 29 May 2009
- - 11_all_gcc44_config.in.patch
- + 11_all_gcc44_config.in.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- + 23_all_gcc44_opts.c.patch
- - 25_all_gcc44-espf.h.patch
- + 25_all_gcc44-espf.h.patch
- - 30_all_gcc44-config-defaul-linux.patch
-
-0.2.6 28 May 2009
- + 22_all_gcc44-toplev.c.patch
- - 25_all_gcc44-espf.h.patch
- + 25_all_gcc44-espf.h.patch
- - 30_all_gcc44-config-defaul-linux.patch
- + 30_all_gcc44-config-defaul-linux.patch
-
-0.2.5 27 May 2009
- - 10_all_gcc44_configure.patch
- + 10_all_gcc44_configure.patch
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- - 25_all_gcc44-espf.h.patch
- + 25_all_gcc44-espf.h.patch
- - 30_all_gcc44-config-defaul-linux.patch
- + 30_all_gcc44-config-defaul-linux.patch
- - 40_all_gcc44-gentoo.patch
-
-0.2.4 08 May 2009
- - 12_all_gcc44_Makefile.in.patch
- + 12_all_gcc44_Makefile.in.patch
-
-0.2.3 08 May 2009
- - 20_all_gcc44_gcc.c.patch
- + 20_all_gcc44_gcc.c.patch
- - 40_all_gcc44-gentoo.patch
- + 40_all_gcc44-gentoo.patch
-
-0.2.2 04 May 2009
- + 10_all_gcc44_configure.patch
- + 11_all_gcc44_config.in.patch
- + 12_all_gcc44_Makefile.in.patch
- + 20_all_gcc44_gcc.c.patch
- + 21_all_gcc44_decl-tls-model.patch
- + 25_all_gcc44-espf.h.patch
- + 30_all_gcc44-config-defaul-linux.patch
- + 40_all_gcc44-gentoo.patch
- - 01_all_gcc44-configure.patch
- - 10_all_gcc44-gcc_configure.patch
- - 11_all_gcc44-gcc_config.in.patch
- - 12_all_gcc44-gcc_config.gcc.patch
- - 13_all_gcc44-gcc_Makefile.in.patch
- - 15_all_gcc44-libgcc_config.host.patch
- - 16_all_gcc44-libgcc_configure.patch
- - 17_all_gcc44-libgcc_Makefile.in.patch
- - 21_all_gcc44-gcc_espf.h.patch
- - 22_all_gcc44-gcc_gcc.c.patch
- - 23_all_gcc44-gcc_varasm.c.patch
- - 30_all_gcc44-add-crt-start-endfiles-linux.patch
-
-0.2.1 28 Apr 2009
- + 01_all_gcc44-configure.patch
- + 10_all_gcc44-gcc_configure.patch
- + 11_all_gcc44-gcc_config.in.patch
- + 12_all_gcc44-gcc_config.gcc.patch
- + 13_all_gcc44-gcc_Makefile.in.patch
- + 15_all_gcc44-libgcc_config.host.patch
- + 16_all_gcc44-libgcc_configure.patch
- + 17_all_gcc44-libgcc_Makefile.in.patch
- + 21_all_gcc44-gcc_espf.h.patch
- + 22_all_gcc44-gcc_gcc.c.patch
- + 23_all_gcc44-gcc_varasm.c.patch
- + 30_all_gcc44-add-crt-start-endfiles-linux.patch
- - 00_all_gcc4.4-cvs-incompat.patch
- - 05_all_gcc4.4-compile-no-ssp.patch
- - 10_all_gcc4.4-hardened-minispecs-support.patch
- - 11_all_gcc4.4-decl-tls-model.patch
- - 12_all_gcc4.4-fortify-minispecs-support.patch
- - 20-all_gcc4.4-default-crt-start-endfile.patch
- - 30-all_gcc4.4-crtbeginTS-fno-PIE.patch
-
-0.1.0 16 Apr 2009
- + 00_all_gcc4.4-cvs-incompat.patch
- + 05_all_gcc4.4-compile-no-ssp.patch
- + 10_all_gcc4.4-hardened-minispecs-support.patch
- + 11_all_gcc4.4-decl-tls-model.patch
- + 12_all_gcc4.4-fortify-minispecs-support.patch
- + 20-all_gcc4.4-default-crt-start-endfile.patch
- + 30-all_gcc4.4-crtbeginTS-fno-PIE.patch
+
+
+
+
+<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
+"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
+<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
+<!-- ViewVC :: http://www.viewvc.org/ -->
+<head>
+<title>[gentoo] Log of /src/patchsets/gcc/4.8.0/pie/README.history</title>
+<meta name="generator" content="ViewVC 1.1.20" />
+<link rel="shortcut icon" href="/static/images/favicon.ico" type="image/x-icon" />
+<link rel="stylesheet" href="/static/styles.css" type="text/css" />
+
+</head>
+<body>
+<div class="vc_navheader">
+<table><tr>
+<td><strong><a href="/cgi-bin/viewvc.cgi"><span class="pathdiv">/</span></a><a href="/cgi-bin/viewvc.cgi/gentoo/">[gentoo]</a><span class="pathdiv">/</span><a href="/cgi-bin/viewvc.cgi/gentoo/src/">src</a><span class="pathdiv">/</span><a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/">patchsets</a><span class="pathdiv">/</span><a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/">gcc</a><span class="pathdiv">/</span><a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/">4.8.0</a><span class="pathdiv">/</span><a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/">pie</a><span class="pathdiv">/</span>README.history</strong></td>
+<td style="text-align: right;">
+</td>
+</tr></table>
+</form>
+</div>
+<div style="float: right; padding: 5px;"><a href="http://www.gentoo.org/" title="Gentoo Linux"><img src="/static/images/gentoo-new.gif" alt="Gentoo" width="182" height="59" /></a></div>
+<h1>Log of /src/patchsets/gcc/4.8.0/pie/README.history</h1>
+
+<p style="margin:0;">
+
+<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/"><img src="/static/images/back_small.png" class="vc_icon" alt="Parent Directory" /> Parent Directory</a>
+
+| <a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log"><img src="/static/images/log.png" class="vc_icon" alt="Revision Log" /> Revision Log</a>
+
+
+
+
+</p>
+
+<hr />
+<table class="auto">
+
+
+
+<tr>
+<td>Links to HEAD:</td>
+<td>
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=markup">view</a>)
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history">download</a>)
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=annotate">annotate</a>)
+</td>
+</tr>
+
+
+
+</table>
+
+
+
+
+
+
+
+
+<div>
+<hr />
+
+<a name="rev1.3"></a>
+<a name="HEAD"></a>
+
+
+Revision <strong>1.3</strong> -
+
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?revision=1.3&amp;view=markup">view</a>)
+
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?revision=1.3">download</a>)
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?annotate=1.3">annotate</a>)
+
+
+
+- <a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;r1=1.3">[select for diffs]</a>
+
+
+
+
+<br />
+
+<em>Thu Aug 22 15:10:18 2013 UTC</em>
+(3 days, 17 hours ago)
+by <em>zorry</em>
+
+
+<br />Branch:
+
+<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;pathrev=MAIN"><strong>MAIN</strong></a>
+
+
+
+<br />CVS Tags:
+
+<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;pathrev=HEAD"><strong>HEAD</strong></a>
+
+
+
+
+
+
+<br />Changes since <strong>1.2: +3 -0 lines</strong>
+
+
+
+
+
+
+
+
+<br />Diff to <a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?r1=1.2&amp;r2=1.3">previous 1.2</a>
+
+
+
+
+
+
+
+
+
+
+<pre class="vc_log">Update gcc 4.8.1 piepatchset to 0.5.7
+
+</pre>
+</div>
+
+
+
+<div>
+<hr />
+
+<a name="rev1.2"></a>
+
+
+Revision <strong>1.2</strong> -
+
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?revision=1.2&amp;view=markup">view</a>)
+
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?revision=1.2">download</a>)
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?annotate=1.2">annotate</a>)
+
+
+
+- <a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;r1=1.2">[select for diffs]</a>
+
+
+
+
+<br />
+
+<em>Sun Jun 2 23:06:46 2013 UTC</em>
+(2 months, 3 weeks ago)
+by <em>zorry</em>
+
+
+<br />Branch:
+
+<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;pathrev=MAIN"><strong>MAIN</strong></a>
+
+
+
+
+
+
+
+<br />Changes since <strong>1.1: +3 -0 lines</strong>
+
+
+
+
+
+
+
+
+<br />Diff to <a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?r1=1.1&amp;r2=1.2">previous 1.1</a>
+
+
+
+
+
+
+
+
+
+
+<pre class="vc_log">Add gcc 4.8.1 piepatchset
+
+</pre>
+</div>
+
+
+
+<div>
+<hr />
+
+<a name="rev1.1"></a>
+
+
+Revision <strong>1.1</strong> -
+
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?revision=1.1&amp;view=markup">view</a>)
+
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?revision=1.1">download</a>)
+
+(<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?annotate=1.1">annotate</a>)
+
+
+
+- <a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;r1=1.1">[select for diffs]</a>
+
+
+
+
+<br />
+
+<em>Mon Apr 1 00:14:07 2013 UTC</em>
+(4 months, 3 weeks ago)
+by <em>zorry</em>
+
+
+<br />Branch:
+
+<a href="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history?view=log&amp;pathrev=MAIN"><strong>MAIN</strong></a>
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+<pre class="vc_log">Add piepatchset for gcc 4.8.0
+
+</pre>
+</div>
+
+
+
+
+ <hr />
+<p><a name="diff"></a>
+This form allows you to request diffs between any two revisions of this file.
+For each of the two "sides" of the diff,
+
+select a symbolic revision name using the selection box, or choose
+'Use Text Field' and enter a numeric revision.
+
+</p>
+<form method="get" action="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history" id="diff_select">
+<table cellpadding="2" cellspacing="0" class="auto">
+<tr>
+<td>&nbsp;</td>
+<td>
+<input type="hidden" name="view" value="diff"/>
+Diffs between
+
+<select name="r1">
+<option value="text" selected="selected">Use Text Field</option>
+
+<option value="1.3:MAIN">MAIN</option>
+
+<option value="1.3:HEAD">HEAD</option>
+
+</select>
+<input type="text" size="12" name="tr1"
+value="1.3"
+onchange="document.getElementById('diff_select').r1.selectedIndex=0" />
+
+and
+
+<select name="r2">
+<option value="text" selected="selected">Use Text Field</option>
+
+<option value="1.3:MAIN">MAIN</option>
+
+<option value="1.3:HEAD">HEAD</option>
+
+</select>
+<input type="text" size="12" name="tr2"
+value="1.1"
+onchange="document.getElementById('diff_select').r2.selectedIndex=0" />
+
+</td>
+</tr>
+<tr>
+<td>&nbsp;</td>
+<td>
+Type of Diff should be a
+<select name="diff_format" onchange="submit()">
+<option value="h" selected="selected">Colored Diff</option>
+<option value="l" >Long Colored Diff</option>
+<option value="f" >Full Colored Diff</option>
+<option value="u" >Unidiff</option>
+<option value="c" >Context Diff</option>
+<option value="s" >Side by Side</option>
+</select>
+<input type="submit" value=" Get Diffs " />
+</td>
+</tr>
+</table>
+</form>
+
+
+
+<form method="get" action="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history">
+<div>
+<hr />
+<a name="logsort"></a>
+<input type="hidden" name="view" value="log"/>
+Sort log by:
+<select name="logsort" onchange="submit()">
+<option value="cvs" >Not sorted</option>
+<option value="date" selected="selected">Commit date</option>
+<option value="rev" >Revision</option>
+</select>
+<input type="submit" value=" Sort " />
+</div>
+</form>
+
+<br>
+<tr>
+<td>Sticky Tag:</td>
+<td><form method="get" action="/cgi-bin/viewvc.cgi/gentoo/src/patchsets/gcc/4.8.0/pie/README.history" style="display: inline">
+<div style="display: inline">
+<input type="hidden" name="view" value="log"/>
+
+
+<select name="pathrev" onchange="submit()">
+<option value=""></option>
+
+<optgroup label="Branches">
+
+
+<option>MAIN</option>
+
+
+</optgroup>
+
+<optgroup label="Non-branch tags">
+
+
+<option>HEAD</option>
+
+
+</optgroup>
+
+</select>
+
+<input type="submit" value="Set" />
+</div>
+</form>
+
+</td>
+</tr>
+
+<hr />
+<table>
+<tr>
+<td>&nbsp;</td>
+<td style="text-align: right;"><strong><a href="/static/help_log.html">ViewVC Help</a></strong></td>
+</tr>
+<tr>
+<td>Powered by <a href="http://viewvc.tigris.org/">ViewVC 1.1.20</a></td>
+<td style="text-align: right;">&nbsp;</td>
+</tr>
+</table>
+</body>
+</html>
+
+