aboutsummaryrefslogtreecommitdiff
path: root/4.1.0
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-03-14 06:04:25 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-03-14 06:04:25 +0000
commit61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d (patch)
tree85df3a731bfc9251bc2ed8ca015c2aba5942bf01 /4.1.0
parentcut pointless wchar hunk (diff)
downloadgcc-patches-61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d.tar.gz
gcc-patches-61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d.tar.bz2
gcc-patches-61b0a5951ea7f9223b1e5e74b1f88d6cd6ab244d.zip
Patch to fix bug #114359; backported from trunk
Diffstat (limited to '4.1.0')
-rw-r--r--4.1.0/gentoo/04_all_gcc42-boehmgc-include.patch281
1 files changed, 281 insertions, 0 deletions
diff --git a/4.1.0/gentoo/04_all_gcc42-boehmgc-include.patch b/4.1.0/gentoo/04_all_gcc42-boehmgc-include.patch
new file mode 100644
index 0000000..f589dbb
--- /dev/null
+++ b/4.1.0/gentoo/04_all_gcc42-boehmgc-include.patch
@@ -0,0 +1,281 @@
+--- libobjc/configure 2006/01/24 21:44:57 110181
++++ libobjc/configure 2006/01/24 21:57:22 110182
+@@ -309,7 +309,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os build_subdir host_subdir target_subdir VERSION OBJC_BOEHM_GC toplevel_srcdir host host_cpu host_vendor host_os target target_cpu target_vendor target_os target_noncanonical glibcpp_srcdir toolexecdir toolexeclibdir includedirname libext CC ac_ct_CC EXEEXT OBJEXT extra_ldflags_libobjc CFLAGS AS ac_ct_AS AR ac_ct_AR RANLIB ac_ct_RANLIB INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA MAINTAINER_MODE_TRUE MAINTAINER_MODE_FALSE MAINT LN_S STRIP ac_ct_STRIP LIBTOOL SET_MAKE CPP CPPFLAGS EGREP LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os build_subdir host_subdir target_subdir VERSION OBJC_BOEHM_GC OBJC_BOEHM_GC_INCLUDES toplevel_srcdir host host_cpu host_vendor host_os target target_cpu target_vendor target_os target_noncanonical glibcpp_srcdir toolexecdir toolexeclibdir includedirname libext CC ac_ct_CC EXEEXT OBJEXT extra_ldflags_libobjc CFLAGS AS ac_ct_AS AR ac_ct_AR RANLIB ac_ct_RANLIB INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA MAINTAINER_MODE_TRUE MAINTAINER_MODE_FALSE MAINT LN_S STRIP ac_ct_STRIP LIBTOOL SET_MAKE CPP CPPFLAGS EGREP LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -957,7 +957,7 @@
+ else
+ echo "$as_me: WARNING: no configuration information is in $ac_dir" >&2
+ fi
+- cd $ac_popdir
++ cd "$ac_popdir"
+ done
+ fi
+
+@@ -1467,14 +1467,21 @@
+ if test "${enable_objc_gc+set}" = set; then
+ enableval="$enable_objc_gc"
+ case $enable_objc_gc in
+- no) OBJC_BOEHM_GC='' ;;
+- *) OBJC_BOEHM_GC=libobjc_gc.la ;;
++ no)
++ OBJC_BOEHM_GC=''
++ OBJC_BOEHM_GC_INCLUDES=''
++ ;;
++ *)
++ OBJC_BOEHM_GC=libobjc_gc.la
++ OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
++ ;;
+ esac
+ else
+- OBJC_BOEHM_GC=''
++ OBJC_BOEHM_GC=''; OBJC_BOEHM_GC_INCLUDES=''
+ fi;
+
+
++
+ # -----------
+ # Directories
+ # -----------
+@@ -2248,8 +2255,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2307,8 +2313,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2424,8 +2429,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2479,8 +2483,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2525,8 +2528,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -2570,8 +2572,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -3765,7 +3766,7 @@
+ case $host in
+ *-*-irix6*)
+ # Find out which ABI we are using.
+- echo '#line 3768 "configure"' > conftest.$ac_ext
++ echo '#line 3769 "configure"' > conftest.$ac_ext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ (eval $ac_compile) 2>&5
+ ac_status=$?
+@@ -3912,8 +3913,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4482,8 +4482,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4653,8 +4652,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4717,8 +4715,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -4875,8 +4872,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5043,8 +5039,7 @@
+ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -z "$ac_c_werror_flag"
+- || test ! -s conftest.err'
++ { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -5193,7 +5188,7 @@
+ :
+ else
+ cat > conftest.$ac_ext << EOF
+-#line 5196 "configure"
++#line 5191 "configure"
+ @interface Frob
+ @end
+ @implementation Frob
+@@ -5906,6 +5901,7 @@
+ s,@target_subdir@,$target_subdir,;t t
+ s,@VERSION@,$VERSION,;t t
+ s,@OBJC_BOEHM_GC@,$OBJC_BOEHM_GC,;t t
++s,@OBJC_BOEHM_GC_INCLUDES@,$OBJC_BOEHM_GC_INCLUDES,;t t
+ s,@toplevel_srcdir@,$toplevel_srcdir,;t t
+ s,@host@,$host,;t t
+ s,@host_cpu@,$host_cpu,;t t
+@@ -6115,11 +6111,6 @@
+ *) ac_INSTALL=$ac_top_builddir$INSTALL ;;
+ esac
+
+- if test x"$ac_file" != x-; then
+- { echo "$as_me:$LINENO: creating $ac_file" >&5
+-echo "$as_me: creating $ac_file" >&6;}
+- rm -f "$ac_file"
+- fi
+ # Let's still pretend it is `configure' which instantiates (i.e., don't
+ # use $as_me), people would be surprised to read:
+ # /* config.h. Generated by config.status. */
+@@ -6158,6 +6149,12 @@
+ fi;;
+ esac
+ done` || { (exit 1); exit 1; }
++
++ if test x"$ac_file" != x-; then
++ { echo "$as_me:$LINENO: creating $ac_file" >&5
++echo "$as_me: creating $ac_file" >&6;}
++ rm -f "$ac_file"
++ fi
+ _ACEOF
+ cat >>$CONFIG_STATUS <<_ACEOF
+ sed "$ac_vpsub
+--- libobjc/configure.ac 2006/01/24 21:44:57 110181
++++ libobjc/configure.ac 2006/01/24 21:57:22 110182
+@@ -1,6 +1,6 @@
+ # Process this file with autoconf to produce a configure script.
+ # Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004
+-# Free Software Foundation, Inc.
++# 2005, 2006 Free Software Foundation, Inc.
+ # Originally contributed by Dave Love (d.love@dl.ac.uk).
+ #
+ #This file is part of GCC.
+@@ -73,11 +73,18 @@
+ [ --enable-objc-gc enable the use of Boehm's garbage collector with
+ the GNU Objective-C runtime.],
+ [case $enable_objc_gc in
+- no) OBJC_BOEHM_GC='' ;;
+- *) OBJC_BOEHM_GC=libobjc_gc.la ;;
++ no)
++ OBJC_BOEHM_GC=''
++ OBJC_BOEHM_GC_INCLUDES=''
++ ;;
++ *)
++ OBJC_BOEHM_GC=libobjc_gc.la
++ OBJC_BOEHM_GC_INCLUDES='-I$(top_srcdir)/../boehm-gc/include -I../boehm-gc/include'
++ ;;
+ esac],
+-[OBJC_BOEHM_GC=''])
++[OBJC_BOEHM_GC=''; OBJC_BOEHM_GC_INCLUDES=''])
+ AC_SUBST(OBJC_BOEHM_GC)
++AC_SUBST(OBJC_BOEHM_GC_INCLUDES)
+
+ # -----------
+ # Directories
+--- libobjc/Makefile.in 2006/01/24 21:44:57 110181
++++ libobjc/Makefile.in 2006/01/24 21:57:22 110182
+@@ -1,6 +1,6 @@
+ # Makefile for GNU Objective C runtime library.
+-# Copyright 1993, 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004
+-# Free Software Foundation, Inc.
++# Copyright 1993, 1995, 1996, 1997, 1998, 1999, 2001, 2002, 2003, 2004,
++# 2005, 2006 Free Software Foundation, Inc.
+
+ #This file is part of GCC.
+
+@@ -91,14 +91,17 @@
+ LIBTOOL_CLEAN = $(LIBTOOL) --mode=clean
+ #LIBTOOL_UNINSTALL = $(LIBTOOL) --mode=uninstall
+
++OBJC_GCFLAGS=-DOBJC_WITH_GC=1
++OBJC_THREAD_FILE=thr-objc
++OBJC_BOEHM_GC=@OBJC_BOEHM_GC@
++OBJC_BOEHM_GC_INCLUDES=@OBJC_BOEHM_GC_INCLUDES@
++
+ INCLUDES = -I$(srcdir)/objc -I$(srcdir)/$(MULTISRCTOP)../gcc \
+ -I$(srcdir)/$(MULTISRCTOP)../gcc/config \
+ -I$(MULTIBUILDTOP)../../$(host_subdir)/gcc \
+- -I$(srcdir)/$(MULTISRCTOP)../include
++ -I$(srcdir)/$(MULTISRCTOP)../include \
++ $(OBJC_BOEHM_GC_INCLUDES)
+
+-OBJC_GCFLAGS=-DOBJC_WITH_GC=1
+-OBJC_THREAD_FILE=thr-objc
+-OBJC_BOEHM_GC=@OBJC_BOEHM_GC@
+
+ .SUFFIXES:
+ .SUFFIXES: .c .m .lo