aboutsummaryrefslogtreecommitdiff
path: root/13.1.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-09 11:26:27 +0000
committerSam James <sam@gentoo.org>2022-12-09 11:29:18 +0000
commitf260e88d6d7aac22aabc5d90318f72501b2a1443 (patch)
tree4ae7a9ea9ecea905942207dd41f847efbad2a7e3 /13.1.0
parent12.2.0: scrub patches (diff)
downloadgcc-patches-f260e88d6d7aac22aabc5d90318f72501b2a1443.tar.gz
gcc-patches-f260e88d6d7aac22aabc5d90318f72501b2a1443.tar.bz2
gcc-patches-f260e88d6d7aac22aabc5d90318f72501b2a1443.zip
13.1.0: scrub patches
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '13.1.0')
-rw-r--r--13.1.0/gentoo/09_all_nopie-all-flags.patch4
-rw-r--r--13.1.0/gentoo/10_all_sh-drop-sysroot-suffix.patch6
-rw-r--r--13.1.0/gentoo/11_all_ia64-TEXTREL.patch2
-rw-r--r--13.1.0/gentoo/24_all_DEF_GENTOO_SCP-fstack-clash-protection.patch2
-rw-r--r--13.1.0/musl/25_all_multilib_pure64.patch30
-rw-r--r--13.1.0/musl/50_all_posix_memalign.patch5
6 files changed, 18 insertions, 31 deletions
diff --git a/13.1.0/gentoo/09_all_nopie-all-flags.patch b/13.1.0/gentoo/09_all_nopie-all-flags.patch
index 0f7c769..fe1cd80 100644
--- a/13.1.0/gentoo/09_all_nopie-all-flags.patch
+++ b/13.1.0/gentoo/09_all_nopie-all-flags.patch
@@ -1,8 +1,8 @@
We need to pass NO_PIE_CFLAGS to ALL_* so gcc don't fail when
we compile it with older gcc and pie.
---- a/gcc/Makefile.in 2015-06-25 19:18:12.000000000 +0200
-+++ b/gcc/Makefile.in 2016-04-22 00:12:54.029178860 +0200
+--- a/gcc/Makefile.in
++++ b/gcc/Makefile.in
@@ -1054,10 +1054,10 @@ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@)
ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS)
diff --git a/13.1.0/gentoo/10_all_sh-drop-sysroot-suffix.patch b/13.1.0/gentoo/10_all_sh-drop-sysroot-suffix.patch
index fd3bda5..e778f81 100644
--- a/13.1.0/gentoo/10_all_sh-drop-sysroot-suffix.patch
+++ b/13.1.0/gentoo/10_all_sh-drop-sysroot-suffix.patch
@@ -10,12 +10,6 @@ multilib flavour always prepends sysroot-prefix.
Bug: https://bugs.gentoo.org/511548
Bug: https://gcc.gnu.org/PR42947
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
----
- gcc/config.gcc | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/gcc/config.gcc b/gcc/config.gcc
-index 55c314afdbd..c320f24f123 100644
--- a/gcc/config.gcc
+++ b/gcc/config.gcc
@@ -3328,8 +3328,6 @@ sh-*-elf* | sh[12346l]*-*-elf* | \
diff --git a/13.1.0/gentoo/11_all_ia64-TEXTREL.patch b/13.1.0/gentoo/11_all_ia64-TEXTREL.patch
index 69347f5..f5d0a99 100644
--- a/13.1.0/gentoo/11_all_ia64-TEXTREL.patch
+++ b/13.1.0/gentoo/11_all_ia64-TEXTREL.patch
@@ -2,7 +2,7 @@ Fix textrels on -rdynamic binaries:
Bug: https://gcc.gnu.org/PR84553
Bug: https://bugs.gentoo.org/566118
--- a/gcc/config/ia64/ia64.cc
-+++ a/gcc/config/ia64/ia64.cc
++++ b/gcc/config/ia64/ia64.cc
@@ -10840,12 +10840,14 @@ ia64_hpux_reloc_rw_mask (void)
/* For others, relax this so that relocations to local data goes in
diff --git a/13.1.0/gentoo/24_all_DEF_GENTOO_SCP-fstack-clash-protection.patch b/13.1.0/gentoo/24_all_DEF_GENTOO_SCP-fstack-clash-protection.patch
index 1ed716b..b13215d 100644
--- a/13.1.0/gentoo/24_all_DEF_GENTOO_SCP-fstack-clash-protection.patch
+++ b/13.1.0/gentoo/24_all_DEF_GENTOO_SCP-fstack-clash-protection.patch
@@ -1,7 +1,7 @@
We add -fstack-clash-protection if requested
--- a/gcc/common.opt
-+++ a/gcc/common.opt
++++ b/gcc/common.opt
@@ -2698,7 +2698,7 @@ Common Alias(fstack-check=, specific, no
Insert stack checking code into the program. Same as -fstack-check=specific.
diff --git a/13.1.0/musl/25_all_multilib_pure64.patch b/13.1.0/musl/25_all_multilib_pure64.patch
index 4ff0a25..d55c04c 100644
--- a/13.1.0/musl/25_all_multilib_pure64.patch
+++ b/13.1.0/musl/25_all_multilib_pure64.patch
@@ -1,9 +1,8 @@
https://bugs.gentoo.org/675954
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=90077
-diff -Naur gcc-9.3.0.orig/gcc/config/aarch64/t-aarch64-linux gcc-9.3.0/gcc/config/aarch64/t-aarch64-linux
---- gcc-9.3.0.orig/gcc/config/aarch64/t-aarch64-linux 2020-10-05 02:59:12.767988285 -0700
-+++ gcc-9.3.0/gcc/config/aarch64/t-aarch64-linux 2020-10-05 03:03:32.310816444 -0700
+--- a/gcc/config/aarch64/t-aarch64-linux
++++ b/gcc/config/aarch64/t-aarch64-linux
@@ -22,7 +22,7 @@
LIB1ASMFUNCS = _aarch64_sync_cache_range
@@ -13,9 +12,8 @@ diff -Naur gcc-9.3.0.orig/gcc/config/aarch64/t-aarch64-linux gcc-9.3.0/gcc/confi
MULTIARCH_DIRNAME = $(call if_multiarch,aarch64$(AARCH_BE)-linux-gnu)
MULTILIB_OSDIRNAMES += mabi.ilp32=../libilp32$(call if_multiarch,:aarch64$(AARCH_BE)-linux-gnu_ilp32)
-diff -Naur gcc-9.3.0.orig/gcc/config/i386/t-linux64 gcc-9.3.0/gcc/config/i386/t-linux64
---- gcc-9.3.0.orig/gcc/config/i386/t-linux64 2020-10-05 02:59:12.757989347 -0700
-+++ gcc-9.3.0/gcc/config/i386/t-linux64 2020-10-05 03:24:58.878825272 -0700
+--- a/gcc/config/i386/t-linux64
++++ b/gcc/config/i386/t-linux64
@@ -33,6 +33,6 @@
comma=,
MULTILIB_OPTIONS = $(subst $(comma),/,$(TM_MULTILIB_CONFIG))
@@ -26,9 +24,8 @@ diff -Naur gcc-9.3.0.orig/gcc/config/i386/t-linux64 gcc-9.3.0/gcc/config/i386/t-
+MULTILIB_OSDIRNAMES = m64=../lib
+MULTILIB_OSDIRNAMES+= m32=../lib32
+MULTILIB_OSDIRNAMES+= mx32=../libx32
-diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux gcc-9.3.0/gcc/config/rs6000/t-linux
---- gcc-9.3.0.orig/gcc/config/rs6000/t-linux 2020-10-05 02:59:12.767988285 -0700
-+++ gcc-9.3.0/gcc/config/rs6000/t-linux 2020-10-05 03:03:32.310816444 -0700
+--- a/gcc/config/rs6000/t-linux
++++ b/gcc/config/rs6000/t-linux
@@ -2,7 +2,8 @@
# or soft-float.
ifeq (,$(filter $(with_cpu),$(SOFT_FLOAT_CPUS))$(findstring soft,$(with_float)))
@@ -49,9 +46,8 @@ diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux gcc-9.3.0/gcc/config/rs6000/
endif
endif
-diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux64 gcc-9.3.0/gcc/config/rs6000/t-linux64
---- gcc-9.3.0.orig/gcc/config/rs6000/t-linux64 2020-10-05 02:59:12.767988285 -0700
-+++ gcc-9.3.0/gcc/config/rs6000/t-linux64 2020-10-05 03:03:32.310816444 -0700
+--- a/gcc/config/rs6000/t-linux64
++++ b/gcc/config/rs6000/t-linux64
@@ -28,8 +28,8 @@
MULTILIB_OPTIONS := m64/m32
MULTILIB_DIRNAMES := 64 32
@@ -63,9 +59,8 @@ diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux64 gcc-9.3.0/gcc/config/rs600
rs6000-linux.o: $(srcdir)/config/rs6000/rs6000-linux.c
$(COMPILE) $<
-diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux64bele gcc-9.3.0/gcc/config/rs6000/t-linux64bele
---- gcc-9.3.0.orig/gcc/config/rs6000/t-linux64bele 2020-10-05 02:59:12.767988285 -0700
-+++ gcc-9.3.0/gcc/config/rs6000/t-linux64bele 2020-10-05 03:03:32.310816444 -0700
+--- a/gcc/config/rs6000/t-linux64bele
++++ b/gcc/config/rs6000/t-linux64bele
@@ -2,6 +2,6 @@
MULTILIB_OPTIONS += mlittle
@@ -75,9 +70,8 @@ diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux64bele gcc-9.3.0/gcc/config/r
+MULTILIB_OSDIRNAMES = m64=../lib
+MULTILIB_OSDIRNAMES+= m32=../lib32
MULTILIB_MATCHES := ${MULTILIB_MATCHES_ENDIAN}
-diff -Naur gcc-9.3.0.orig/gcc/config/rs6000/t-linux64lebe gcc-9.3.0/gcc/config/rs6000/t-linux64lebe
---- gcc-9.3.0.orig/gcc/config/rs6000/t-linux64lebe 2020-10-05 02:59:12.777987222 -0700
-+++ gcc-9.3.0/gcc/config/rs6000/t-linux64lebe 2020-10-05 03:03:32.310816444 -0700
+--- a/gcc/config/rs6000/t-linux64lebe
++++ b/gcc/config/rs6000/t-linux64lebe
@@ -2,6 +2,6 @@
MULTILIB_OPTIONS += mbig
diff --git a/13.1.0/musl/50_all_posix_memalign.patch b/13.1.0/musl/50_all_posix_memalign.patch
index a288e1d..dd75a93 100644
--- a/13.1.0/musl/50_all_posix_memalign.patch
+++ b/13.1.0/musl/50_all_posix_memalign.patch
@@ -1,6 +1,5 @@
-diff -Naur gcc-7.1.0.orig/gcc/config/i386/pmm_malloc.h gcc-7.1.0/gcc/config/i386/pmm_malloc.h
---- gcc-7.1.0.orig/gcc/config/i386/pmm_malloc.h 2017-01-01 04:07:43.000000000 -0800
-+++ gcc-7.1.0/gcc/config/i386/pmm_malloc.h 2017-05-07 11:35:22.878398460 -0700
+--- a/gcc/config/i386/pmm_malloc.h
++++ b/gcc/config/i386/pmm_malloc.h
@@ -27,12 +27,13 @@
#include <stdlib.h>