aboutsummaryrefslogtreecommitdiff
path: root/12.1.0
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-03 03:03:18 +0100
committerSam James <sam@gentoo.org>2022-07-03 03:22:11 +0100
commit1a5882abf01ae085e999ddcf4d208105e21e1a0d (patch)
tree75c5139a6ab02579a06acf2c337a75db128bed35 /12.1.0
parent12.1.0: musl: fixup README.history (diff)
downloadgcc-patches-1a5882abf01ae085e999ddcf4d208105e21e1a0d.tar.gz
gcc-patches-1a5882abf01ae085e999ddcf4d208105e21e1a0d.tar.bz2
gcc-patches-1a5882abf01ae085e999ddcf4d208105e21e1a0d.zip
10.4.0, 11.3.0, 11.4.0, 12.1.0: add gettext/msgfmt libstdc++ patch
Fixes building w/ USE=nls using a newer GCC. Bug: https://bugs.gentoo.org/843119 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to '12.1.0')
-rw-r--r--12.1.0/gentoo/29_all_msgfmt-libstdc++-link.patch39
-rw-r--r--12.1.0/gentoo/README.history3
2 files changed, 42 insertions, 0 deletions
diff --git a/12.1.0/gentoo/29_all_msgfmt-libstdc++-link.patch b/12.1.0/gentoo/29_all_msgfmt-libstdc++-link.patch
new file mode 100644
index 0000000..0d2f113
--- /dev/null
+++ b/12.1.0/gentoo/29_all_msgfmt-libstdc++-link.patch
@@ -0,0 +1,39 @@
+Ensure that msgfmt doesn't encounter problems during gcc bootstrapping.
+
+Solves error messages like the following:
+
+msgfmt: /var/tmp/portage/sys-devel/gcc-4.1.2/work/build/./gcc/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.3/libstdc++.so.6)
+
+The libgcc_s.so used during build doesn't satisfy the needs of the
+libstdc++.so that msgfmt is linked against. On the other hand, msgfmt
+is used as a stand-alone application here, and what library it uses
+behind the scenes is of no concern to the gcc build process.
+Therefore, simply invoking it "as usual", i.e. without any special
+library path, will make it work as expected here.
+
+2011-09-19 Martin von Gagern
+
+References:
+https://bugs.gentoo.org/372377
+https://bugs.gentoo.org/295480
+https://bugs.gentoo.org/843119
+--- a/libstdc++-v3/po/Makefile.am
++++ b/libstdc++-v3/po/Makefile.am
+@@ -39,6 +39,7 @@ MSGFMT = msgfmt
+ EXTRA_DIST = string_literals.cc POTFILES.in $(PACKAGE).pot $(LOCALE_IN)
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
+--- a/libstdc++-v3/po/Makefile.in
++++ b/libstdc++-v3/po/Makefile.in
+@@ -419,6 +419,7 @@ uninstall-am: uninstall-info-am
+
+
+ .po.mo:
++ env --unset=LD_LIBRARY_PATH \
+ $(MSGFMT) -o $@ $<
+
+ all-local: all-local-$(USE_NLS)
diff --git a/12.1.0/gentoo/README.history b/12.1.0/gentoo/README.history
index 04019c0..1602600 100644
--- a/12.1.0/gentoo/README.history
+++ b/12.1.0/gentoo/README.history
@@ -1,3 +1,6 @@
+9 3 Jul 2022
+ + 29_all_msgfmt-libstdc++-link.patch
+
8 26 Jun 2022
+ 28_all_drop_CFLAGS_sed.patch