aboutsummaryrefslogtreecommitdiff
path: root/10.4.0
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-11-27 22:14:22 +0100
committerDavid Seifert <soap@gentoo.org>2021-11-27 22:14:22 +0100
commit28ba3bac32109520950963c91edbd49a7b6a6458 (patch)
tree9c8c694f5a87550d1fca36c734007b387b3e46cd /10.4.0
parent10.4.0: copy patches from 10.3.0 (diff)
downloadgcc-patches-28ba3bac32109520950963c91edbd49a7b6a6458.tar.gz
gcc-patches-28ba3bac32109520950963c91edbd49a7b6a6458.tar.bz2
gcc-patches-28ba3bac32109520950963c91edbd49a7b6a6458.zip
10.4.0: rebase patches to avoid fuzz
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to '10.4.0')
-rw-r--r--10.4.0/gentoo/02_all_default-warn-format-security.patch12
-rw-r--r--10.4.0/gentoo/04_all_nossp-on-nostdlib.patch12
-rw-r--r--10.4.0/gentoo/08_all_libiberty-asprintf.patch6
-rw-r--r--10.4.0/gentoo/16_all_libgfortran-Werror.patch12
-rw-r--r--10.4.0/gentoo/17_all_libgomp-Werror.patch10
-rw-r--r--10.4.0/gentoo/18_all_libitm-Werror.patch10
-rw-r--r--10.4.0/gentoo/19_all_libatomic-Werror.patch10
-rw-r--r--10.4.0/gentoo/27_all_EXTRA_OPTIONS-z-now.patch14
8 files changed, 56 insertions, 30 deletions
diff --git a/10.4.0/gentoo/02_all_default-warn-format-security.patch b/10.4.0/gentoo/02_all_default-warn-format-security.patch
index f809abd..36201dc 100644
--- a/10.4.0/gentoo/02_all_default-warn-format-security.patch
+++ b/10.4.0/gentoo/02_all_default-warn-format-security.patch
@@ -1,9 +1,9 @@
Enable -Wformat and -Wformat-security by default.
---- a/gcc/c-family/c.opt 2016-03-23 18:51:56.000000000 +0100
-+++ b/gcc/c-family/c.opt 2016-04-28 23:45:54.063351272 +0200
-@@ -459,7 +459,7 @@ C ObjC C++ ObjC++ Var(warn_format_nonlit
- Warn about format strings that are not literals.
+--- a/gcc/c-family/c.opt
++++ b/gcc/c-family/c.opt
+@@ -599,7 +599,7 @@
+ of the destination region. Same as -Wformat-overflow=1.
Wformat-security
-C ObjC C++ ObjC++ Var(warn_format_security) Warning LangEnabledBy(C ObjC C++ ObjC++,Wformat=, warn_format >= 2, 0)
@@ -11,7 +11,7 @@ Enable -Wformat and -Wformat-security by default.
Warn about possible security problems with format functions.
Wformat-signedness
-@@ -475,7 +475,7 @@ C ObjC C++ ObjC++ Var(warn_format_zero_l
+@@ -620,7 +620,7 @@
Warn about zero-length formats.
Wformat=
@@ -19,4 +19,4 @@ Enable -Wformat and -Wformat-security by default.
+C ObjC C++ ObjC++ Joined RejectNegative UInteger Var(warn_format) Init(1) Warning LangEnabledBy(C ObjC C++ ObjC++,Wall, 1, 0) IntegerRange(0, 2)
Warn about printf/scanf/strftime/strfmon format string anomalies.
- Wignored-qualifiers
+ Wformat-overflow=
diff --git a/10.4.0/gentoo/04_all_nossp-on-nostdlib.patch b/10.4.0/gentoo/04_all_nossp-on-nostdlib.patch
index 648d712..6d9f00a 100644
--- a/10.4.0/gentoo/04_all_nossp-on-nostdlib.patch
+++ b/10.4.0/gentoo/04_all_nossp-on-nostdlib.patch
@@ -1,10 +1,10 @@
Disable ssp on -nostdlib, -nodefaultlibs and -ffreestanding
https://bugs.gentoo.org/484714
---- a/gcc/gcc.c 2017-07-04 09:15:57.740793000 +0200
-+++ b/gcc/gcc.c 2018-03-02 13:58:44.387741114 +0100
-@@ -857,6 +857,12 @@ proper position among the other output f
- #define LINK_GCC_C_SEQUENCE_SPEC "%G %L %G"
+--- a/gcc/gcc.c
++++ b/gcc/gcc.c
+@@ -874,6 +874,12 @@
+ #define LINK_GCC_C_SEQUENCE_SPEC "%G %{!nolibc:%L %G}"
#endif
+#ifdef ENABLE_DEFAULT_SSP
@@ -16,7 +16,7 @@ https://bugs.gentoo.org/484714
#ifndef LINK_SSP_SPEC
#ifdef TARGET_LIBC_PROVIDES_SSP
#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
-@@ -1131,7 +1148,7 @@ static const char *cc1_options =
+@@ -1155,7 +1161,7 @@
%{-version:--version}\
%{-help=*:--help=%*}\
%{!fsyntax-only:%{S:%W{o*}%{!o*:-o %b.s}}}\
@@ -24,4 +24,4 @@ https://bugs.gentoo.org/484714
+ %{fsyntax-only:-o %j} %{-param*} " NO_SSP_SPEC "\
%{coverage:-fprofile-arcs -ftest-coverage}\
%{fprofile-arcs|fprofile-generate*|coverage:\
- %{!fprofile-update=singel:\
+ %{!fprofile-update=single:\
diff --git a/10.4.0/gentoo/08_all_libiberty-asprintf.patch b/10.4.0/gentoo/08_all_libiberty-asprintf.patch
index bee0c4c..83ae56e 100644
--- a/10.4.0/gentoo/08_all_libiberty-asprintf.patch
+++ b/10.4.0/gentoo/08_all_libiberty-asprintf.patch
@@ -4,7 +4,7 @@
--- a/include/libiberty.h
+++ b/include/libiberty.h
-@@ -609,8 +609,11 @@ extern int pwait (int, int *, int);
+@@ -645,8 +645,11 @@
/* Like sprintf but provides a pointer to malloc'd storage, which must
be freed by the caller. */
@@ -14,5 +14,5 @@
#endif
+#endif
- #if !HAVE_DECL_VASPRINTF
- /* Like vsprintf but provides a pointer to malloc'd storage, which
+ /* Like asprintf but allocates memory without fail. This works like
+ xmalloc. */
diff --git a/10.4.0/gentoo/16_all_libgfortran-Werror.patch b/10.4.0/gentoo/16_all_libgfortran-Werror.patch
index f6c26bf..1501057 100644
--- a/10.4.0/gentoo/16_all_libgfortran-Werror.patch
+++ b/10.4.0/gentoo/16_all_libgfortran-Werror.patch
@@ -6,15 +6,23 @@ http://gcc.gnu.org/PR54724
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
-@@ -140,3 +140,3 @@ AM_PROG_CC_C_O
+@@ -146,7 +146,7 @@
+
+ # Add -Wall -fno-repack-arrays -fno-underscoring if we are using GCC.
if test "x$GCC" = "xyes"; then
- AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
+ AM_FCFLAGS="-I . -Wall -fimplicit-none -fno-repack-arrays -fno-underscoring"
## We like to use C11 and C99 routines when available. This makes
+ ## sure that
+ ## __STDC_VERSION__ is set such that libc includes make them available.
--- a/libgfortran/configure
+++ b/libgfortran/configure
-@@ -5764,3 +5764,3 @@ fi
+@@ -5981,7 +5981,7 @@
+
# Add -Wall -fno-repack-arrays -fno-underscoring if we are using GCC.
if test "x$GCC" = "xyes"; then
- AM_FCFLAGS="-I . -Wall -Werror -fimplicit-none -fno-repack-arrays -fno-underscoring"
+ AM_FCFLAGS="-I . -Wall -fimplicit-none -fno-repack-arrays -fno-underscoring"
+ ## We like to use C11 and C99 routines when available. This makes
+ ## sure that
+ ## __STDC_VERSION__ is set such that libc includes make them available.
diff --git a/10.4.0/gentoo/17_all_libgomp-Werror.patch b/10.4.0/gentoo/17_all_libgomp-Werror.patch
index 416808a..ffcb076 100644
--- a/10.4.0/gentoo/17_all_libgomp-Werror.patch
+++ b/10.4.0/gentoo/17_all_libgomp-Werror.patch
@@ -4,17 +4,23 @@ https://bugs.gentoo.org/229059
http://gcc.gnu.org/PR38436
--- a/libgomp/configure.ac
+++ b/libgomp/configure.ac
-@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+@@ -123,7 +123,7 @@
+
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
+
+ # Find other programs we need.
--- a/libgomp/configure
+++ b/libgomp/configure
-@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+@@ -4616,7 +4616,7 @@
+
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
+
+ # Find other programs we need.
diff --git a/10.4.0/gentoo/18_all_libitm-Werror.patch b/10.4.0/gentoo/18_all_libitm-Werror.patch
index 27181e0..c2b9164 100644
--- a/10.4.0/gentoo/18_all_libitm-Werror.patch
+++ b/10.4.0/gentoo/18_all_libitm-Werror.patch
@@ -3,17 +3,23 @@ libitm does not respect --disable-werror
https://bugs.gentoo.org/475350
--- a/libitm/configure.ac
+++ b/libitm/configure.ac
-@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+@@ -263,7 +263,7 @@
+
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
+
+ XCFLAGS="$XCFLAGS $XPCFLAGS"
--- a/libitm/configure
+++ b/libitm/configure
-@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+@@ -17864,7 +17864,7 @@
+
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
+
+ XCFLAGS="$XCFLAGS $XPCFLAGS"
diff --git a/10.4.0/gentoo/19_all_libatomic-Werror.patch b/10.4.0/gentoo/19_all_libatomic-Werror.patch
index 0550722..c39ca37 100644
--- a/10.4.0/gentoo/19_all_libatomic-Werror.patch
+++ b/10.4.0/gentoo/19_all_libatomic-Werror.patch
@@ -3,17 +3,23 @@ libatomic does not respect --disable-werror
https://bugs.gentoo.org/475350
--- a/libatomic/configure.ac
+++ b/libatomic/configure.ac
-@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+@@ -253,7 +253,7 @@
+
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
+
+ # Add CET specific flags if CET is enabled
--- a/libatomic/configure
+++ b/libatomic/configure
-@@ -4282,4 +4282,4 @@ save_CFLAGS="$CFLAGS"
+@@ -15571,7 +15571,7 @@
+
# Add -Wall -Werror if we are using GCC.
if test "x$GCC" = "xyes"; then
- XCFLAGS="$XCFLAGS -Wall -Werror"
+ XCFLAGS="$XCFLAGS -Wall"
fi
+
+ # Add CET specific flags if CET is enabled
diff --git a/10.4.0/gentoo/27_all_EXTRA_OPTIONS-z-now.patch b/10.4.0/gentoo/27_all_EXTRA_OPTIONS-z-now.patch
index 121dec4..93d31f2 100644
--- a/10.4.0/gentoo/27_all_EXTRA_OPTIONS-z-now.patch
+++ b/10.4.0/gentoo/27_all_EXTRA_OPTIONS-z-now.patch
@@ -1,8 +1,8 @@
On Hardened we add some options like -z now
---- a/gcc/gcc.c 2016-02-19 23:18:38.000000000 +0100
-+++ b/gcc/gcc.c 2016-05-02 22:56:10.185721270 +0200
-@@ -868,6 +868,12 @@ proper position among the other output f
+--- a/gcc/gcc.c
++++ b/gcc/gcc.c
+@@ -891,6 +891,12 @@
#endif
#endif
@@ -13,9 +13,9 @@ On Hardened we add some options like -z now
+#endif
+
#ifdef ENABLE_DEFAULT_PIE
- #define NO_PIE_SPEC "no-pie|static"
- #define PIE_SPEC NO_PIE_SPEC "|r|shared:;"
-@@ -1013,7 +1020,7 @@ proper position among the other output f
+ #define PIE_SPEC "!no-pie"
+ #define NO_FPIE1_SPEC "fno-pie"
+@@ -1043,7 +1049,7 @@
%(linker) " \
LINK_PLUGIN_SPEC \
"%{flto|flto=*:%<fcompare-debug*} \
@@ -23,4 +23,4 @@ On Hardened we add some options like -z now
+ %{flto} %{fno-lto} %{flto=*} %l " LINK_PIE_SPEC LINK_NOW_SPEC \
"%{fuse-ld=*:-fuse-ld=%*} " LINK_COMPRESS_DEBUG_SPEC \
"%X %{o*} %{e*} %{N} %{n} %{r}\
- %{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!nostartfiles:%S}} \
+ %{s} %{t} %{u*} %{z} %{Z} %{!nostdlib:%{!r:%{!nostartfiles:%S}}} \