aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-06-05 02:52:27 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-06-05 02:52:27 -0300
commit8a434e7028ca4e21c034dd68a749e2f94e128fe4 (patch)
treed8bd9f7acfda73976bf25c0f2574014c20e4b08a /ebuilds
parentfixes in the "build system" (diff)
downloadg-octave-8a434e7028ca4e21c034dd68a749e2f94e128fe4.tar.gz
g-octave-8a434e7028ca4e21c034dd68a749e2f94e128fe4.tar.bz2
g-octave-8a434e7028ca4e21c034dd68a749e2f94e128fe4.zip
added new ebuild; removed old ebuild
Diffstat (limited to 'ebuilds')
-rw-r--r--ebuilds/g-octave-0.1.ebuild (renamed from ebuilds/g-octave-0.1_rc3.ebuild)8
1 files changed, 6 insertions, 2 deletions
diff --git a/ebuilds/g-octave-0.1_rc3.ebuild b/ebuilds/g-octave-0.1.ebuild
index c5c22cf..9f42174 100644
--- a/ebuilds/g-octave-0.1_rc3.ebuild
+++ b/ebuilds/g-octave-0.1.ebuild
@@ -8,12 +8,12 @@ inherit distutils
DESCRIPTION="A tool that generates and installs ebuilds for Octave-Forge"
HOMEPAGE="http://g-octave.rafaelmartins.eng.br/"
-SRC_URI="http://files.rafaelmartins.eng.br/distfiles/${P}.tar.gz"
+SRC_URI="http://files.rafaelmartins.eng.br/distfiles/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
DEPEND="( >=dev-lang/python-2.6 <dev-lang/python-3 )"
RDEPEND="${DEPEND}
@@ -24,3 +24,7 @@ src_install() {
dohtml ${PN}.html
doman ${PN}.1
}
+
+src_test() {
+ PYTHONPATH=. scripts/run_tests.py || die "test failed."
+}