summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'g_cran/g_cran.py')
-rw-r--r--g_cran/g_cran.py13
1 files changed, 0 insertions, 13 deletions
diff --git a/g_cran/g_cran.py b/g_cran/g_cran.py
index 6898109..d005d38 100644
--- a/g_cran/g_cran.py
+++ b/g_cran/g_cran.py
@@ -35,17 +35,6 @@ def list_packages(repo_location):
for package in packages:
print 'dev-R/'+package.ebuild_vars['pn'],package.ebuild_vars['pv']
-#generate a tree of ebuilds... note that we only link ebuild files
-#metadata.xml and Manifest and whatnot is not generated
-def generate_tree(repo_location):
- packages=read_packages(os.path.join(repo_location,REPO_MYDIR,'PACKAGES'),repo_location)
- ebuild_file=os.path.join(os.path.dirname(__file__),'cran.ebuild')
- for package in packages:
- ebuild_dir=os.path.join(repo_location,'dev-R',package.ebuild_vars['pn'])
- if not os.path.exists(ebuild_dir):
- os.makedirs(ebuild_dir)
- os.symlink(ebuild_file,os.path.join(ebuild_dir,package.ebuild_vars['pn']+'-'+package.ebuild_vars['pv']+'.ebuild'))
-
#list package details, in PMS's format
def action_package(repo_location,package_name):
defined_phases=[]
@@ -90,8 +79,6 @@ def main():
list_categories(repo_location)
elif action=='list-packages':
list_packages(repo_location)
- elif action=='generate-tree':
- generate_tree(repo_location)
elif action=='package':
if len(arguments)<3:
print "The 'package' action takes the following parameters:"