summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAuke Booij (tulcod) <auke@tulcod.com>2010-06-26 12:34:34 +0200
committerAuke Booij (tulcod) <auke@tulcod.com>2010-06-26 12:34:34 +0200
commit44322d85803ab96342d1bba74363a0fa8b8884e7 (patch)
tree661067c7ea23ad3027dd87c14c9bda5b7c6b7109
parentFix python script name (diff)
downloadg-cran-44322d85803ab96342d1bba74363a0fa8b8884e7.tar.gz
g-cran-44322d85803ab96342d1bba74363a0fa8b8884e7.tar.bz2
g-cran-44322d85803ab96342d1bba74363a0fa8b8884e7.zip
Should install correctly with distutils now. The g-cran script ends up in /usr/bin.
-rwxr-xr-xbin/g-cran4
-rwxr-xr-xg_cran/cran.ebuild (renamed from cran.ebuild)4
-rw-r--r--setup.py1
3 files changed, 5 insertions, 4 deletions
diff --git a/bin/g-cran b/bin/g-cran
index 03579ae..171c836 100755
--- a/bin/g-cran
+++ b/bin/g-cran
@@ -1,6 +1,6 @@
#!python
-import g_cran
+from g_cran import g_cran
if __name__ == "__main__":
- g_cran.g_cran.main()
+ g_cran.main()
diff --git a/cran.ebuild b/g_cran/cran.ebuild
index 7f33727..ecdc5a0 100755
--- a/cran.ebuild
+++ b/g_cran/cran.ebuild
@@ -16,7 +16,7 @@ cat_pn_pvr=$(echo $this_file|/bin/sed -r 's$.+?/([A-Za-z0-9+_.-]+)/([A-Za-z0-9+_
do
export "$line"
done
-} < <(g-cran.py $this_repo package $cat_pn_pvr || die);
+} < <(/usr/bin/g-cran $this_repo package $cat_pn_pvr || die);
for phase in $GCOMMON_PHASES
do
@@ -24,6 +24,6 @@ do
done
function exec_phase() {
- g-cran.py $this_repo $1 || die
+ /usr/bin/g-cran $this_repo $1 || die
}
diff --git a/setup.py b/setup.py
index 6ac7e1c..8fb2bcb 100644
--- a/setup.py
+++ b/setup.py
@@ -10,4 +10,5 @@ setup(name='G-CRAN',
url='http://git.overlays.gentoo.org/gitweb/?p=proj/g-cran.git ',
packages=['g_cran'],
scripts=['bin/g-cran'],
+ package_data={'g_cran':['cran.ebuild',]},
)