diff options
author | Auke Booij (tulcod) <auke@tulcod.com> | 2010-06-26 12:34:34 +0200 |
---|---|---|
committer | Auke Booij (tulcod) <auke@tulcod.com> | 2010-06-26 12:34:34 +0200 |
commit | 44322d85803ab96342d1bba74363a0fa8b8884e7 (patch) | |
tree | 661067c7ea23ad3027dd87c14c9bda5b7c6b7109 | |
parent | Fix python script name (diff) | |
download | g-cran-44322d85803ab96342d1bba74363a0fa8b8884e7.tar.gz g-cran-44322d85803ab96342d1bba74363a0fa8b8884e7.tar.bz2 g-cran-44322d85803ab96342d1bba74363a0fa8b8884e7.zip |
Should install correctly with distutils now. The g-cran script ends up in /usr/bin.
-rwxr-xr-x | bin/g-cran | 4 | ||||
-rwxr-xr-x | g_cran/cran.ebuild (renamed from cran.ebuild) | 4 | ||||
-rw-r--r-- | setup.py | 1 |
3 files changed, 5 insertions, 4 deletions
@@ -1,6 +1,6 @@ #!python -import g_cran +from g_cran import g_cran if __name__ == "__main__": - g_cran.g_cran.main() + g_cran.main() diff --git a/cran.ebuild b/g_cran/cran.ebuild index 7f33727..ecdc5a0 100755 --- a/cran.ebuild +++ b/g_cran/cran.ebuild @@ -16,7 +16,7 @@ cat_pn_pvr=$(echo $this_file|/bin/sed -r 's$.+?/([A-Za-z0-9+_.-]+)/([A-Za-z0-9+_ do export "$line" done -} < <(g-cran.py $this_repo package $cat_pn_pvr || die); +} < <(/usr/bin/g-cran $this_repo package $cat_pn_pvr || die); for phase in $GCOMMON_PHASES do @@ -24,6 +24,6 @@ do done function exec_phase() { - g-cran.py $this_repo $1 || die + /usr/bin/g-cran $this_repo $1 || die } @@ -10,4 +10,5 @@ setup(name='G-CRAN', url='http://git.overlays.gentoo.org/gitweb/?p=proj/g-cran.git ', packages=['g_cran'], scripts=['bin/g-cran'], + package_data={'g_cran':['cran.ebuild',]}, ) |