summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAuke Booij (tulcod) <auke@tulcod.com>2010-06-26 17:31:28 +0200
committerAuke Booij (tulcod) <auke@tulcod.com>2010-06-26 17:31:28 +0200
commit4125a0a13dd5d0d8de64f46ad83715dbdb8cb9cc (patch)
tree31ba84b740c8c385213ae2e533972f3bad839f9e
parentAdd generate-tree action (diff)
downloadg-cran-4125a0a13dd5d0d8de64f46ad83715dbdb8cb9cc.tar.gz
g-cran-4125a0a13dd5d0d8de64f46ad83715dbdb8cb9cc.tar.bz2
g-cran-4125a0a13dd5d0d8de64f46ad83715dbdb8cb9cc.zip
Argh, I should check my syntax before uploading
-rw-r--r--g_cran/g_cran.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/g_cran/g_cran.py b/g_cran/g_cran.py
index 6e92d5d..94a5b7d 100644
--- a/g_cran/g_cran.py
+++ b/g_cran/g_cran.py
@@ -29,7 +29,7 @@ def generate_tree(repo_location):
ebuild_file=os.path.join(os.path.dirname(__file__),'cran.ebuild')
for package in packages:
ebuild_dir=os.path.join(repo_location,'dev-R',package.ebuild_vars['pn'])
- if !os.path.exists(ebuild_dir):
+ if not os.path.exists(ebuild_dir):
os.path.makedirs(ebuild_dir)
os.symlink(ebuild_file,os.path.join(ebuild_dir,package.ebuild_vars['pn']+'-'+package.ebuild_vars['pv']+'.ebuild'))