aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-09-10 13:16:43 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-09-10 13:16:43 +0000
commit1ca509c7efb7becfab6a93d3bd6a1a79676df3fa (patch)
treeb2bd3ae6d01cfa944d0581a6128d3f66bc560a23 /libs/Makefile.am
parent2005-09-10 Danny van Dyk <kugelfang@gentoo.org> (diff)
downloadeselect-1ca509c7efb7becfab6a93d3bd6a1a79676df3fa.tar.gz
eselect-1ca509c7efb7becfab6a93d3bd6a1a79676df3fa.tar.bz2
eselect-1ca509c7efb7becfab6a93d3bd6a1a79676df3fa.zip
2005-09-10 Danny van Dyk <kugelfang@gentoo.org>
* bin/eselect.in: Fixed Bug in usage of has(). Thanks to Sven Wegener <swegener@gentoo.org> for spotting this. * man/opengl.eselect: Added manpage for opengl module. * libs/portage.bash.in, libs/Makefile.am, configure.ac, modules/binutils.eselect, modules/config.eselect, modules/opengl.eselect, modules/profile.eselect: Added portage library, moved profile.eselect:get_arch() to portage.bash:arch(). diffstat configure.ac | 9 +++++- libs/Makefile.am | 3 +- libs/core.bash.in | 2 - libs/portage.bash.in | 67 +++++++++++++++++++++++++++++++++++++++++++++++ man/opengl.eselect.5 | 55 ++++++++++++++++++++++++++++++++++++++ modules/binutils.eselect | 2 - modules/config.eselect | 2 + modules/opengl.eselect | 2 - modules/profile.eselect | 20 ++------------ 9 files changed, 141 insertions(+), 21 deletions(-) svn path=/trunk/; revision=191
Diffstat (limited to 'libs/Makefile.am')
-rw-r--r--libs/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libs/Makefile.am b/libs/Makefile.am
index 886fbb0..49656dd 100644
--- a/libs/Makefile.am
+++ b/libs/Makefile.am
@@ -6,11 +6,12 @@ noinst_SCRIPTS = \
multilib.bash \
output.bash \
path-manipulation.bash \
+ portage.bash \
tests.bash
EXTRA_DIST = $(foreach f, $(noinst_SCRIPTS), $(f).in)
-dosed = @SED@ -e 's,%SED%,@SED@,g'
+dosed = @SED@ -e 's,\@SED\@,@SED@,g' -e 's,\@PORTAGEQ\@,@PORTAGEQ@,g'
%.bash : %.bash.in
@$(dosed) $< > $@