summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 20:17:53 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-25 20:17:53 -0400
commit0b67931ad054c8d109ea89faa8844b1f5a02e8ec (patch)
treead30dd46e8792afa1e28d19abaf9cdd0470a86ff /configure.ac
parentMakefile.am: mark openrc/php-fpm as a script and not as data. (diff)
downloadeselect-php-0b67931ad054c8d109ea89faa8844b1f5a02e8ec.tar.gz
eselect-php-0b67931ad054c8d109ea89faa8844b1f5a02e8ec.tar.bz2
eselect-php-0b67931ad054c8d109ea89faa8844b1f5a02e8ec.zip
Install the php-fpm init scripts conditional on --enable-fpm.0.9.3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e6ccfc..02aeaf2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,18 @@ AC_ARG_ENABLE(
esac],[apache2=false])
AM_CONDITIONAL([APACHE2], [test x$apache2 = xtrue])
+# --enable-fpm flag, disabled by default, that decides whether or
+# not we install the php-fpm init script and config file.
+AC_ARG_ENABLE(
+ [fpm],
+ [ --enable-fpm install the php-fpm init script [[default=no]]],
+ [case "${enableval}" in
+ yes) fpm=true ;;
+ no) fpm=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-fpm]) ;;
+ esac],[fpm=false])
+ AM_CONDITIONAL([FPM], [test x$fpm = xtrue])
+
piddir=${piddir="@LOCALSTATEDIR@"}
AC_ARG_WITH(piddir, AC_HELP_STRING([--with-piddir=DIR],
[where php-fpm PID files are placed [LOCALSTATEDIR]]),