summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <michael@orlitzky.com>2017-07-19 09:55:54 -0400
committerMichael Orlitzky <michael@orlitzky.com>2017-07-19 09:55:54 -0400
commit8cfe3c367df66bcb27cab3868190de3a18538fff (patch)
tree82f6357053096f2c04638132fc4fd8490d28e805 /Makefile.am
parentAdd .gitignore (diff)
downloadeselect-php-8cfe3c367df66bcb27cab3868190de3a18538fff.tar.gz
eselect-php-8cfe3c367df66bcb27cab3868190de3a18538fff.tar.bz2
eselect-php-8cfe3c367df66bcb27cab3868190de3a18538fff.zip
php-fpm.example.init.in: use @SYSCONFDIR@ from autotools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 578062e..eb3b89b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,19 +12,20 @@ if APACHE2
nodist_apacheconf_DATA = $(srcdir)/src/70_mod_php.conf
endif
-# The next few rules allow us to replace bindir, libdir, and
-# localstatedir within our script and conf file. The example is taken
+# The next few rules allow us to replace bindir, libdir, etc.
+# within our script and conf file. The example is taken
# from the autoconf documentation and can be found in the
# "Installation Directory Variables" section.
edit = sed -e 's|@BINDIR[@]|$(bindir)|g' \
-e 's|@LIBDIR[@]|$(libdir)|g' \
- -e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g'
+ -e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g' \
+ -e 's|@SYSCONFDIR[@]|$(sysconfdir)|g'
$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_DATA): Makefile
rm -f $@ $@.tmp
srcdir=''; \
test -f ./$@.in || srcdir=$(srcdir)/; \
- $(edit) $${srcdir}$@.in > $@.tmp
+ $(edit) $${srcdir}$@.in > $@.tmp
mv $@.tmp $@
$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in