aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2010-02-22 20:05:35 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2010-02-22 20:05:35 +0000
commit734e18033c6eaf2708bf7d6ce84e2bec2c98a609 (patch)
tree07322ad2de98ebc6a3268a3563acd84da5c5de0f
parentRemove obsolete versions of alsa-lib. (diff)
downloadembedded-cross-734e18033c6eaf2708bf7d6ce84e2bec2c98a609.tar.gz
embedded-cross-734e18033c6eaf2708bf7d6ce84e2bec2c98a609.tar.bz2
embedded-cross-734e18033c6eaf2708bf7d6ce84e2bec2c98a609.zip
Fix gst-python cross-compilation.
-rw-r--r--dev-python/gst-python/Manifest4
-rw-r--r--dev-python/gst-python/files/gst-python-0.10.16-cross-python-dirs.patch33
-rw-r--r--dev-python/gst-python/files/gst-python-0.10.9-lazy.patch21
-rw-r--r--dev-python/gst-python/gst-python-0.10.16.ebuild55
4 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/gst-python/Manifest b/dev-python/gst-python/Manifest
new file mode 100644
index 0000000..455a828
--- /dev/null
+++ b/dev-python/gst-python/Manifest
@@ -0,0 +1,4 @@
+AUX gst-python-0.10.16-cross-python-dirs.patch 1489 RMD160 33f4a53c01f5ad995d8a8d17d641dcccbfb4e2c6 SHA1 abf17131fc709c81a56ecd554a3faf8dd3d8f8b7 SHA256 6d78b714262848e442beb4ed18ff4aaa8a558f88a4527147939ad7dd5f79ef99
+AUX gst-python-0.10.9-lazy.patch 534 RMD160 912cd099a3f045305a6a9b33dd3bbc6aa422890c SHA1 a70a68be3e7f03b002f5a49e4685cf7d4daba264 SHA256 5a973c247741dcf2418c3f15427e9408295606ff3b2bf559ae7d82e060b18fee
+DIST gst-python-0.10.16.tar.bz2 579649 RMD160 28cb3fa6c63f4aa271caf859e2acbb803a3c30c1 SHA1 d6719417e3228a392ab6a40d3961c0de830bdc79 SHA256 ad145a15a1d7d227321cea8d309a7794edcd8124b4f5c5d00750f72fb6809607
+EBUILD gst-python-0.10.16.ebuild 1573 RMD160 d8f6a9c6a842ed406cba9a30bf04f2570a26ec1c SHA1 b17482fd8975cde8a5b8825f03c9e172f996b29a SHA256 8c9954933cd2d829ee2de9e4e615f516eed8981392356fd87d4fb8a127a898c7
diff --git a/dev-python/gst-python/files/gst-python-0.10.16-cross-python-dirs.patch b/dev-python/gst-python/files/gst-python-0.10.16-cross-python-dirs.patch
new file mode 100644
index 0000000..51f8161
--- /dev/null
+++ b/dev-python/gst-python/files/gst-python-0.10.16-cross-python-dirs.patch
@@ -0,0 +1,33 @@
+--- acinclude.m4 2009-04-15 22:16:30.000000000 +0200
++++ acinclude.m4.new 2010-02-22 20:51:58.000000000 +0100
+@@ -43,11 +43,13 @@
+ [AC_REQUIRE([AM_PATH_PYTHON])
+ AC_MSG_CHECKING(for headers required to compile python extensions)
+ dnl deduce PYTHON_INCLUDES
+-py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+-py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ if $PYTHON-config --help 2>/dev/null; then
++ py_prefix=`$PYTHON-config --prefix 2>/dev/null`
++ py_exec_prefix=`$PYTHON-config --exec-prefix 2>/dev/null`
+ PYTHON_INCLUDES=`$PYTHON-config --includes 2>/dev/null`
+ else
++ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
++ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+ if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+@@ -73,8 +75,12 @@
+ AC_MSG_CHECKING(for libraries required to embed python)
+ dnl deduce PYTHON_LIBS
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+-PYTHON_LIBS="-L${py_prefix}/lib -lpython${PYTHON_VERSION}"
+-PYTHON_LIB_LOC="${py_prefix}/lib"
++if $PYTHON-config --help 2>/dev/null; then
++ PYTHON_LIBS=`$PYTHON-config --libs 2>/dev/null`
++else
++ PYTHON_LIBS="-L${py_exec_prefix}/lib -lpython${PYTHON_VERSION}"
++fi
++PYTHON_LIB_LOC="${py_exec_prefix}/lib"
+ AC_SUBST(PYTHON_LIBS)
+ AC_SUBST(PYTHON_LIB_LOC)
+ dnl check if the headers exist:
diff --git a/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch b/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch
new file mode 100644
index 0000000..880d550
--- /dev/null
+++ b/dev-python/gst-python/files/gst-python-0.10.9-lazy.patch
@@ -0,0 +1,21 @@
+diff -ur gst-python-0.10.9.orig/configure.ac gst-python-0.10.9/configure.ac
+--- gst-python-0.10.9.orig/configure.ac 2007-11-28 11:33:05.000000000 +0200
++++ gst-python-0.10.9/configure.ac 2007-11-28 18:09:48.000000000 +0200
+@@ -363,6 +363,17 @@
+
+ AG_GST_VALGRIND_CHECK
+
++AC_MSG_CHECKING([whether $LD accepts -z,lazy])
++case `$LD -z,lazy -v 2>&1 </dev/null` in
++*GNU* | *'with BFD'*)
++ LDFLAGS="$LDFLAGS -Wl,-z,lazy"
++ AC_MSG_RESULT([yes])
++ ;;
++*)
++ AC_MSG_RESULT([no])
++ ;;
++esac
++
+ AC_OUTPUT([
+ Makefile
+ codegen/Makefile
diff --git a/dev-python/gst-python/gst-python-0.10.16.ebuild b/dev-python/gst-python/gst-python-0.10.16.ebuild
new file mode 100644
index 0000000..3cdf611
--- /dev/null
+++ b/dev-python/gst-python/gst-python-0.10.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gst-python/gst-python-0.10.16.ebuild,v 1.11 2010/01/05 18:36:15 nixnut Exp $
+
+EAPI=2
+NEED_PYTHON=2.4
+inherit autotools eutils multilib python
+
+DESCRIPTION="A Python Interface to GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.10"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples"
+
+RDEPEND="|| ( >=dev-python/pygobject-2.11.2 >=dev-python/pygtk-2.6.3 )
+ >=media-libs/gstreamer-0.10.24
+ >=media-libs/gst-plugins-base-0.10.24
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.10.9-lazy.patch
+
+ # Fix python include and libdir for cross-compilation.
+ epatch "${FILESDIR}/${P}-cross-python-dirs.patch"
+
+ rm -f py-compile ltmain.sh common/m4/{libtool,lt*}.m4 || die "rm -f failed"
+ ln -s $(type -P true) py-compile
+ AT_M4DIR="common/m4" eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*
+ fi
+}
+
+pkg_postinst() {
+ python_version
+ python_need_rebuild
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/pygst.py
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gst-0.10
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}