aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-06-22 19:52:00 +0200
committerUlrich Müller <ulm@gentoo.org>2024-06-22 19:52:00 +0200
commit2021feb5c322751d05c1a7f8c7554bb02db39b97 (patch)
tree5c6a1c1fbc95e6c95d721ea1f57f81e888663544
parent29.2: Remove patchset (diff)
downloademacs-patches-2021feb5c322751d05c1a7f8c7554bb02db39b97.tar.gz
emacs-patches-2021feb5c322751d05c1a7f8c7554bb02db39b97.tar.bz2
emacs-patches-2021feb5c322751d05c1a7f8c7554bb02db39b97.zip
29.4: Copy patches from 29.3, unless applied upstreamemacs-29.4-patches-1
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--emacs/29.4/01_all_sanity-check.patch13
-rw-r--r--emacs/29.4/02_all_epg-gpmsm.patch38
-rw-r--r--emacs/29.4/03_all_autoconf-2.72.patch24
3 files changed, 75 insertions, 0 deletions
diff --git a/emacs/29.4/01_all_sanity-check.patch b/emacs/29.4/01_all_sanity-check.patch
new file mode 100644
index 0000000..6509cf7
--- /dev/null
+++ b/emacs/29.4/01_all_sanity-check.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/916180
+
+--- emacs-29.1/Makefile.in
++++ emacs-29.1/Makefile.in
+@@ -417,7 +417,7 @@
+
+ sanity-check:
+ @[ -f .no-advice-on-failure ] && exit 0; true
+- @v=$$(src/emacs${EXEEXT} --batch --eval \
++ @v=$$(src/emacs${EXEEXT} --batch --quick --eval \
+ '(progn (defun f (n) (if (= 0 n) 1 (* n (f (- n 1))))) (princ (f 10)))' \
+ 2> /dev/null); \
+ [ "X$$v" = "X3628800" ] && exit 0; \
diff --git a/emacs/29.4/02_all_epg-gpmsm.patch b/emacs/29.4/02_all_epg-gpmsm.patch
new file mode 100644
index 0000000..646798c
--- /dev/null
+++ b/emacs/29.4/02_all_epg-gpmsm.patch
@@ -0,0 +1,38 @@
+Don't enable pinentry loopback mode for gpgsm
+Patch from master branch
+https://debbugs.gnu.org/67012
+
+commit e736a1b5a2aa2dd8dbaba32a408db70822fe434f
+Author: Ulrich Müller <ulm@gentoo.org>
+Date: Fri Nov 17 12:16:54 2023 +0100
+
+ Don't enable pinentry loopback mode for gpgsm
+
+--- a/doc/misc/epa.texi
++++ b/doc/misc/epa.texi
+@@ -640,6 +640,9 @@ GnuPG Pinentry
+ Emacs.
+ @end enumerate
+
++Note that loopback Pinentry does not work with @command{gpgsm},
++therefore EasyPG will ignore this setting for it.
++
+ There are other options available to use Emacs as Pinentry, you might
+ come across a Pinentry called @command{pinentry-emacs} or
+ @command{gpg-agent} option @code{allow-emacs-pinentry}. However,
+--- a/lisp/epg.el
++++ b/lisp/epg.el
+@@ -595,7 +595,12 @@ epg--start
+ (if (epg-context-textmode context) '("--textmode"))
+ (if (epg-context-output-file context)
+ (list "--output" (epg-context-output-file context)))
+- (if (epg-context-pinentry-mode context)
++ (if (and (epg-context-pinentry-mode context)
++ (not
++ ;; loopback doesn't work with gpgsm
++ (and (eq (epg-context-protocol context) 'CMS)
++ (eq (epg-context-pinentry-mode context)
++ 'loopback))))
+ (list "--pinentry-mode"
+ (symbol-name (epg-context-pinentry-mode
+ context))))
diff --git a/emacs/29.4/03_all_autoconf-2.72.patch b/emacs/29.4/03_all_autoconf-2.72.patch
new file mode 100644
index 0000000..45ad85c
--- /dev/null
+++ b/emacs/29.4/03_all_autoconf-2.72.patch
@@ -0,0 +1,24 @@
+Compatibility fix for autoconf-2.72
+Patch backported from master branch
+https://bugs.gentoo.org/930502
+
+commit e34ebc0ccc6c27e7e1217baad9ca74dd7bea4c37
+Author: Paul Eggert <eggert@cs.ucla.edu>
+Date: Wed Feb 7 13:17:57 2024 -0800
+
+ Port better to Autoconf 2.72
+
+ * configure.ac: Set ac_cv_type_gid_t=yes to pacify Autoconf 2.72
+ AC_TYPE_GETGROUPS. Problem reported by Nick Bowler in:
+ https://lists.gnu.org/r/autoconf-patches/2024-02/msg00001.html
+
+--- emacs-29.3/configure.ac
++++ emacs-29.3/configure.ac
+@@ -1661,6 +1661,7 @@
+ AC_DEFUN([AC_TYPE_SIZE_T])
+ # Likewise for obsolescent test for uid_t, gid_t; Emacs assumes them.
+ AC_DEFUN([AC_TYPE_UID_T])
++ac_cv_type_gid_t=yes # AC_TYPE_GETGROUPS needs this in Autoconf 2.72.
+
+ # Check for all math.h functions that Emacs uses; on some platforms,
+ # -lm is needed for some of these functions.