aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-14 21:35:12 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-14 21:35:12 +0100
commit228b2c051a9db004ca03dffc36500893502c94ee (patch)
tree87639afb1166a0b8555c782ffdb1dd0d03d20266
parentebuild.yas: add SRC corrections; unquoite PV (diff)
downloademacs-ebuild-snippets-228b2c051a9db004ca03dffc36500893502c94ee.tar.gz
emacs-ebuild-snippets-228b2c051a9db004ca03dffc36500893502c94ee.tar.bz2
emacs-ebuild-snippets-228b2c051a9db004ca03dffc36500893502c94ee.zip
Makefile: add eldev-install
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index e2b7514..9d46c46 100644
--- a/Makefile
+++ b/Makefile
@@ -5,6 +5,7 @@ ELCS = $(ELS:.el=.elc)
EMACS := emacs
RM := rm -f
+SH := sh
EMACFLAGS := --batch -q --no-site-file -L $(PWD)
EMACSCMD = $(EMACS) $(EMACFLAGS)
@@ -27,3 +28,9 @@ compile-snippets:
.PHONY: compile
compile: $(ELCS)
compile: compile-snippets
+
+.PHONY: eldev-install
+eldev-install:
+ $(MAKE) -B clean
+ $(MAKE) -B $(ELCS)
+ $(SH) $(PWD)/scripts/eldev-install.sh