summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile5
-rw-r--r--eltpatch.in2
2 files changed, 5 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 05a8b7e..90ddc87 100644
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
DESTDIR =
-prefix = /usr
+rootprefix =
+gentoofuncs = $(rootprefix)/lib/gentoo/functions.sh
+prefix = $(rootprefix)/usr
bindir = $(prefix)/bin
libdirname = lib
datadir = $(prefix)/share
@@ -16,6 +18,7 @@ eltpatch: eltpatch.in
rm -f $@ $@.tmp
sed -e 's^@ELT_patchdir@^$(patchdir)^' \
-e 's^@ELT_libdir@^$(libdirname)^' \
+ -e 's^@ELT_gentoofuncs@^$(gentoofuncs)^' \
$< > $@.tmp
chmod +x $@.tmp
mv $@.tmp $@
diff --git a/eltpatch.in b/eltpatch.in
index 7dae4bb..a4e87d2 100644
--- a/eltpatch.in
+++ b/eltpatch.in
@@ -2,7 +2,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-source "/lib/gentoo/functions.sh" || exit 1
+source "@ELT_gentoofuncs@" || exit 1
die() {
eerror "${@}"