aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 23 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 38fd84b..7e7a7d0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,13 +1,32 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
+#
+# configure.ac: this is part of the elfix package
+# Copyright (C) 2011 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
-AC_PREREQ([2.65])
+AC_PREREQ([2.68])
AC_INIT([elfix], [0.6], [http://bugs.gentoo.org/])
AC_CONFIG_SRCDIR([src/fix-gnustack.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 foreign])
AM_SILENT_RULES([no])
+LT_PREREQ([2.4])
+LT_INIT([dlopen])
+AC_CONFIG_MACRO_DIR([m4])
+
AC_ARG_ENABLE(
[tests],
AS_HELP_STRING(
@@ -123,6 +142,7 @@ AC_CONFIG_FILES([
tests/gnustack/Makefile
tests/pxtpax/Makefile
tests/paxmodule/Makefile
+ tests/revdeppaxtest/Makefile
])
AC_OUTPUT