aboutsummaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-04-25 16:29:47 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-04-25 16:29:47 -0400
commitf2dad582692fee256b79dadbf398d3372d4bda56 (patch)
tree9a622b10429c67e58dbbaaba1d8276aaf184db89 /tests
parentAdded contitional for 'tests' (diff)
downloadelfix-f2dad582692fee256b79dadbf398d3372d4bda56.tar.gz
elfix-f2dad582692fee256b79dadbf398d3372d4bda56.tar.bz2
elfix-f2dad582692fee256b79dadbf398d3372d4bda56.zip
Fixed test on x86
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6ac6da6..a7fafde 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,7 +4,7 @@ bad_SOURCES = bad.c
bad_DEPENDENCIES = test-bad.o
bad_LDADD = test-bad.o
-ARCH = $(shell uname -m)
+ARCH = $(shell uname -m | sed -e 's/i./x/')
test-bad.o: test-bad64.asm test-bad32.asm
[[ "$(ARCH)" == "x86" ]] && yasm -f elf -m x86 test-bad32.asm && mv test-bad32.o test-bad.o || true