aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-05-05 11:10:36 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-05-05 11:10:36 -0400
commitdf7e9066d5f19264caa2b27cdae8a8e27c67433d (patch)
tree35b0b76407850c54e516c8fdaeac75c007cae7b6 /tests/Makefile.am
parentconfigure.ac: added check for more headers (diff)
downloadelfix-df7e9066d5f19264caa2b27cdae8a8e27c67433d.tar.gz
elfix-df7e9066d5f19264caa2b27cdae8a8e27c67433d.tar.bz2
elfix-df7e9066d5f19264caa2b27cdae8a8e27c67433d.zip
Revamped tests, added poc
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am33
1 files changed, 13 insertions, 20 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a7fafde..ab23520 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,14 +1,13 @@
-noinst_PROGRAMS = good bad
-good_SOURCES = good.c
-bad_SOURCES = bad.c
-bad_DEPENDENCIES = test-bad.o
-bad_LDADD = test-bad.o
+noinst_PROGRAMS = bad-gnustack
+bad_gnustack_SOURCES = bad-gnustack.c
+bad_gnustack_DEPENDENCIES = bad-asm.o
+bad_gnustack_LDADD = bad-asm.o
ARCH = $(shell uname -m | sed -e 's/i./x/')
-test-bad.o: test-bad64.asm test-bad32.asm
- [[ "$(ARCH)" == "x86" ]] && yasm -f elf -m x86 test-bad32.asm && mv test-bad32.o test-bad.o || true
- [[ "$(ARCH)" == "x86_64" ]] && yasm -f elf -m amd64 test-bad64.asm && mv test-bad64.o test-bad.o || true
+bad-asm.o: bad64.asm bad32.asm
+ [[ "$(ARCH)" == "x86" ]] && yasm -f elf -m x86 bad32.asm && mv bad32.o bad-asm.o || true
+ [[ "$(ARCH)" == "x86_64" ]] && yasm -f elf -m amd64 bad64.asm && mv bad64.o bad-asm.o || true
check_SCRIPTS = test.sh
TEST = $(check_SCRIPTS)
@@ -16,19 +15,13 @@ TEST = $(check_SCRIPTS)
test.sh:
@echo "================================================================================"
@echo
- @echo "Good Elf"
- @../src/fix-gnustack good
+ @echo "Fixing Bad GNU_STACK Elf"
+ @../src/fix-gnustack -f bad-gnustack
@echo
- @echo "Bad Elf"
- @../src/fix-gnustack bad
- @echo
- @echo "Fixing Bad Elf"
- @../src/fix-gnustack -f bad
- @echo
- @echo "Fixed Bad Elf"
- @../src/fix-gnustack bad
- @rm -f good bad
+ @echo "Fixed Bad GNU_STACK Elf"
+ @../src/fix-gnustack bad-gnustack
+ @rm -f good
@echo
@echo "================================================================================"
-CLEANFILES = test-bad.o test.sh
+CLEANFILES = bad-asm.o test.sh