aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-04-12 20:41:32 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-04-12 21:23:02 -0400
commit586447f4fbd854ccc31ec187c87d71f84e670a3a (patch)
tree20e7f0aa7dd8e2a1a8ae95aee8a149af2cc16ad7 /tests/Makefile.am
parentFixed unit tests to work with 'make check' (diff)
downloadelfix-586447f4fbd854ccc31ec187c87d71f84e670a3a.tar.gz
elfix-586447f4fbd854ccc31ec187c87d71f84e670a3a.tar.bz2
elfix-586447f4fbd854ccc31ec187c87d71f84e670a3a.zip
Added: fix-gnustack.c to clear X flag on .gnu.stack
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eb398ea..6a997c8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -4,15 +4,21 @@ TEST = $(check_SCRIPTS)
test.sh:
@echo "================================================================================"
@echo
+# @[[ -x ../get-gnustack ]] || echo "Run 'make' first" && exit
+# @[[ -x ../fix-gnustack ]] || echo "Run 'make' first" && exit
@gcc -o good good.c
@echo "Good result"
- @[[ -x ../get-gnustack ]] && ../get-gnustack good || echo "Run 'make' first"
+ @../get-gnustack good
@echo
@yasm -f elf -m amd64 test-bad.asm
@gcc -c bad.c
@gcc -o bad bad.o test-bad.o
@echo "Bad result"
- @[[ -x ../get-gnustack ]] && ../get-gnustack bad || echo "Run 'make' first"
+ @../get-gnustack bad
+ @echo
+ @echo "Fixed results"
+ @../fix-gnustack bad
+ @../get-gnustack bad
@echo
@echo "================================================================================"