aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-16 14:05:24 -0500
committerAnthony G. Basile <blueness@gentoo.org>2012-12-16 14:05:24 -0500
commitf2cefd132d6157e117b833e28824bebc5aa93d19 (patch)
tree9d5500d3fe0492ceae9a0d697f82da945e60140f /scripts
parenttests/revdeppaxtest: no longer require python module to be installed (diff)
downloadelfix-f2cefd132d6157e117b833e28824bebc5aa93d19.tar.gz
elfix-f2cefd132d6157e117b833e28824bebc5aa93d19.tar.bz2
elfix-f2cefd132d6157e117b833e28824bebc5aa93d19.zip
ChangeLog, TODO, README, Copyright Notices: updated
Diffstat (limited to 'scripts')
-rw-r--r--scripts/paxmodule.c2
-rwxr-xr-xscripts/pypaxctl18
-rwxr-xr-xscripts/revdep-pax18
-rwxr-xr-xscripts/setup.py18
4 files changed, 55 insertions, 1 deletions
diff --git a/scripts/paxmodule.c b/scripts/paxmodule.c
index 57c9ce1..5e7b1fe 100644
--- a/scripts/paxmodule.c
+++ b/scripts/paxmodule.c
@@ -1,5 +1,5 @@
/*
- paxmodule.c: python module to get/set pax flags on an ELF object
+ paxmodule.c: this file is part of the elfix package
Copyright (C) 2011 Anthony G. Basile
This program is free software: you can redistribute it and/or modify
diff --git a/scripts/pypaxctl b/scripts/pypaxctl
index 5993641..8edf61e 100755
--- a/scripts/pypaxctl
+++ b/scripts/pypaxctl
@@ -1,4 +1,22 @@
#!/usr/bin/env python
+#
+# pypaxctl: this file is part of the elfix package
+# Copyright (C) 2011 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
import sys
import getopt
diff --git a/scripts/revdep-pax b/scripts/revdep-pax
index 8626e95..0116971 100755
--- a/scripts/revdep-pax
+++ b/scripts/revdep-pax
@@ -1,4 +1,22 @@
#!/usr/bin/env python
+#
+# revdep-pax: this file is part of the elfix package
+# Copyright (C) 2011 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
import sys
import getopt
diff --git a/scripts/setup.py b/scripts/setup.py
index 0c6e9cc..ccb6989 100755
--- a/scripts/setup.py
+++ b/scripts/setup.py
@@ -1,4 +1,22 @@
#!/usr/bin/env python
+#
+# setup.py: this file is part of the elfix package
+# Copyright (C) 2011 Anthony G. Basile
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
import sys, os, re
from distutils.core import setup, Extension