aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-08-03 07:40:07 -0400
committerAnthony G. Basile <blueness@gentoo.org>2014-08-03 07:40:07 -0400
commit5a408e1b46a80e022a01da0750de92dce46dd104 (patch)
treef5fcfac2d7eb3c5e6d94ea106a5c9539021f36be
parentconfigure.ac: cleanup after moving fix-gnustack (diff)
downloadelfix-5a408e1b46a80e022a01da0750de92dce46dd104.tar.gz
elfix-5a408e1b46a80e022a01da0750de92dce46dd104.tar.bz2
elfix-5a408e1b46a80e022a01da0750de92dce46dd104.zip
pocs/link-graph: rename 'maps' -> 'graph'
-rw-r--r--pocs/link-graph/__pycache__/link_graph.cpython-33.pycbin0 -> 6588 bytes
-rwxr-xr-xpocs/link-graph/link_graph.py (renamed from pocs/link-maps/link_map.py)6
-rwxr-xr-xpocs/link-graph/link_graph_test (renamed from pocs/link-maps/link_map_test)8
3 files changed, 7 insertions, 7 deletions
diff --git a/pocs/link-graph/__pycache__/link_graph.cpython-33.pyc b/pocs/link-graph/__pycache__/link_graph.cpython-33.pyc
new file mode 100644
index 0000000..400f22e
--- /dev/null
+++ b/pocs/link-graph/__pycache__/link_graph.cpython-33.pyc
Binary files differ
diff --git a/pocs/link-maps/link_map.py b/pocs/link-graph/link_graph.py
index 5b0e822..030aba8 100755
--- a/pocs/link-maps/link_map.py
+++ b/pocs/link-graph/link_graph.py
@@ -1,6 +1,6 @@
#!/usr/bin/env python
#
-# LinkMap.py: this file is part of the elfix package
+# LinkGraph.py: this file is part of the elfix package
# Copyright (C) 2011 Anthony G. Basile
#
# This program is free software: you can redistribute it and/or modify
@@ -19,7 +19,7 @@
import re
import portage
-class LinkMap:
+class LinkGraph:
def __init__(self):
""" Put all the NEEDED.ELF.2 files for all installed packages
@@ -178,7 +178,7 @@ class LinkMap:
return object_reverse_linkings
- def get_maps(self):
+ def get_graph(self):
""" Generate the full forward and reverse links using the above functions """
# After get_object_needed() and get_soname_needed(), both object_linkings and
diff --git a/pocs/link-maps/link_map_test b/pocs/link-graph/link_graph_test
index 9a1af8e..619b88f 100755
--- a/pocs/link-maps/link_map_test
+++ b/pocs/link-graph/link_graph_test
@@ -1,6 +1,6 @@
#!/usr/bin/env python
#
-# link_map_test: this file is part of the elfix package
+# link_graph_test: this file is part of the elfix package
# Copyright (C) 2011 Anthony G. Basile
#
# This program is free software: you can redistribute it and/or modify
@@ -18,7 +18,7 @@
import os
import sys
-from link_map import LinkMap
+from link_graph import LinkGraph
def main():
@@ -28,8 +28,8 @@ def main():
print('RUN AS ROOT: cannot read all flags')
sys.exit(0)
- link_map = LinkMap()
- ( object_linkings, object_reverse_linkings, library2soname, soname2library ) = link_map.get_maps()
+ link_graph = LinkGraph()
+ ( object_linkings, object_reverse_linkings, library2soname, soname2library ) = link_graph.get_graph()
layout = "{0:<30} => {1:<30}"