summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-21 14:18:08 +0100
committerSam James <sam@gentoo.org>2022-10-02 04:31:25 +0100
commita529111f77ff46f4836fe7312e70953bc16587cf (patch)
tree9dc3924cb1a6ef3ef853b7bb45f735365e0b4e6d /configure.ac
parentImport Ghostscript 9.56.1 (diff)
downloadghostscript-gpl-patches-ghostscript-10.tar.gz
ghostscript-gpl-patches-ghostscript-10.tar.bz2
ghostscript-gpl-patches-ghostscript-10.zip
Import Ghostscript 10.0ghostscript-10.0ghostscript-10
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac64
1 files changed, 40 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index e955b2f1..bb578250 100644
--- a/configure.ac
+++ b/configure.ac
@@ -560,6 +560,16 @@ dnl feature set of GNU make. We still prefer GNU make,
dnl but......
dnl --------------------------------------------------
+AC_ARG_WITH([make], AS_HELP_STRING([--with-make=@<:@"make" program name@:>@],
+ [If you use a version of make not called "make"]),
+ [MAKE=$with_make], [MAKE=make])
+
+AC_CHECK_PROG(MAKE_EXISTS,[$MAKE],[yes],[no])
+
+if test x"$MAKE_EXISTS" = x"no" ; then
+ AC_MSG_ERROR([Required make program '$MAKE' not found.])
+fi
+
OBJDIR_BSDMAKE_WORKAROUND=obj
SUB_MAKE_OPTION=
ORDER_ONLY=""
@@ -1416,17 +1426,6 @@ if test -z "$SHARE_ZLIB"; then
])
fi
-dnl if GS is to use the system zlib, freetype
-dnl should do the same
-FT_SYS_ZLIB=""
-if test x$FT_BRIDGE != x0; then
- if test xx$SHARE_FT != x1; then
- if test x$SHARE_ZLIB != x0; then
- FT_SYS_ZLIB="-DFT_CONFIG_OPTION_SYSTEM_ZLIB"
- fi
- fi
-fi
-
AC_SUBST(SHARE_ZLIB)
AC_SUBST(AUX_SHARED_ZLIB)
AC_SUBST(ZLIBCFLAGS)
@@ -1440,7 +1439,7 @@ if test x"$enable_auxtools_only" = x"yes" ; then
else
LIBPNGDIR=src
PNGDEVS=''
- PNGDEVS_ALL='png48 png16m pnggray pngmono pngmonod png256 png16 pngalpha'
+ PNGDEVS_ALL='png48 png16m pnggray pngmono pngmonod png256 png16 pngalpha png16malpha'
AC_MSG_CHECKING([for local png library source])
if test -f $srcdir/libpng/pngread.c; then
AC_MSG_RESULT([yes])
@@ -1660,7 +1659,7 @@ if test x"$SHARE_LIBTIFF" = x"0" ; then
if ! test -d "$LIBTIFFCONFDIR" ; then
mkdir "$LIBTIFFCONFDIR"
fi
- cd "$LIBTIFFCONFDIR" && "$absolute_source_path/$LIBTIFFDIR/configure" $GS_TIFF_CONFIGURE_OPTS --disable-jbig --disable-lzma --disable-zstd --disable-webp --disable-libdeflate $SUBCONFIG_OPTS
+ cd "$LIBTIFFCONFDIR" && "$absolute_source_path/$LIBTIFFDIR/configure" $GS_TIFF_CONFIGURE_OPTS --disable-lerc --disable-jbig --disable-lzma --disable-zstd --disable-webp --disable-libdeflate $SUBCONFIG_OPTS
status=$?
if test $status -ne 0 ; then
AC_MSG_ERROR([libtiff configure script failed], $status)
@@ -2212,6 +2211,7 @@ if test x$WITH_CAL != x0; then
unsigned char buf1[[128]];
input1 = _mm_loadu_si128((const __m128i *)buf1);
input1 = _mm_hadd_epi32(input1, input1);
+ (void)_mm_extract_epi64(input1, 0);
return(0);
])],
[HAVE_SSE4_2="-DHAVE_SSE4_2"], [HAVE_SSE4_2=""])
@@ -2238,6 +2238,7 @@ if test x$WITH_CAL != x0; then
unsigned char buf1[[256]];
input1 = _mm256_loadu_si256((const __m256i *)buf1);
input1 = _mm256_adds_epu8(input1, input1);
+ (void)_mm256_insert_epi64(input1, 0, 0);
return(0);
])],
[HAVE_AVX2="-DHAVE_AVX2"], [HAVE_AVX2=""])
@@ -2286,12 +2287,15 @@ if test x$WITH_CAL != x0; then
CAL_NEON_CFLAGS=""
if test "x$HAVE_SSE4_2" != x; then
CAL_SSE4_2_CFLAGS="-msse4.2"
+ CAL_CFLAGS="$CAL_CFLAGS $HAVE_SSE4_2"
fi
if test "x$HAVE_AVX2" != x; then
CAL_AVX2_CFLAGS="-mavx2"
+ CAL_CFLAGS="$CAL_CFLAGS $HAVE_AVX2"
fi
if test "x$HAVE_NEON" != x; then
CAL_NEON_CFLAGS="-mfpu=neon -mcpu=cortex-a53"
+ CAL_CFLAGS="$CAL_CFLAGS $HAVE_NEON"
fi
fi
@@ -2479,6 +2483,14 @@ PDF_MAK="\$(GLSRCDIR)\$(D)stub.mak"
PDFROMFS_MAK="\$(GLSRCDIR)\$(D)stub.mak"
if test x"$with_pdf" != x"no" ; then
+
+ if test x"$JBIG2_DECODER" = x""; then
+ AC_MSG_ERROR([No JBIG2 decoder available, required for PDF support])
+ fi
+ if test x"$JPX_DECODER" = x""; then
+ AC_MSG_ERROR([No JPX/JPEG2000 decoder available, required for PDF support])
+ fi
+
if test -f $srcdir/pdf/pdf.mak; then
AC_ARG_WITH([pdf], AS_HELP_STRING([--with-pdf=NAME],
[name of the Ghostpdf executible (if the source is available, ignored otherwise) [[gpdf]]]),
@@ -2883,17 +2895,17 @@ GPDL_SONAME="lib\$(GPDL${libname1}"
GPDL_SONAME_MAJOR="lib\$(GPDL${libname2}"
GPDL_SONAME_MAJOR_MINOR="lib\$(GPDL${libname3}"
-hide_symbols=no
+hide_symbols=yes
attr_default=
attr_hidden=
_ldflags=
AC_ARG_ENABLE([hidden-visibility],
- AS_HELP_STRING([--enable-hidden-visibility],
- [hide all shared library symbols which are not part of its public API]),
- [hide_symbols=yes])
+ AS_HELP_STRING([--disable-hidden-visibility],
+ [expose all shared library symbols even those which are not part of its public API]),
+ [hide_symbols=no])
-if test x$hide_symbols = xyes -a x"$GCC" = x"yes"; then
+if test x"$hide_symbols" = x"yes" -a x"$GCC" = x"yes"; then
attr_default="__attribute__((visibility(\\\"default\\\")))"
attr_hidden="__attribute__((visibility(\\\"hidden\\\")))"
fi
@@ -2915,7 +2927,7 @@ case $host in
SO_LIB_EXT=".so"
;;
*-mingw*|*-msys*)
- if test x$hide_symbols = xyes; then
+ if test x"$hide_symbols" = x"yes"; then
attr_default="__declspec(dllexport)"
attr_hidden=""
else
@@ -2947,7 +2959,7 @@ case $host in
GPDL_SONAME_MAJOR_MINOR="lib\$(GPDL${libname2}"
;;
*-cygwin*)
- if test x$hide_symbols = xyes; then
+ if test x"$hide_symbols" = x"yes"; then
attr_default="__declspec(dllexport)"
attr_hidden=""
fi
@@ -2997,7 +3009,7 @@ case $host in
DYNAMIC_CFLAGS="-fPIC $DYNAMIC_CFLAGS"
else
DYNAMIC_CFLAGS="-KPIC $DYNAMIC_CFLAGS"
- #if test x$hide_symbols = xyes; then
+ #if test x"$hide_symbols" = x"yes"; then
# attr_default="__global"
# attr_hidden="__hidden"
# _ldflags="-xldscope=hidden"
@@ -3034,16 +3046,17 @@ case $host in
;;
esac
-if test x$hide_symbols = xyes ; then
+if test x"$hide_symbols" = x"yes" ; then
if test x"$GCC" = x"yes"; then
DYNAMIC_CFLAGS="$DYNAMIC_CFLAGS -fvisibility=hidden"
fi
DYNAMIC_CFLAGS="$DYNAMIC_CFLAGS -DGSDLLEXPORT=\"$attr_default\""
if test "x$FT_BRIDGE" = x1 -a "x$SHARE_FT" = x0 ; then
- DYNAMIC_CFLAGS="$DYNAMIC_CFLAGS -D\"FT_EXPORT(x)\"=\"$attr_hidden x\""
+ # disable warnings for redefined macros, so our abuse of FT_EXPORT() to hide symbols doesn't flag warnings
+ FT_HIDDEN_CFLAGS="-Wp,-w -D\"FT_EXPORT(x)\"=\"$attr_hidden x\" -D\"FT_EXPORT_DEF(x)\"=\"$attr_hidden x\""
fi
if test "x$SHARE_EXPAT" = x0 ; then
- DYNAMIC_CFLAGS="$DYNAMIC_CFLAGS -DXML_STATIC -DXMLIMPORT=\"$attr_hidden\""
+ XML_HIDDEN_CFLAGS="-DXML_STATIC -DXMLIMPORT=\"$attr_hidden\""
fi
fi
@@ -3065,6 +3078,9 @@ AC_SUBST(GPDL_SONAME)
AC_SUBST(GPDL_SONAME_MAJOR)
AC_SUBST(GPDL_SONAME_MAJOR_MINOR)
+AC_SUBST(FT_HIDDEN_CFLAGS)
+AC_SUBST(XML_HIDDEN_CFLAGS)
+
AC_ARG_ENABLE([dynamic], AS_HELP_STRING([--enable-dynamic],
[Enable dynamically loaded drivers]),
[