aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'catalyst/nfsroot')
-rw-r--r--catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh31
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec12
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/stage1.spec2
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/stage2.spec2
-rw-r--r--catalyst/nfsroot/2008.0/specs/amd64/stage3.spec2
5 files changed, 25 insertions, 24 deletions
diff --git a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
index 569e721..4f9b7c9 100644
--- a/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
+++ b/catalyst/nfsroot/2008.0/scripts/nfsroot_setup.sh
@@ -1,18 +1,15 @@
#!/bin/bash
-
# (C) Eric Thibodeau GPL v2
-. /sbin/functions.sh
-
-eeinfo(){
- einfo "====================================="
- einfo "$*"
- einfo "====================================="
+eecho(){
+ echo "====================================="
+ echo "$*"
+ echo "====================================="
}
kernel_links()
{
- eeinfo "Correcting kernel and initramfs links"
+ eecho "Correcting kernel and initramfs links"
cd /boot
ln -s kernel-* vmlinuz
ln -s initramfs-* initramfs
@@ -21,7 +18,7 @@ kernel_links()
unionfs_prep()
{
- eeinfo "=adding unionfs required dirs========"
+ eecho "=adding unionfs required dirs========"
# for I in etc var tmp
# do
mkdir -p /mnt/rw_mounts/
@@ -54,7 +51,7 @@ change_opt() {
}
openrc_diskless_setup() {
- eeinfo "=Setting up default RC configs======="
+ eecho "=Setting up default RC configs======="
# /etc/rc.conf
for I in 'rc_parallel="yes"' 'rc_depend_strict="NO"' 'rc_tty_number=2'
@@ -75,39 +72,39 @@ openrc_diskless_setup() {
# We don't do this anymore since it puts files into /lib64/rc/init.d/
# and that causes error messages on reboot:
- #einfo "Pre-generating dependencies..."
+ #echo "Pre-generating dependencies..."
#/lib/rc/bin/rc-depend -u
# Instead, we actually clean out that folder:
rm -Rf /lib64/rc/init.d/*
# The following is only useful if some freak grabs the livecd and is in a TZ
# making the /etc files dated in the future (my system is UTC-5
- einfo "Moving dates to the past so the Cache isn't always regenerated"
+ echo "Moving dates to the past so the Cache isn't always regenerated"
find /etc/ -exec touch --date=yesterday {} \;
}
setup_services() {
# Pre-generating sshd keys can be the source of philosophical debates:
- eeinfo "=Pre-generating sshd keys============"
+ eecho "=Pre-generating sshd keys============"
. /etc/init.d/sshd
gen_keys
# ln -s /etc/runlevels/default /etc/runlevels/unionfs
}
dash_is_sh() {
- eeinfo "=Replacing sh with dash=============="
+ eecho "=Replacing sh with dash=============="
rm /bin/sh
ln -s /bin/dash /bin/sh
}
clear_resolv.conf(){
# we don't want the buildhost's resolv.conf to lie around and confuse things
- eeinfo "=Clearing our resolv.conf============"
+ eecho "=Clearing our resolv.conf============"
echo "" > /etc/resolv.conf
}
setup_ntp-client(){
- eeinfo "=Configuring ntp-client=============="
+ eecho "=Configuring ntp-client=============="
sed -ie 's:NTPCLIENT_OPTS=.*:NTPCLIENT_OPTS="-s -b -u master.gentoo.local":' /etc/conf.d/ntp-client
}
@@ -120,7 +117,7 @@ openrc_diskless_setup
setup_services
# TEMPORARY for testing:
-eeinfo "=Changing root password=============="
+eecho "=Changing root password=============="
echo root:test | chpasswd
exit 0
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec b/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
index 9998844..7567b8d 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/nfsroot_stage4.spec
@@ -12,7 +12,7 @@ subarch: amd64
# example:
# version_stamp: 2006.1
#version_stamp: nfsroot-20080629
-version_stamp: nfsroot-20080806
+version_stamp: nfsroot-20080816
# The target specifies what target we want catalyst to do. For building a CD,
# we start with stage4 as our target.
@@ -34,7 +34,7 @@ profile: default/linux/amd64/2008.0/
# This specifies which snapshot to use for building this target.
# example:
-snapshot: 20080806
+snapshot: 20080816
# This specifies where the seed stage comes from for this target, The path is
# relative to $clst_sharedir/builds. The rel_type is also used as a path prefix# for the seed.
@@ -60,7 +60,7 @@ portage_confdir: /var/git/clustering-livecd/profiles/hpc-clustering/
# have used when building this target.
# example:
# portage_overlay: /usr/local/portage
-portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise
+portage_overlay: /var/git/clustering-livecd/overlay/ /var/svnroot/livecd-tools /usr/local/portage/layman/sunrise /usr/local/portage/layman/science
# This allows the optional directory containing the output packages for
# catalyst. Mainly used as a way for different spec files to access the same
@@ -84,11 +84,14 @@ pkgcache_path: /var/tmp/catalyst/packages/amd64
# Leaving this blank will default to the system use flags
# example:
# stage4/use: ipv6 socks5 fbcon ncurses readline ssl
+# -tk, -server for torque
stage4/use:
minimal
openmp
mpi
-
+ pbs
+ -tk
+ -server
# This is the set of packages that we will merge into the stage4 tarball. They
# will be built with the USE flags configured above. These packages must not
@@ -114,6 +117,7 @@ stage4/packages:
app-admin/eselect-cblas
app-admin/eselect-blas
app-admin/eselect-lapack
+
# A fsscript is simply a shell script that is copied into the chroot of the stage4
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec b/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
index a5c35e2..a182d44 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/stage1.spec
@@ -3,7 +3,7 @@ target: stage1
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0
-snapshot: 20080806
+snapshot: 20080816
source_subpath: drobbins/stage3-amd64-2008.06.27
# Kyron:
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec b/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec
index 9612e94..9aa22b0 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/stage2.spec
@@ -3,7 +3,7 @@ target: stage2
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage1-amd64-2008.0
# Kyron:
diff --git a/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec b/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec
index 4b86af8..f736964 100644
--- a/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec
+++ b/catalyst/nfsroot/2008.0/specs/amd64/stage3.spec
@@ -3,7 +3,7 @@ target: stage3
version_stamp: 2008.0
rel_type: default
profile: default/linux/amd64/2008.0/
-snapshot: 20080806
+snapshot: 20080816
source_subpath: default/stage2-amd64-2008.0
# Kyron: