aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-08-18 14:25:29 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-08-18 14:25:29 -0400
commit2b5da8cd75d578fb476ad5a15dda5f8f4ea9f020 (patch)
treed5803c358caccbad96af75d4d468fea83b4aa23f
parentAdded for the X-enabled livecd with the new snapshots (diff)
downloadclustering-livecd-2b5da8cd75d578fb476ad5a15dda5f8f4ea9f020.tar.gz
clustering-livecd-2b5da8cd75d578fb476ad5a15dda5f8f4ea9f020.tar.bz2
clustering-livecd-2b5da8cd75d578fb476ad5a15dda5f8f4ea9f020.zip
A crude snapshot switching script
NOTE: it does not compensate for the tag name defined in nfsroot-stage4.spec (that tag shouldn't be snapshot specific actually)
-rwxr-xr-xswitchshapshot.sh13
1 files changed, 13 insertions, 0 deletions
diff --git a/switchshapshot.sh b/switchshapshot.sh
new file mode 100755
index 0000000..9832641
--- /dev/null
+++ b/switchshapshot.sh
@@ -0,0 +1,13 @@
+#!/bin/bash
+
+if [[ $# != 1 ]]; then
+ echo "Specify snapshot to switch to, ie:
+$0 20080806"
+ exit 1
+fi
+
+for I in catalyst/livecd/2008.0/specs/amd64 catalyst/nfsroot/2008.0/specs/amd64
+do
+ sed -i -e "s#snapshot:.*#snapshot: $1#" ${I}/*.spec
+done
+