aboutsummaryrefslogtreecommitdiff
path: root/bin
diff options
context:
space:
mode:
authorW. Trevor King <wking@tremily.us>2013-06-05 13:13:43 -0400
committerBrian Dolbec <dolsen@gentoo.org>2014-02-22 10:30:31 -0800
commit46b261e967904262245c42322a96f0d7f2322a27 (patch)
tree44ccd4bdc2e22705fc5862ced02c1321a2aa6eca /bin
parentMove catalyst.conf and catalystrc to an etc/ directory (diff)
downloadcatalyst-46b261e967904262245c42322a96f0d7f2322a27.tar.gz
catalyst-46b261e967904262245c42322a96f0d7f2322a27.tar.bz2
catalyst-46b261e967904262245c42322a96f0d7f2322a27.zip
setup.py: Add disutils-based packaging
Package catalyst in the usual manner for Python projects. Now it is ready for PyPI :). I also expose the version string in catalyst.__version__ and the maintainer string in catalyst.__maintainer__, since those are more traditional locations. I dropped official Python 2.6 support following: 19:31 <@jmbsvicetto> I don't see a need to make catalyst incompatible with 2.6, but I think it's time we drop it as a "requirement". So feel free to do any changes that improve the code, even if they drop 2.6 compatibility I kept the explicit indexes in the string formatting, since Python 2.6 doesn't support: '{}'.format(value)
Diffstat (limited to 'bin')
-rwxr-xr-xbin/catalyst6
1 files changed, 2 insertions, 4 deletions
diff --git a/bin/catalyst b/bin/catalyst
index ace43fc7..19f5289f 100755
--- a/bin/catalyst
+++ b/bin/catalyst
@@ -12,10 +12,6 @@ from __future__ import print_function
import sys
-__maintainer__="Catalyst <catalyst@gentoo.org>"
-__version__="2.0.12.2"
-
-
# This block ensures that ^C interrupts are handled quietly.
try:
import signal
@@ -36,6 +32,8 @@ except KeyboardInterrupt:
from catalyst.main import main
+from catalyst import __maintainer__
+from catalyst import __version__
try:
main()