aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/Qt/tests/CMakeLists.txt')
-rw-r--r--src/Qt/tests/CMakeLists.txt34
1 files changed, 3 insertions, 31 deletions
diff --git a/src/Qt/tests/CMakeLists.txt b/src/Qt/tests/CMakeLists.txt
index 9c10387..a2b1e28 100644
--- a/src/Qt/tests/CMakeLists.txt
+++ b/src/Qt/tests/CMakeLists.txt
@@ -1,34 +1,6 @@
-find_package(Qt4 REQUIRED)
-include_directories(${QT_INCLUDE_DIR} ${QT_QTCORE_INCLUDE_DIR} ${QT_QTGUI_INCLUDE_DIR})
-remove_definitions(-std=c99)
-
-set(cpp-portage-tests_SRCS qlistconverter_test.cpp qpackageproperties_test.cpp qportagesettings_test.cpp )
-
add_executable(QtWrapperTest test.cpp)
+target_link_libraries(QtWrapperTest cpp-portage)
add_executable(QPackagepropertiesTest qpackageproperties_test.cpp)
+target_link_libraries(QPackagepropertiesTest cpp-portage)
add_executable(QPortagesettingsTest qportagesettings_test.cpp)
-
-
-set(test_EXECS QtWrapperTest QPackagepropertiesTest QPortagesettingsTest)
-target_link_libraries(QtWrapperTest ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
-target_link_libraries(QPackagepropertiesTest ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
-target_link_libraries(QPortagesettingsTest ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
-
-install(TARGETS QtWrapperTest QPackagepropertiesTest QPortagesettingsTest DESTINATION lib)
-
-
-
-#include_directories(${QT_INCLUDE_DIR} ${QT_QTCORE_INCLUDE_DIR})
-#remove_definitions(-std=c99)
-
-#set(cpp-portage_SRCS qportagesettings.cpp)
-#set(cpp-portage_HDRS qportagesettings.h)
-
-#QT4_WRAP_CPP(cpp-portage_MOC_SRCS ${cpp-portage_HDRS})
-
-#add_library(cpp-portage qportagesettings.cpp ${cpp-portage_MOC_SRCS})
-
-#install(TARGETS cpp-portage DESTINATION lib)
-#install(FILES ${cpp-portage_HDRS} DESTINATION include/cpp-portage)
-
-#add_subdirectory(tests) \ No newline at end of file
+target_link_libraries(QPortagesettingsTest cpp-portage)