aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheofilos Intzoglou <int.teo@gmail.com>2011-10-11 14:55:11 +0300
committerTheofilos Intzoglou <int.teo@gmail.com>2011-10-11 14:55:11 +0300
commitae40b3bc70886a26f6ec26fba31c30f23270ca8c (patch)
treee5e28a2556474e7f43404c1b298897cd45485d1b /src/Qt/tests/qpackageproperties_test.cpp
parentadd a readme and a TODO (diff)
downloadc-portage-ae40b3bc70886a26f6ec26fba31c30f23270ca8c.tar.gz
c-portage-ae40b3bc70886a26f6ec26fba31c30f23270ca8c.tar.bz2
c-portage-ae40b3bc70886a26f6ec26fba31c30f23270ca8c.zip
A couple of fixes on the CMakeLists and change the test programs to use QCoreApplication instead of QApplication as GUI isn't necessary for the tests
Diffstat (limited to 'src/Qt/tests/qpackageproperties_test.cpp')
-rw-r--r--src/Qt/tests/qpackageproperties_test.cpp11
1 files changed, 3 insertions, 8 deletions
diff --git a/src/Qt/tests/qpackageproperties_test.cpp b/src/Qt/tests/qpackageproperties_test.cpp
index efde5e7..b7e99ac 100644
--- a/src/Qt/tests/qpackageproperties_test.cpp
+++ b/src/Qt/tests/qpackageproperties_test.cpp
@@ -1,14 +1,9 @@
-#include <QApplication>
+#include <QCoreApplication>
#include <QDebug>
+#include <QStringList>
#include "../qpackageproperties.h"
-#include "../qpackageproperties.cpp"
#include "../qlistconverter.h"
-#include "../qlistconverter.cpp"
-#include <QStringList>
-namespace CppPortage {
-class QPackageProperties;
-}
using namespace CppPortage;
@@ -27,6 +22,6 @@ void test() {
int main(int argc, char *argv[])
{
test();
- QApplication app(argc, argv);
+ QCoreApplication app(argc, argv);
return app.exec();
} \ No newline at end of file