aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2021-10-02 23:57:53 -0400
committerMike Frysinger <vapier@gentoo.org>2021-10-02 23:57:53 -0400
commitbd29656622f75011e723c71880ebba5844f7f518 (patch)
tree9ffd1a91516b01b53ad149f70bf8f0128a739bf9 /Makefile
parentmake file updates atomic (diff)
downloadbuild-docbook-catalog-bd29656622f75011e723c71880ebba5844f7f518.tar.gz
build-docbook-catalog-bd29656622f75011e723c71880ebba5844f7f518.tar.bz2
build-docbook-catalog-bd29656622f75011e723c71880ebba5844f7f518.zip
update README & dist processv2.0
Now that we're in git, we can simplify things a lot. Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/Makefile b/Makefile
index b920de3..cb8634a 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,5 @@
-PN = build-docbook-catalog
-PV = $(shell awk '/^\# .Header:/{print $$4;exit}' build-docbook-catalog)
-P = $(PN)-$(PV)
+# Copyright 2004-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
all:
@@ -14,11 +13,4 @@ install:
install -d $(DESTDIR)$(SBINDIR)
install -m 755 build-docbook-catalog $(DESTDIR)$(SBINDIR)
-dist:
- rm -rf $(P)
- mkdir -p $(P)
- cp -pPR build-docbook-catalog Makefile README $(P)/
- tar --posix --owner 0 --group 0 -cf - $(P) | xz -9 > $(P).tar.xz
- rm -rf $(P)
-
-.PHONY: all clean dist install
+.PHONY: all clean install