summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/sparkleshare/sparkleshare-0.2.5.ebuild')
-rw-r--r--app-backup/sparkleshare/sparkleshare-0.2.5.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-backup/sparkleshare/sparkleshare-0.2.5.ebuild b/app-backup/sparkleshare/sparkleshare-0.2.5.ebuild
new file mode 100644
index 0000000..4ec9052
--- /dev/null
+++ b/app-backup/sparkleshare/sparkleshare-0.2.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit gnome2-utils
+
+DESCRIPTION="A collaboration and sharing tool that is designed to keep things simple and to stay out of your way."
+HOMEPAGE="http://sparkleshare.org/"
+SRC_URI="https://github.com/downloads/hbons/SparkleShare/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc libnotify nautilus"
+
+RDEPEND=">=dev-lang/mono-2.2
+ >=dev-dotnet/gtk-sharp-2.12.2
+ >=dev-dotnet/glib-sharp-2.12.2
+ libnotify? ( dev-dotnet/notify-sharp )
+ dev-dotnet/webkit-sharp
+ nautilus? ( dev-python/nautilus-python )
+ >=dev-vcs/git-1.7.1
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ doc? ( >=app-text/gnome-doc-utils-0.17.3 )"
+# appindicator? ( >=dev-dotnet/appindicator-sharp-0.0.7 )
+
+src_configure() {
+ local myconf
+ if use debug ; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --enable-release"
+ fi
+ econf ${myconf} || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS NEWS README || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}