summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-22 12:42:34 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-22 12:42:34 +0200
commite6378c0b80ebbe6b0e734663b6a411fb4cc3f1cb (patch)
treec556897a1ea37141939729408fc312882c92537a /dev-util
parentdev-cpp/curlpp: Fix SRC_URI (diff)
downloadbetagarden-e6378c0b80ebbe6b0e734663b6a411fb4cc3f1cb.tar.gz
betagarden-e6378c0b80ebbe6b0e734663b6a411fb4cc3f1cb.tar.bz2
betagarden-e6378c0b80ebbe6b0e734663b6a411fb4cc3f1cb.zip
dev-util/ohcount: Version Bump
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ohcount/Manifest2
-rw-r--r--dev-util/ohcount/metadata.xml4
-rw-r--r--dev-util/ohcount/ohcount-3.0.0.ebuild (renamed from dev-util/ohcount/ohcount-3.0.0_rc.ebuild)13
3 files changed, 11 insertions, 8 deletions
diff --git a/dev-util/ohcount/Manifest b/dev-util/ohcount/Manifest
index 589c46f..583ea44 100644
--- a/dev-util/ohcount/Manifest
+++ b/dev-util/ohcount/Manifest
@@ -1 +1 @@
-DIST ohcount3.0.0.rc.tar.gz 1300112 SHA256 0255a9c24464fcde243a59440ecb6d4d7910215333f0e9c34dc6e6816baf0521
+DIST ohcount-3.0.0.tar.gz 1191931 SHA256 46ef92e1bbf9313de507a03decaf8279173584555fb580bb3d46d42c65aa4a6d SHA512 6c314a7f1773495eb67cb2fec4c6006caa27d5e30154c04286f9582c0c4cfa06c6e07190524b8a2dbaeb5913277743075fcc351cf2b6775c8343fc7ca56b10c7 WHIRLPOOL b8da4ce30e2c79b3f31af59f1b3e108defdf11d2f2a0f588e69023ba26d6ee01563de87e63df061fdb7667673f3fc97f3fb78e161bbeec26025aa663a439447f
diff --git a/dev-util/ohcount/metadata.xml b/dev-util/ohcount/metadata.xml
index 31dc017..cc3fe24 100644
--- a/dev-util/ohcount/metadata.xml
+++ b/dev-util/ohcount/metadata.xml
@@ -1,5 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-util/ohcount/ohcount-3.0.0_rc.ebuild b/dev-util/ohcount/ohcount-3.0.0.ebuild
index f6ae0b9..7858f40 100644
--- a/dev-util/ohcount/ohcount-3.0.0_rc.ebuild
+++ b/dev-util/ohcount/ohcount-3.0.0.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=5
+
MY_PV=${PV/_/.}
MY_P="${PN}${MY_PV}"
DESCRIPTION="Source code line counter"
HOMEPAGE="http://labs.ohloh.net/ohcount"
-SRC_URI="http://d10xg45o6p6dbl.cloudfront.net/projects/o/${PN}/${MY_P}.tar.gz"
+SRC_URI="https://github.com/blackducksoftware/ohcount/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -15,17 +17,16 @@ KEYWORDS="~x86"
IUSE=""
# TODO RUBY dev-lang/swig
-RDEPEND="dev-util/ragel
+RDEPEND="
+ dev-util/ragel
dev-libs/libpcre"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN}"
-
src_compile() {
# TODO RUBY ./build ruby
./build ohcount || die './build failed'
}
src_install() {
- dobin bin/ohcount || die 'dobin failed'
+ dobin bin/ohcount
}