summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-21 11:23:51 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-21 11:23:51 +0100
commit7e3a3eb8d0fd6f2dfee1680b45fb53b4492a3282 (patch)
treee2088535bea264c91c8e9c971ecf4f46dfb41e06 /app-portage
parentapp-portage/gentwoo: Drop old (diff)
downloadbetagarden-7e3a3eb8d0fd6f2dfee1680b45fb53b4492a3282.tar.gz
betagarden-7e3a3eb8d0fd6f2dfee1680b45fb53b4492a3282.tar.bz2
betagarden-7e3a3eb8d0fd6f2dfee1680b45fb53b4492a3282.zip
app-portage/gentwoo: Bump to new python eclasses
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentwoo/gentwoo-0.0.20120705.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/app-portage/gentwoo/gentwoo-0.0.20120705.ebuild b/app-portage/gentwoo/gentwoo-0.0.20120705.ebuild
index 77c5eb4..32e3b12 100644
--- a/app-portage/gentwoo/gentwoo-0.0.20120705.ebuild
+++ b/app-portage/gentwoo/gentwoo-0.0.20120705.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-PYTHON_NEEDED="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+EAPI=5
-inherit python
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
DESCRIPTION="Client program for Social Compiling site GenTwoo"
HOMEPAGE="http://gentwoo.elisp.net"
@@ -18,16 +17,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="dev-python/simplejson"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/simplejson[${PYTHON_USEDEP}]"
src_install() {
- gentwoo_install() {
- python_convert_shebangs -- ${PYTHON_ABI} gentwoo.py
- newbin gentwoo.py gentwoo-${PYTHON_ABI}
- }
- python_execute_function gentwoo_install
- python_generate_wrapper_scripts "${ED}"usr/bin/gentwoo
+ python_foreach_impl python_newscript gentwoo.py gentwoo
insinto /etc
doins gentwoo.conf