summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2013-06-04 01:50:29 +0200
committerSebastian Pipping <sebastian@pipping.org>2013-06-04 01:57:01 +0200
commit988b8ba17abb56af6c333c6733eabe25637fcccf (patch)
tree27d3234146f04a98b9e548910891d41988dbcd71
parentdev-vcs/git-big-picture: 0.9.0 (diff)
downloadbetagarden-988b8ba17abb56af6c333c6733eabe25637fcccf.tar.gz
betagarden-988b8ba17abb56af6c333c6733eabe25637fcccf.tar.bz2
betagarden-988b8ba17abb56af6c333c6733eabe25637fcccf.zip
sys-fs/wrapfs: Integrate from sping overlay, include snapshot script and updated ebuild
-rw-r--r--sys-fs/wrapfs/Manifest4
-rwxr-xr-xsys-fs/wrapfs/files/extract-module-snapshot-tarball.sh97
-rw-r--r--sys-fs/wrapfs/metadata.xml8
-rw-r--r--sys-fs/wrapfs/wrapfs-0.1_p20101202.ebuild35
-rw-r--r--sys-fs/wrapfs/wrapfs-0.1_p20110704.ebuild31
-rw-r--r--sys-fs/wrapfs/wrapfs-0.1_p20111027.ebuild31
-rw-r--r--sys-fs/wrapfs/wrapfs-0.1_p20130604.ebuild31
7 files changed, 237 insertions, 0 deletions
diff --git a/sys-fs/wrapfs/Manifest b/sys-fs/wrapfs/Manifest
new file mode 100644
index 0000000..f8afae3
--- /dev/null
+++ b/sys-fs/wrapfs/Manifest
@@ -0,0 +1,4 @@
+DIST wrapfs-0.1_p20101202.tar.bz2 13611 SHA256 eeec82df15e89a6a21f6350f7621242a99d92132f42596ac2e5536a92c385a9a SHA512 e136db8e93d2438e28bb3e9e1630a9631d69c853a4fd0caa4d113701f4363c2bccff29472ac38c8308bec85c7fcab1ffdd4f2d2855f7cb565ee47ec892f4ad65 WHIRLPOOL aeab34ccfcff72b4c25e9baafe253aeea67f01e30705f99d119af58df55e8c654e63b0f6100dae6352c175f9d6f52f3eb089dc8868a300e05b38802994b1236e
+DIST wrapfs-0.1_p20110704.tar.bz2 13638 SHA256 98cb9802f73d51441dabffd4c9d5102a1de119388c0f277dec430251529aea78 SHA512 d01d8cc24264de1f845c2ba3db5d097c0564669014fc55891eac3e36e9cf847d7c1b38e3a6ca99d3d090bc6f55a91156fe8818b8b801e332cc5028db17abb034 WHIRLPOOL 99820f95d024f1d4396755a6b0cb1e683a11b224b4fd6eaeb0385d80c8dc6999cfeb875100150212fd8a0b8a6e5bd3ecb89e2e53e27292b96830b04525cedae0
+DIST wrapfs-0.1_p20111027.tar.bz2 13637 SHA256 043e168d2d7d8ae1a2da129c08664949c9ed4504a4de1805715f9175c886126c SHA512 bf7bb4d3cd91d3cf897a35fb5403c821e577c66ff77716f09c523cc54924933aa1845ecde3dccfd3840550ba958f7104f7f0202eb8116119b023c3d3b4bbe7ee WHIRLPOOL 6204e8650c92f8a68c1940badb8a491f87ee600d35fa172b5ba7dae5388c9d34b4c4094fd3b56e880fd29ac4540de57ac1d5ca5c2c863eb8c1b91c1afca4d3f5
+DIST wrapfs-0.1_p20130604.tar.xz 14184 SHA256 2eb86552cabe88e6703443f1a0ddcf3af61f4f1f1590f0a55c07b57c8f725e9b SHA512 802c2bc993d153131352dbd5450d333b21973f1691f36e257afb1453ba3ac4da64ca0f0b5c4dfd52d680ad152fd20f59376384ffd6396481e191a7d8dd1c9377 WHIRLPOOL 4a4abadcd5f0277c40a5c868f7bb9e664a87906ddf3740380ac97b51cf548e327ccc0d1223af19a476af2b443be7eab27b2539e4754691a810c8e457b121eed5
diff --git a/sys-fs/wrapfs/files/extract-module-snapshot-tarball.sh b/sys-fs/wrapfs/files/extract-module-snapshot-tarball.sh
new file mode 100755
index 0000000..882a602
--- /dev/null
+++ b/sys-fs/wrapfs/files/extract-module-snapshot-tarball.sh
@@ -0,0 +1,97 @@
+#! /usr/bin/env bash
+# Copyright (C) 2010-2013 Sebastian Pipping <sebastian@pipping.org>
+# Licensed under GPL v2 or later
+#
+# Purpose:
+# Makes a wrapfs snapshot tarball to allow distribution as a standlone kernel module
+#
+# Usage:
+# $ ./files/extract-module-snapshot-tarball.sh
+
+die() {
+ echo $@
+ exit 1
+}
+
+
+# Fetch latest sources from Git
+if [[ -d .wrapfs-latest ]]; then
+ cd .wrapfs-latest || die
+ git remote update || die
+ git checkout master || die
+ git reset --hard origin/master || die
+ echo
+else
+ git clone --depth 1 git://git.fsl.cs.sunysb.edu/wrapfs-latest.git .wrapfs-latest || die
+ echo
+ cd .wrapfs-latest || die
+fi
+
+
+# Ensure usable kernel version string
+if [[ ! -e include/config/kernel.release ]]; then
+ if [[ ! -e .config ]]; then
+ make allnoconfig || die
+ fi
+ make include/config/kernel.release || die
+ echo
+fi
+
+
+VERSION=$(/bin/grep '^WRAPFS_VERSION=' fs/wrapfs/Makefile | sed 's/WRAPFS_VERSION="\(.\+\)"/\1/')
+[ $(wc -l <<<"${VERSION}") == 1 ] || die 'grepping WRAPFS_VERSION failed'
+VERSION="${VERSION}_p$(date +'%Y%m%d')"
+DISTNAME="wrapfs-${VERSION}"
+TARBALL_NAME="${DISTNAME}".tar
+
+
+# Reset
+if [[ -n "${DISTNAME}" && -d "${DISTNAME}" ]]; then
+ echo 'Cleaning up...'
+ rm -Rfv "${DISTNAME}"
+ echo
+fi
+mkdir -p "${DISTNAME}" || die 'mkdir failed'
+
+
+# Code
+cp fs/wrapfs/*.{c,h} "${DISTNAME}"/ || die 'cp failed'
+
+# Patch: Integrate WRAPFS_SUPER_MAGIC
+wrapfs_super_magic_line=$(fgrep WRAPFS_SUPER_MAGIC include/uapi/linux/magic.h)
+[ $(wc -l <<<"${wrapfs_super_magic_line}") == 1 ] || die 'grepping WRAPFS_SUPER_MAGIC failed'
+sed 's|^#include "wrapfs.h"|&\n'"${wrapfs_super_magic_line}"'|' -i "${DISTNAME}"/super.c
+
+# Patch: Turn into module, update version
+sed \
+ -e 's|^WRAPFS_VERSION=.*|WRAPFS_VERSION="'"${VERSION}"'"|' \
+ -e 's|$(CONFIG_WRAP_FS)|m|' \
+ fs/wrapfs/Makefile \
+ > "${DISTNAME}"/Makefile
+
+# Docs
+cp Documentation/filesystems/wrapfs.txt "${DISTNAME}"/README || die 'cp failed'
+cp include/config/kernel.release "${DISTNAME}"/LINUX_VERSION || die 'cp failed'
+
+# Author and contact info
+fgrep -A6 WRAPFS MAINTAINERS > "${DISTNAME}"/AUTHORS
+
+# Install instructions
+cat <<-EOF >"${DISTNAME}"/INSTALL
+ tar -xvjf ${DISTNAME}.tar.xz
+ cd ${DISTNAME}
+ make -C /lib/modules/\`uname -r\`/build M=\`pwd\` modules
+ sudo make -C /lib/modules/\`uname -r\`/build M=\`pwd\` modules_install
+ sudo insmod /lib/modules/`uname -r`/extra/wrapfs.ko
+EOF
+
+
+# Archive
+echo 'Archiving...'
+rm -f ../"${TARBALL_NAME}"{,.xz}
+tar -cvf ../"${TARBALL_NAME}" "${DISTNAME}"
+xz ../"${TARBALL_NAME}"
+echo
+
+target_kernel=$(cat include/config/kernel.release)
+echo "Done. Target kernel is \"${target_kernel}\", tarball created at \"${TARBALL_NAME}.xz\"."
diff --git a/sys-fs/wrapfs/metadata.xml b/sys-fs/wrapfs/metadata.xml
new file mode 100644
index 0000000..16bcc9f
--- /dev/null
+++ b/sys-fs/wrapfs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-fs/wrapfs/wrapfs-0.1_p20101202.ebuild b/sys-fs/wrapfs/wrapfs-0.1_p20101202.ebuild
new file mode 100644
index 0000000..b346eff
--- /dev/null
+++ b/sys-fs/wrapfs/wrapfs-0.1_p20101202.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit eutils linux-mod
+
+DESCRIPTION="Stackable passthru file system for Linux."
+HOMEPAGE="http://wrapfs.filesystems.org/"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="wrapfs(extra:)"
+ BUILD_TARGETS="wrapfs.ko"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${S} modules"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-2.6.39.patch
+}
+
+src_install() {
+ dodoc AUTHORS README
+ linux-mod_src_install
+}
diff --git a/sys-fs/wrapfs/wrapfs-0.1_p20110704.ebuild b/sys-fs/wrapfs/wrapfs-0.1_p20110704.ebuild
new file mode 100644
index 0000000..d2bc46b
--- /dev/null
+++ b/sys-fs/wrapfs/wrapfs-0.1_p20110704.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit linux-mod
+
+DESCRIPTION="Stackable passthru file system for Linux."
+HOMEPAGE="http://wrapfs.filesystems.org/"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="wrapfs(extra:)"
+ BUILD_TARGETS="wrapfs.ko"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${S} modules"
+}
+
+src_install() {
+ dodoc AUTHORS README
+ linux-mod_src_install
+}
diff --git a/sys-fs/wrapfs/wrapfs-0.1_p20111027.ebuild b/sys-fs/wrapfs/wrapfs-0.1_p20111027.ebuild
new file mode 100644
index 0000000..d2bc46b
--- /dev/null
+++ b/sys-fs/wrapfs/wrapfs-0.1_p20111027.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit linux-mod
+
+DESCRIPTION="Stackable passthru file system for Linux."
+HOMEPAGE="http://wrapfs.filesystems.org/"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="wrapfs(extra:)"
+ BUILD_TARGETS="wrapfs.ko"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${S} modules"
+}
+
+src_install() {
+ dodoc AUTHORS README
+ linux-mod_src_install
+}
diff --git a/sys-fs/wrapfs/wrapfs-0.1_p20130604.ebuild b/sys-fs/wrapfs/wrapfs-0.1_p20130604.ebuild
new file mode 100644
index 0000000..19d701f
--- /dev/null
+++ b/sys-fs/wrapfs/wrapfs-0.1_p20130604.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit linux-mod
+
+DESCRIPTION="Stackable passthru file system for Linux."
+HOMEPAGE="http://wrapfs.filesystems.org/"
+SRC_URI="http://www.hartwork.org/public/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ MODULE_NAMES="wrapfs(extra:)"
+ BUILD_TARGETS="wrapfs.ko"
+ BUILD_PARAMS="-C ${KERNEL_DIR} M=${S} modules"
+}
+
+src_install() {
+ dodoc AUTHORS README
+ linux-mod_src_install
+}