summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-06-18 03:44:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-06-18 03:44:10 +0000
commit9bf723be41365505e137583b0a1e762a957e4e92 (patch)
treed478200dea58551195020316ec54dfccbaf952bb /Makefile
parentdrop /usr/local/share/{doc,man} ... if packages use these dirs, they can crea... (diff)
downloadbaselayout-9bf723be41365505e137583b0a1e762a957e4e92.tar.gz
baselayout-9bf723be41365505e137583b0a1e762a957e4e92.tar.bz2
baselayout-9bf723be41365505e137583b0a1e762a957e4e92.zip
install more skel dirs as required by fhs and our general usage
svn path=/trunk/; revision=3191
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 06a4aa76..eacd4f0f 100644
--- a/Makefile
+++ b/Makefile
@@ -27,19 +27,26 @@ endif
KEEP_DIRS-Linux += \
/dev \
- /sys
+ /sys \
+ /usr/src
KEEP_DIRS = $(KEEP_DIRS-$(OS)) \
/boot \
/etc/profile.d \
/home \
+ /media \
/mnt \
/proc \
+ /opt \
/root \
/usr/local/bin \
/usr/local/sbin \
+ /var/cache \
/var/empty \
+ /var/lib \
/var/lock \
- /var/run
+ /var/log \
+ /var/run \
+ /var/spool
all:
@@ -71,9 +78,9 @@ layout:
touch $(DESTDIR)/var/tmp/.keep
install -m 1777 -d $(DESTDIR)/tmp
touch $(DESTDIR)/tmp/.keep
+ -chgrp uucp $(DESTDIR)/var/lock
# FHS compatibility symlinks stuff
ln -snf /var/tmp $(DESTDIR)/usr/tmp
- ln -snf share/man $(DESTDIR)/usr/local/man
diststatus:
@if [ -z "$(PV)" ] ; then \